aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-04-03 06:56:15 +0800
committerpav <pav@FreeBSD.org>2007-04-03 06:56:15 +0800
commit85f93575663adb5a7fa7799d5b3b6bdb05f3eda7 (patch)
tree9444ec7f98d0f2faaf4734217466e921e7d27034 /astro
parentc12598153f1706af748413173a0b3dc1a5e4fed7 (diff)
downloadfreebsd-ports-gnome-85f93575663adb5a7fa7799d5b3b6bdb05f3eda7.tar.gz
freebsd-ports-gnome-85f93575663adb5a7fa7799d5b3b6bdb05f3eda7.tar.zst
freebsd-ports-gnome-85f93575663adb5a7fa7799d5b3b6bdb05f3eda7.zip
- Convert existing ports to a new bsd.tcl.mk order
PR: ports/109097 Submitted by: Martin Matuska <martin@matuska.org> Tested on: pointyhat exp-run
Diffstat (limited to 'astro')
-rw-r--r--astro/gpsman/Makefile2
-rw-r--r--astro/ptiger/Makefile2
-rw-r--r--astro/tclgeomap/Makefile2
-rw-r--r--astro/tkgeomap/Makefile3
-rw-r--r--astro/xeartk/Makefile2
5 files changed, 4 insertions, 7 deletions
diff --git a/astro/gpsman/Makefile b/astro/gpsman/Makefile
index 7ab1ce0dfea0..f7a90ba0e4e9 100644
--- a/astro/gpsman/Makefile
+++ b/astro/gpsman/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= david@catwhisker.org
COMMENT= A Tcl/Tk-based GPS management utility
#RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
-USE_TK= 84
+USE_TK_RUN= 84
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
NO_BUILD= yes
diff --git a/astro/ptiger/Makefile b/astro/ptiger/Makefile
index ec3201cca6b3..1124566c74cc 100644
--- a/astro/ptiger/Makefile
+++ b/astro/ptiger/Makefile
@@ -17,7 +17,7 @@ COMMENT= Displays U.S. Census Burea populated places on a map
LIB_DEPENDS= tkgeomap.0:${PORTSDIR}/astro/tkgeomap
USE_XLIB= yes
-USE_TK= yes
+USE_TK_RUN= yes
NO_BUILD= yes
post-patch:
diff --git a/astro/tclgeomap/Makefile b/astro/tclgeomap/Makefile
index d18c040d8eed..d0a1d4ea02d6 100644
--- a/astro/tclgeomap/Makefile
+++ b/astro/tclgeomap/Makefile
@@ -13,8 +13,6 @@ MASTER_SITES= SF/tkgeomap
MAINTAINER= infofarmer@FreeBSD.org
COMMENT= Read, manipulate and display geo data
-LIB_DEPENDS= tcl${USE_TCL}.1:${PORTSDIR}/lang/tcl${USE_TCL}
-
USE_TCL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} --with-tclinclude=${TCL_INCLUDEDIR} \
diff --git a/astro/tkgeomap/Makefile b/astro/tkgeomap/Makefile
index 183b0d0678bc..b4afd577a380 100644
--- a/astro/tkgeomap/Makefile
+++ b/astro/tkgeomap/Makefile
@@ -13,8 +13,7 @@ MASTER_SITES= SF
MAINTAINER= infofarmer@FreeBSD.org
COMMENT= Read, manipulate and display geo data
-LIB_DEPENDS= tclgeomap.0:${PORTSDIR}/astro/tclgeomap \
- tk${USE_TK}.1:${PORTSDIR}/x11-toolkits/tk${USE_TK}
+LIB_DEPENDS= tclgeomap.0:${PORTSDIR}/astro/tclgeomap
CONFIGURE_ARGS= --with-tclgeomap-include=${LOCALBASE}/include/tclgeomap --with-x \
--with-tcl=${TCL_LIBDIR} --with-tclinclude=${TCL_INCLUDEDIR} \
diff --git a/astro/xeartk/Makefile b/astro/xeartk/Makefile
index 0613d70b946c..7e47935b12f4 100644
--- a/astro/xeartk/Makefile
+++ b/astro/xeartk/Makefile
@@ -17,7 +17,7 @@ COMMENT= Small demo for tkgeomap
LIB_DEPENDS= tkgeomap.0:${PORTSDIR}/astro/tkgeomap
USE_XLIB= yes
-USE_TK= yes
+USE_TK_RUN= yes
NO_BUILD= yes
DATA_FILES= README cities land.xdr rivers.xdr water.xdr
PLIST_FILES= bin/${PORTNAME} ${DATA_FILES:S,^,%%DATADIR%%/,}