aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2016-08-24 16:20:31 +0800
committertcberner <tcberner@FreeBSD.org>2016-08-24 16:20:31 +0800
commita5fddeafcdb2cab1016827038e317a262dad4857 (patch)
treeb9dc00f333e96550a5732b38b9c9444035e4339c /astro
parent3832b190ef3ea2bbefdd61450bff8af422a2e9ae (diff)
downloadfreebsd-ports-gnome-a5fddeafcdb2cab1016827038e317a262dad4857.tar.gz
freebsd-ports-gnome-a5fddeafcdb2cab1016827038e317a262dad4857.tar.zst
freebsd-ports-gnome-a5fddeafcdb2cab1016827038e317a262dad4857.zip
Replace Mk/bsd.kde4.mk by Mk/Uses/kde.mk in preparation for KDE Frameworks and
Plasma5 ports At the moment KDE ports use bsd.kde4.mk to handle their dependencies. When working on the ports for KDE Frameworks and Plasma5 it seemed to be more reasonable to create a new kde.mk instead of adding an bsd.kde5.mk. The kde.mk in this review is a stripped down version of the one we are using in the KDE Test repositories plasma5 branch [1] to only contain the parts relevant to the current KDE4 ports in the portstree [2]. Changes to the KDE Ports needed by this: Replace USE_KDE4 by USE_KDE [3] Add USES=kde:4 [4] [1] http://src.mouf.net/area51/view/branches/plasma5/KDE/Mk/Uses/kde.mk [2] The version in the plasma5 branch also handles frameworks/plasma5 and handles MASTER_SITES via a KDE_DIST variable similar to bsd.qt.mk for Qt Ports -- I chose to leave this out for now, as the diff is already large enough. [3] I chose USE_KDE instead of USE_KDE4, USE_KDE5, USE_KDEX as the version we want is already specified as argument to kde:<arg> [4] For KDE Frameworks and Plasma5 ports this would be kde:5 PR: 210667 Approved by: portmgr, mat (mentor), rakuco (mentor) Reviewed by: mat, rakuco Differential Revision: https://reviews.freebsd.org/D6961
Diffstat (limited to 'astro')
-rw-r--r--astro/kstars/Makefile6
-rw-r--r--astro/libkgeomap/Makefile4
-rw-r--r--astro/marble/Makefile4
3 files changed, 7 insertions, 7 deletions
diff --git a/astro/kstars/Makefile b/astro/kstars/Makefile
index bbd19d7f0e75..aa4597a2e3ae 100644
--- a/astro/kstars/Makefile
+++ b/astro/kstars/Makefile
@@ -16,13 +16,13 @@ BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen3.pc:math/eigen3 \
xplanet:astro/xplanet
RUN_DEPENDS= xplanet:astro/xplanet
-USE_KDE4= kdelibs automoc4
-USES= cmake:outsource compiler:c++11-lib tar:xz
+USES= cmake:outsource compiler:c++11-lib kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= opengl qmake_build moc_build rcc_build uic_build
OPTIONS_DEFINE= PYKDE
PYKDE_DESC= Support for updating supernovae data
-PYKDE_USE= KDE4=pykde4_run
+PYKDE_USE= KDE=pykde4_run
.include <bsd.port.mk>
diff --git a/astro/libkgeomap/Makefile b/astro/libkgeomap/Makefile
index 2b525ef80c2c..137b76d5371d 100644
--- a/astro/libkgeomap/Makefile
+++ b/astro/libkgeomap/Makefile
@@ -14,8 +14,8 @@ LICENSE_COMB= multi
BUILD_DEPENDS= ${LOCALBASE}/include/boost/graph/buffer_concepts.hpp:devel/boost-libs
-USE_KDE4= kdelibs automoc4 marble
-USES= cmake:outsource pathfix tar:xz
+USES= cmake:outsource kde:4 pathfix tar:xz
+USE_KDE= kdelibs automoc4 marble
USE_LDCONFIG= yes
USE_QT4= network phonon xml moc_build qmake_build rcc_build uic_build
diff --git a/astro/marble/Makefile b/astro/marble/Makefile
index c9384bb5e796..b995df8d2d39 100644
--- a/astro/marble/Makefile
+++ b/astro/marble/Makefile
@@ -11,8 +11,8 @@ COMMENT= Virtual globe and world atlas for KDE
LIB_DEPENDS= libquazip.so:archivers/quazip
-USE_KDE4= kdelibs automoc4
-USES= cmake:outsource gmake shared-mime-info tar:xz
+USES= cmake:outsource gmake kde:4 shared-mime-info tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= corelib dbus declarative designer_build gui network phonon \
qtestlib script sql svg webkit xml \
qmake_build moc_build rcc_build uic_build