aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2012-08-04 15:14:25 +0800
committerwen <wen@FreeBSD.org>2012-08-04 15:14:25 +0800
commitaeb095b0b29df8be5090803925ca48f0fdb22a9f (patch)
treef56f87d87c390eae7a9dead153a4fd625782abe3 /astro
parent26f9f03d00c11dada11c6d0e47eff6f537d5353c (diff)
downloadfreebsd-ports-gnome-aeb095b0b29df8be5090803925ca48f0fdb22a9f.tar.gz
freebsd-ports-gnome-aeb095b0b29df8be5090803925ca48f0fdb22a9f.tar.zst
freebsd-ports-gnome-aeb095b0b29df8be5090803925ca48f0fdb22a9f.zip
Starlink::AST provides a perl wrapper to the Starlink AST library.
The Starlink AST library provides facilities for transforming coordinates from one system to another in an object oriented manner. Multiple coordinate frames can be associated with a data set and it is also possible to generate automatic mappings between frames. Coordinate frame objects can be imported from FITS headers and from NDF files. WWW: http://search.cpan.org/dist/Starlink-AST/
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/p5-Starlink-AST/Makefile28
-rw-r--r--astro/p5-Starlink-AST/distinfo2
-rw-r--r--astro/p5-Starlink-AST/pkg-descr10
-rw-r--r--astro/p5-Starlink-AST/pkg-plist10
5 files changed, 51 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 69c9beffcab7..7c648b86fab6 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -74,6 +74,7 @@
SUBDIR += p5-GPS-OID
SUBDIR += p5-Geo-METAR
SUBDIR += p5-Misc-Quality
+ SUBDIR += p5-Starlink-AST
SUBDIR += p5-Weather-Underground
SUBDIR += p5-ZConf-Weather
SUBDIR += phoon
diff --git a/astro/p5-Starlink-AST/Makefile b/astro/p5-Starlink-AST/Makefile
new file mode 100644
index 000000000000..97c0f00db61e
--- /dev/null
+++ b/astro/p5-Starlink-AST/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Starlink-AST
+# Date created: 2012-07-01
+# Whom: Wen Heping<wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Starlink-AST
+PORTVERSION= 1.02
+CATEGORIES= astro perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:TJENNESS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Interface to the Starlink AST library
+
+BUILD_DEPENDS= p5-Test-Number-Delta>=0:${PORTSDIR}/devel/p5-Test-Number-Delta
+RUN_DEPENDS= p5-Test-Number-Delta>=0:${PORTSDIR}/devel/p5-Test-Number-Delta
+
+PERL_MODBUILD= yes
+
+MAN3= Starlink::AST.3 \
+ Starlink::AST::PGPLOT.3 \
+ Starlink::AST::Tk.3 \
+ Starlink::AST::PLplot.3
+
+.include <bsd.port.mk>
diff --git a/astro/p5-Starlink-AST/distinfo b/astro/p5-Starlink-AST/distinfo
new file mode 100644
index 000000000000..e94085491a77
--- /dev/null
+++ b/astro/p5-Starlink-AST/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Starlink-AST-1.02.tar.gz) = 8669ce97f8f35e3e7a32b052bf25243cb200fd02ec47b58c090ae940d2bdcde2
+SIZE (Starlink-AST-1.02.tar.gz) = 5371426
diff --git a/astro/p5-Starlink-AST/pkg-descr b/astro/p5-Starlink-AST/pkg-descr
new file mode 100644
index 000000000000..44fd33d64e31
--- /dev/null
+++ b/astro/p5-Starlink-AST/pkg-descr
@@ -0,0 +1,10 @@
+Starlink::AST provides a perl wrapper to the Starlink AST library.
+The Starlink AST library provides facilities for transforming coordinates
+from one system to another in an object oriented manner. Multiple
+coordinate frames can be associated with a data set and it is also
+possible to generate automatic mappings between frames.
+
+Coordinate frame objects can be imported from FITS headers and from
+NDF files.
+
+WWW: http://search.cpan.org/dist/Starlink-AST/
diff --git a/astro/p5-Starlink-AST/pkg-plist b/astro/p5-Starlink-AST/pkg-plist
new file mode 100644
index 000000000000..513b1f6d7654
--- /dev/null
+++ b/astro/p5-Starlink-AST/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Starlink/AST/AST.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Starlink/AST/AST.so
+%%SITE_PERL%%/%%PERL_ARCH%%/Starlink/AST/Tk.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Starlink/AST/PGPLOT.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Starlink/AST/PLplot.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Starlink/AST.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Starlink/AST
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Starlink
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Starlink/AST
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Starlink