aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2006-01-11 21:02:37 +0800
committernovel <novel@FreeBSD.org>2006-01-11 21:02:37 +0800
commitc34c197381300083538f747029ea425771a3b6f5 (patch)
tree076fb9e3f2baf0fe83eccd4a15f970283ab6c7db /astro
parentd87052c3ddecf4a66fd34baf3679ac70e968fa65 (diff)
downloadfreebsd-ports-gnome-c34c197381300083538f747029ea425771a3b6f5.tar.gz
freebsd-ports-gnome-c34c197381300083538f747029ea425771a3b6f5.tar.zst
freebsd-ports-gnome-c34c197381300083538f747029ea425771a3b6f5.zip
gpsd is a service daemon that monitors one or more GPSes
attached to a host computer through serial or USB ports, making all data on the location/course/velocity of the sensors available to be queried on TCP port 2947 of the host computer. With gpsd, multiple GPS client applications (such as navigational and wardriving software) can share access to GPSes without contention or loss of data. Also, gpsd responds to queries with a format that is substantially easier to parse than the NMEA 0183 emitted by most GPSes. WWW: http://gpsd.berlios.de/ PR: ports/91630 Submitted by: Anton Karpov <toxa@toxahost.ru>
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/gpsd/Makefile114
-rw-r--r--astro/gpsd/distinfo3
-rw-r--r--astro/gpsd/files/pkg-message.in9
-rw-r--r--astro/gpsd/pkg-descr11
-rw-r--r--astro/gpsd/pkg-plist17
6 files changed, 155 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 4864ddc59204..ed4959c7043f 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -15,6 +15,7 @@
SUBDIR += gkrellmoon2
SUBDIR += gkrellsun
SUBDIR += glunarclock
+ SUBDIR += gpsd
SUBDIR += gpsdrive
SUBDIR += gpsman
SUBDIR += jday
diff --git a/astro/gpsd/Makefile b/astro/gpsd/Makefile
new file mode 100644
index 000000000000..e1713a73b99c
--- /dev/null
+++ b/astro/gpsd/Makefile
@@ -0,0 +1,114 @@
+# New ports collection makefile for: gpsd
+# Date created: Jan, 10. 2006
+# Whom: Anton Karpov <toxa@toxahost.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gpsd
+PORTVERSION= 2.30
+CATEGORIES= astro
+MASTER_SITES= http://download.berlios.de/${PORTNAME}/
+
+MAINTAINER= toxa@toxahost.ru
+COMMENT= Daemon that monitors one or more GPSes attached to a host computer
+
+GNU_CONFIGURE= yes
+MAN1= gpsfake.1 gpsflash.1 gpspipe.1 gpsprof.1 rtcmdecode.1 sirfmon.1 xgps.1
+MAN3= libgps.3 libgpsd.3 libgpsmm.3
+MAN5= rtcm-104.5 srec.5
+MAN8= gpsd.8
+MANCOMPRESSED= no
+
+OPTIONS= XGPS "Build xgps and xgpsspeed (require X)" off \
+ NMEA "NMEA support" on \
+ SIRFII "SiRF-II chipset support" on \
+ TSIP "Trimble TSIP support" on \
+ FV18 "San Jose Navigation FV-18 support" on \
+ TRIPMATE "DeLorme TripMate support" on \
+ EARTHMATE "DeLorme EarthMate Zodiac support" on \
+ ITRAX "iTrax support" on \
+ ITALK "iTalk support" on \
+ TNT "True North Technologies support" off \
+ EVERMORE "Evermore binary support" on \
+ RTCM104 "rtcm104 support" on \
+ NTPSHM "TP time hinting support" on \
+ PPS "PPS time syncing support" off \
+ DBUS "DBUS support" off
+
+.include <bsd.port.pre.mk>
+
+SUB_FILES= pkg-message
+CONFIGURE_ARGS+=--disable-garmin
+
+INSTALLS_SHLIB= yes
+
+.if defined(WITH_XGPS)
+CONFIGURE_ARGS+=--with-x
+USE_XLIB=yes
+PLIST_SUB+= X11=""
+.else
+CONFIGURE_ARGS+=--without-x
+PLIST_SUB+= X11="@comment "
+.endif
+
+.if defined(WITHOUT_NMEA)
+CONFIGURE_ARGS+=--disable-nmea
+.endif
+
+.if defined(WITHOUT_SIRFII)
+CONFIGURE_ARGS+=--disable-sirfII
+.endif
+
+.if defined(WITHOUT_TSIP)
+CONFIGURE_ARGS+=--disable-tsip
+.endif
+
+.if defined(WITHOUT_FV18)
+CONFIGURE_ARGS+=--disable-fv18
+.endif
+
+.if defined(WITHOUT_TRIPMATE)
+CONFIGURE_ARGS+=--disable-tripmate
+.endif
+
+.if defined(WITHOUT_EARTHMATE)
+CONFIGURE_ARGS+=--disable-earthmate
+.endif
+
+.if defined(WITHOUT_ITRAX)
+CONFIGURE_ARGS+=--disable-itrax
+.endif
+
+.if defined(WITHOUT_ITALK)
+CONFIGURE_ARGS+=--disable-italk
+.endif
+
+.if defined(WITH_TNT)
+CONFIGURE_ARGS+=--enable-tnt
+.endif
+
+.if defined(WITHOUT_EVERMORE)
+CONFIGURE_ARGS+=--disable-evermore
+.endif
+
+.if defined(WITHOUT_RTCM104)
+CONFIGURE_ARGS+=--disable-rtcm104
+.endif
+
+.if defined(WITHOUT_NTPSHM)
+CONFIGURE_ARGS+=--disable-ntpshm
+.endif
+
+.if defined(WITH_PPS)
+CONFIGURE_ARGS+=--enable-pps
+.endif
+
+.if defined(WITH_DBUS)
+CONFIGURE_ARGS+=--enable-dbus
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/astro/gpsd/distinfo b/astro/gpsd/distinfo
new file mode 100644
index 000000000000..ac867eea12ea
--- /dev/null
+++ b/astro/gpsd/distinfo
@@ -0,0 +1,3 @@
+MD5 (gpsd-2.30.tar.gz) = dde177174878e8ae6db15f8010da46dd
+SHA256 (gpsd-2.30.tar.gz) = 9ae74f2ed87a457b53ae1b0150ec44a82e8bd453b26653249f9cf95e622026e2
+SIZE (gpsd-2.30.tar.gz) = 605997
diff --git a/astro/gpsd/files/pkg-message.in b/astro/gpsd/files/pkg-message.in
new file mode 100644
index 000000000000..706e12cf9a55
--- /dev/null
+++ b/astro/gpsd/files/pkg-message.in
@@ -0,0 +1,9 @@
+=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=
+* NOTE:
+
+%%PREFIX%%/bin/gpsfake and %%PREFIX%%/bin/gpsprof
+are Python script text executables.
+To use them, please ensure you have appropriate
+Python install.
+
+=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=
diff --git a/astro/gpsd/pkg-descr b/astro/gpsd/pkg-descr
new file mode 100644
index 000000000000..8cbcb0aeb9fb
--- /dev/null
+++ b/astro/gpsd/pkg-descr
@@ -0,0 +1,11 @@
+gpsd is a service daemon that monitors one or more GPSes
+attached to a host computer through serial or USB ports,
+making all data on the location/course/velocity of the
+sensors available to be queried on TCP port 2947 of the
+host computer. With gpsd, multiple GPS client applications
+(such as navigational and wardriving software) can share
+access to GPSes without contention or loss of data. Also,
+gpsd responds to queries with a format that is substantially
+easier to parse than the NMEA 0183 emitted by most GPSes.
+
+WWW: http://gpsd.berlios.de/
diff --git a/astro/gpsd/pkg-plist b/astro/gpsd/pkg-plist
new file mode 100644
index 000000000000..8d631028d618
--- /dev/null
+++ b/astro/gpsd/pkg-plist
@@ -0,0 +1,17 @@
+%%X11%%bin/xgpsspeed
+%%X11%%bin/xgps
+sbin/gpsd
+bin/cgps
+bin/gpsflash
+bin/gpsprof
+bin/sirfmon
+bin/gpsfake
+bin/gpspipe
+bin/rtcmdecode
+include/gps.h
+include/gpsd.h
+include/libgpsmm.h
+lib/libgps.a
+lib/libgps.la
+lib/libgps.so
+lib/libgps.so.15