aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-10-20 03:34:43 +0800
committerijliao <ijliao@FreeBSD.org>2002-10-20 03:34:43 +0800
commite2b2e7063bf922e20093e92b2a581cb28be5e3f0 (patch)
treef931540e6e6865d0aceb15c854b94fdd8d056819 /astro
parentee012e5607887b21203ca6ea2e682be95b898140 (diff)
downloadfreebsd-ports-gnome-e2b2e7063bf922e20093e92b2a581cb28be5e3f0.tar.gz
freebsd-ports-gnome-e2b2e7063bf922e20093e92b2a581cb28be5e3f0.tar.zst
freebsd-ports-gnome-e2b2e7063bf922e20093e92b2a581cb28be5e3f0.zip
add p5-Astro-SIMBAD 1.9.3
An OO Perl interface to the SIMBAD astronomical database
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/p5-Astro-SIMBAD/Makefile30
-rw-r--r--astro/p5-Astro-SIMBAD/distinfo1
-rw-r--r--astro/p5-Astro-SIMBAD/pkg-comment1
-rw-r--r--astro/p5-Astro-SIMBAD/pkg-descr3
-rw-r--r--astro/p5-Astro-SIMBAD/pkg-plist9
6 files changed, 45 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 603b4759d4af..000e664a4a76 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -24,6 +24,7 @@
SUBDIR += openuniverse
SUBDIR += p5-Astro-ADS
SUBDIR += p5-Astro-MoonPhase
+ SUBDIR += p5-Astro-SIMBAD
SUBDIR += p5-Astro-SunTime
SUBDIR += p5-Astro-Sunrise
SUBDIR += p5-GPS
diff --git a/astro/p5-Astro-SIMBAD/Makefile b/astro/p5-Astro-SIMBAD/Makefile
new file mode 100644
index 000000000000..7e33d595c148
--- /dev/null
+++ b/astro/p5-Astro-SIMBAD/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: Astro-SIMBAD
+# Date created: Oct 19, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= Astro-SIMBAD
+PORTVERSION= 1.9.3
+CATEGORIES= astro perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
+ http://www.astro.ex.ac.uk/estar/software/
+MASTER_SITE_SUBDIR= Astro
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Astro::SIMBAD::Query.3 \
+ Astro::SIMBAD::Result.3 \
+ Astro::SIMBAD::Result::Object.3
+
+.include <bsd.port.mk>
diff --git a/astro/p5-Astro-SIMBAD/distinfo b/astro/p5-Astro-SIMBAD/distinfo
new file mode 100644
index 000000000000..1ea907d30de4
--- /dev/null
+++ b/astro/p5-Astro-SIMBAD/distinfo
@@ -0,0 +1 @@
+MD5 (Astro-SIMBAD-1.9.3.tar.gz) = 2c56eeeb3fbab101c7ad9e38ee0e84e1
diff --git a/astro/p5-Astro-SIMBAD/pkg-comment b/astro/p5-Astro-SIMBAD/pkg-comment
new file mode 100644
index 000000000000..b4f52f5394f8
--- /dev/null
+++ b/astro/p5-Astro-SIMBAD/pkg-comment
@@ -0,0 +1 @@
+An OO Perl interface to the SIMBAD astronomical database
diff --git a/astro/p5-Astro-SIMBAD/pkg-descr b/astro/p5-Astro-SIMBAD/pkg-descr
new file mode 100644
index 000000000000..396f1873dd0d
--- /dev/null
+++ b/astro/p5-Astro-SIMBAD/pkg-descr
@@ -0,0 +1,3 @@
+The Astro::SIMBAD module is an objected orientated Perl interface to the
+SIMBAD astronomical database. SIMBAD provides basic data, cross-identifications
+and bibliography for astronomical objects outside the solar system.
diff --git a/astro/p5-Astro-SIMBAD/pkg-plist b/astro/p5-Astro-SIMBAD/pkg-plist
new file mode 100644
index 000000000000..ffa6f4a2d062
--- /dev/null
+++ b/astro/p5-Astro-SIMBAD/pkg-plist
@@ -0,0 +1,9 @@
+lib/perl5/site_perl/%%PERL_VER%%/Astro/SIMBAD/Query.pm
+lib/perl5/site_perl/%%PERL_VER%%/Astro/SIMBAD/Result.pm
+lib/perl5/site_perl/%%PERL_VER%%/Astro/SIMBAD/Result/Object.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Astro/SIMBAD/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Astro/SIMBAD/Result
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Astro/SIMBAD
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Astro/SIMBAD
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Astro 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Astro 2>/dev/null || true