aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-08-03 16:45:51 +0800
committeraz <az@FreeBSD.org>2013-08-03 16:45:51 +0800
commitf8d84df2018f0071d586d8c74fe89b3ebe61cbfc (patch)
treebea626d8d7aaa3973f00760684b26d2ddcce74eb /astro
parent5ff0965a6a20416caf6012b02767e66ac0694085 (diff)
downloadfreebsd-ports-gnome-f8d84df2018f0071d586d8c74fe89b3ebe61cbfc.tar.gz
freebsd-ports-gnome-f8d84df2018f0071d586d8c74fe89b3ebe61cbfc.tar.zst
freebsd-ports-gnome-f8d84df2018f0071d586d8c74fe89b3ebe61cbfc.zip
- Convert to new perl framework
- Trim Makefile header
Diffstat (limited to 'astro')
-rw-r--r--astro/gpsdrive/Makefile2
-rw-r--r--astro/nightfall/Makefile3
2 files changed, 2 insertions, 3 deletions
diff --git a/astro/gpsdrive/Makefile b/astro/gpsdrive/Makefile
index 35cb6db9c7c3..f260442c4f2b 100644
--- a/astro/gpsdrive/Makefile
+++ b/astro/gpsdrive/Makefile
@@ -15,10 +15,10 @@ LICENSE= GPLv2
LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+USES= perl5
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
USE_GNOME= gtk20
-USE_PERL5= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/astro/nightfall/Makefile b/astro/nightfall/Makefile
index f79499fd49de..78827bc6f375 100644
--- a/astro/nightfall/Makefile
+++ b/astro/nightfall/Makefile
@@ -14,9 +14,8 @@ OPTIONS_DEFINE= GNOME PGPLOT OPENGL
OPTIONS_DEFAULT= PGPLOT OPENGL
PGPLOT_DESC= Enable PGPLOT support
-USES= pathfix gettext
+USES= pathfix gettext perl5
USE_GNOME= gnomehier gtk20
-USE_PERL5= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include