aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-08-03 00:55:05 +0800
committeraz <az@FreeBSD.org>2013-08-03 00:55:05 +0800
commit5c2e842fc7ce547433d4ce95f42e0ce3633edd87 (patch)
treeb1748a305f1fbeae4e79b80ce1f77251f519c987 /astro
parent296211a7fdac688e501bb9908ae965e72fa8fc45 (diff)
downloadfreebsd-ports-gnome-5c2e842fc7ce547433d4ce95f42e0ce3633edd87.tar.gz
freebsd-ports-gnome-5c2e842fc7ce547433d4ce95f42e0ce3633edd87.tar.zst
freebsd-ports-gnome-5c2e842fc7ce547433d4ce95f42e0ce3633edd87.zip
- Convert to new perl framework
- Trim Makefile header
Diffstat (limited to 'astro')
-rw-r--r--astro/p5-Astro-FITS-CFITSIO/Makefile3
-rw-r--r--astro/p5-Astro-SpaceTrack/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/astro/p5-Astro-FITS-CFITSIO/Makefile b/astro/p5-Astro-FITS-CFITSIO/Makefile
index 9c1bd940a413..a31dfe0f3f57 100644
--- a/astro/p5-Astro-FITS-CFITSIO/Makefile
+++ b/astro/p5-Astro-FITS-CFITSIO/Makefile
@@ -13,7 +13,8 @@ COMMENT= Perl extension for using the cfitsio library
LIB_DEPENDS= cfitsio:${PORTSDIR}/astro/cfitsio
CONFIGURE_ENV= CFITSIO=${LOCALBASE}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Astro::FITS::CFITSIO.3
diff --git a/astro/p5-Astro-SpaceTrack/Makefile b/astro/p5-Astro-SpaceTrack/Makefile
index 3fae034f7740..8343c143584f 100644
--- a/astro/p5-Astro-SpaceTrack/Makefile
+++ b/astro/p5-Astro-SpaceTrack/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_ARGS= -y
MAN1= SpaceTrack.1