aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2006-01-05 04:32:16 +0800
committeredwin <edwin@FreeBSD.org>2006-01-05 04:32:16 +0800
commit8d012a98f04a5b2f6e7cb0811c367b12e2a9fa09 (patch)
tree980c0c97d936ad93809984ceb63ac61b50bcef71 /astro
parent338f49b315721e0ff6905cce5ec0b4e76abc106c (diff)
downloadfreebsd-ports-gnome-8d012a98f04a5b2f6e7cb0811c367b12e2a9fa09.tar.gz
freebsd-ports-gnome-8d012a98f04a5b2f6e7cb0811c367b12e2a9fa09.tar.zst
freebsd-ports-gnome-8d012a98f04a5b2f6e7cb0811c367b12e2a9fa09.zip
xglobe does not show markers
When you compile xglobe from ports and start it with xglobe -markers it does not show the markers. PR: ports/82270 Submitted by: Florian Smeets <flo@kasimir.com> Reviewed by: edwin@FreeBSD.org Approved by: maintainer timeout
Diffstat (limited to 'astro')
-rw-r--r--astro/xglobe/Makefile2
-rw-r--r--astro/xglobe/files/patch-renderer.cpp13
2 files changed, 12 insertions, 3 deletions
diff --git a/astro/xglobe/Makefile b/astro/xglobe/Makefile
index bd7b625d29f8..0bcec80242bc 100644
--- a/astro/xglobe/Makefile
+++ b/astro/xglobe/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xglobe
PORTVERSION= 0.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= astro
MASTER_SITES= ftp://quatramaran.ens.fr/pub/espie/
diff --git a/astro/xglobe/files/patch-renderer.cpp b/astro/xglobe/files/patch-renderer.cpp
index ae0ec071695c..de20cc228a18 100644
--- a/astro/xglobe/files/patch-renderer.cpp
+++ b/astro/xglobe/files/patch-renderer.cpp
@@ -1,5 +1,14 @@
---- renderer.cpp.orig Mon Dec 6 17:13:35 1999
-+++ renderer.cpp Sun Jan 26 09:32:22 2003
+--- renderer.cpp.orig Tue Dec 7 03:13:35 1999
++++ renderer.cpp Wed Jan 4 23:17:40 2006
+@@ -1434,7 +1434,7 @@
+
+ for(wx=0 ; wx<visiblerect.width(); wx++)
+ {
+- switch(*src++)
++ switch((*src++)&0x00FFFFFF)
+ {
+ case 0x00000000:
+ *dest++ = 0;
@@ -1483,8 +1483,8 @@
labelstring.sprintf("%s, %s %d. %d, %d:%02d %s\n"
"View pos %2.2f° %c %2.2f° %c\n"