aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2012-06-06 02:27:14 +0800
committerrene <rene@FreeBSD.org>2012-06-06 02:27:14 +0800
commit98e2bf0c69b73fa3f2771a8d4a247c53b5382e0f (patch)
tree98e1ddd3b5909620617817a823c6f80317f7b351 /astro
parent36aed8511c49b86e6d59495101c5b94505fb065b (diff)
downloadfreebsd-ports-gnome-98e2bf0c69b73fa3f2771a8d4a247c53b5382e0f.tar.gz
freebsd-ports-gnome-98e2bf0c69b73fa3f2771a8d4a247c53b5382e0f.tar.zst
freebsd-ports-gnome-98e2bf0c69b73fa3f2771a8d4a247c53b5382e0f.zip
- convert to optionsNG
- strip version information from LIB_DEPENDS to pet portlint - include bsd.port.mk instead of bsd.port.{pre|post}.mk
Diffstat (limited to 'astro')
-rw-r--r--astro/boinc-setiathome-enhanced/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/astro/boinc-setiathome-enhanced/Makefile b/astro/boinc-setiathome-enhanced/Makefile
index 5003556e457f..3281ee1eef02 100644
--- a/astro/boinc-setiathome-enhanced/Makefile
+++ b/astro/boinc-setiathome-enhanced/Makefile
@@ -38,13 +38,17 @@ BOINC_CLIENT_USER?= boinc
BOINC_CLIENT_GROUP?= nobody
BOINC_CLIENT_HOME?= /var/db/boinc
-OPTIONS= X11 "Build screensaver (requires net/boinc-client with X11)" off
+OPTIONS_DEFINE= X11
-.include <bsd.port.pre.mk>
+X11_DESC= Build screensaver (requires net/boinc-client with X11)
-.if !defined(WITHOUT_X11)
-LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg \
- xcb.2:${PORTSDIR}/x11/libxcb
+OPTIONS_DEFAULT=
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MX11}
+LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg \
+ xcb:${PORTSDIR}/x11/libxcb
USE_GL= gl glu glut
USE_XORG= ice sm x11 xau xext xi xdamage xdmcp xfixes xmu xt xxf86vm
BUILD_DEPENDS+= ${LOCALBASE}/lib/libboinc_graphics2.a:${PORTSDIR}/net/boinc-client
@@ -102,7 +106,7 @@ do-install:
${BOINC_CLIENT_HOME}/projects/${SETI_SITE}
${INSTALL_PROGRAM} -o ${BOINC_CLIENT_USER} -g ${BOINC_CLIENT_GROUP} \
${WRKSRC}/client/${SETI_BINARY} ${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/
-.if !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
${INSTALL_PROGRAM} -o ${BOINC_CLIENT_USER} -g ${BOINC_CLIENT_GROUP} \
${WRKSRC}/client/seti_graphics ${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/
.endif
@@ -111,4 +115,4 @@ post-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>