aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-09-08 09:12:10 +0800
committerlinimon <linimon@FreeBSD.org>2007-09-08 09:12:10 +0800
commit9ccc7e92dea72d32d4ae04470bbce43e6f9227da (patch)
tree20264757b2346c435477e3f6cfdf324086bbafe9 /astro
parent07d9e093a64a0c7f96ed0775d50e0f818d98fd80 (diff)
downloadfreebsd-ports-gnome-9ccc7e92dea72d32d4ae04470bbce43e6f9227da.tar.gz
freebsd-ports-gnome-9ccc7e92dea72d32d4ae04470bbce43e6f9227da.tar.zst
freebsd-ports-gnome-9ccc7e92dea72d32d4ae04470bbce43e6f9227da.zip
Welcome bsd.perl.mk. Add support for constructs such as USE_PERL5=5.8.0+.
Drop support for antique perl. Work done by: gabor Sponsored by: Google Summer of Code 2007 Hat: portmgr
Diffstat (limited to 'astro')
-rw-r--r--astro/p5-Astro-Catalog/Makefile8
-rw-r--r--astro/p5-Weather-Underground/Makefile10
2 files changed, 3 insertions, 15 deletions
diff --git a/astro/p5-Astro-Catalog/Makefile b/astro/p5-Astro-Catalog/Makefile
index d028ec281443..84f583b0021a 100644
--- a/astro/p5-Astro-Catalog/Makefile
+++ b/astro/p5-Astro-Catalog/Makefile
@@ -59,12 +59,6 @@ MAN3= Astro::Catalog.3 \
Astro::Catalog::Transport::WebService.3 \
Tk::AstroCatalog.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
-.endif
-
post-patch:
@${PERL} -pi -e "s!^(my.*cfg_to_install).*!\$$1=\"\";!;" ${WRKSRC}/Makefile.PL
@@ -76,4 +70,4 @@ post-install:
.endif
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/astro/p5-Weather-Underground/Makefile b/astro/p5-Weather-Underground/Makefile
index 380a6b80a24e..333dcaadba8e 100644
--- a/astro/p5-Weather-Underground/Makefile
+++ b/astro/p5-Weather-Underground/Makefile
@@ -19,14 +19,8 @@ BUILD_DEPENDS= ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/${PERL_ARCH}/HTML/TokeParser.pm:${PORTSDIR}/www/p5-HTML-Parser
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.0+
MAN3= Weather::Underground.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>