aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-08-30 19:58:59 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-08-30 19:58:59 +0800
commita3375d0554e98daa55fefa0abce2c8cce5b06f72 (patch)
tree09a44058999182d17f4867a193998506f7379096 /astro
parentb8924770b72a253b3375f8e8d62418dade0a153c (diff)
downloadfreebsd-ports-gnome-a3375d0554e98daa55fefa0abce2c8cce5b06f72.tar.gz
freebsd-ports-gnome-a3375d0554e98daa55fefa0abce2c8cce5b06f72.tar.zst
freebsd-ports-gnome-a3375d0554e98daa55fefa0abce2c8cce5b06f72.zip
- Update to 3.1
- Unbreak build on 7.0 - Unbreak some options Approved by: glebius (maintainer implicit)
Diffstat (limited to 'astro')
-rw-r--r--astro/gpsd/Makefile56
-rw-r--r--astro/gpsd/distinfo4
-rw-r--r--astro/gpsd/files/patch-SConstruct62
3 files changed, 37 insertions, 85 deletions
diff --git a/astro/gpsd/Makefile b/astro/gpsd/Makefile
index 33d2b2abe724..50e5eee915c7 100644
--- a/astro/gpsd/Makefile
+++ b/astro/gpsd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gpsd
-PORTVERSION= 3.0
+PORTVERSION= 3.1
CATEGORIES= astro geography
MASTER_SITES= BERLIOS
@@ -22,10 +22,10 @@ USE_RC_SUBR= gpsd
USE_PYTHON= yes
INSTALLS_EGGINFO= yes
PYDISTUTILS_EGGINFO= gps-${PORTVERSION}.egg-info
-MAKE_JOBS_UNSAFE=yes
+MAKE_JOBS_SAFE= yes
SCONS_BUILDENV= ${SCONS_ENV}
-SCONS_ARGS= prefix="${PREFIX}" mandir="/man"
+SCONS_ARGS= prefix="${PREFIX}" mandir="/man" pkgconfigdir="/libdata/pkgconfig"
MAN1= cgps.1 gegps.1 gps.1 gpscat.1 gpsctl.1 gpsdecode.1 \
gpsfake.1 gpspipe.1 gpsprof.1 xgps.1 xgpsspeed.1 \
@@ -38,6 +38,7 @@ MANCOMPRESSED= no
OPTIONS= AIVDM "Aivdm support" on \
ASHTECH "Ashtech support" on \
CPPBIND "Build C++ bindings" on \
+ DBUS "DBUS support" off \
EARTHMATE "DeLorme EarthMate Zodiac support" on \
EVERMORE "Evermore binary support" on \
FV18 "San Jose Navigation FV-18 support" on \
@@ -50,6 +51,7 @@ OPTIONS= AIVDM "Aivdm support" on \
ITRAX "iTrax support" on \
MTK "MTK-3301 support" on \
NAVCOM "Navcom support" on \
+ NETFEED "Build support for handling TCP/IP data sources" on \
NCURSES "Build with ncurses(3)" off \
NMEA "NMEA support" on \
NTPSHM "NTP time hinting support" on \
@@ -61,10 +63,12 @@ OPTIONS= AIVDM "Aivdm support" on \
PPS "PPS time syncing support" on \
PPSONCTS "PPS pulse on CTS rather than DCD" off \
PROFILING "Profiling support" off \
+ RECONFIGURE "Allow gpsd to change device settings" on \
RTCM104V2 "rtcm104v2 support" on \
RTCM104V3 "rtcm104v3 support" on \
SHMEXPORT "Enable export via shared memory" on \
SIRF "SiRF chipset support" on \
+ SOCKEXPORT "Enable export over sockets" on \
SUPERSTARII "SuperStarII support" on \
TIMING "Build latency timing support" on \
TNT "True North Technologies support" on \
@@ -74,16 +78,12 @@ OPTIONS= AIVDM "Aivdm support" on \
UBX "UBX protocol support" on \
USB "libusb support for USB devices" on
-# Doesn't build
-# DBUS "DBUS support" off \
-# Doesn't build when toggled
-# NETFEED "Build support for handling TCP/IP data sources" on \
-# SOCKEXPORT "Enable export over sockets" on \
-# RECONFIGURE "Allow gpsd to change device settings" on \
-
.include <bsd.port.options.mk>
-# This is only temporary for my tinderbox not to try these options
+# Requires libusb.h available in 8.x
+.if ${OSVERSION} < 800069
+WITHOUT_USB= yes
+.endif
# Options related to GPS protocols
.if defined(WITHOUT_NMEA)
@@ -197,19 +197,15 @@ SCONS_ARGS+= pps_on_cts=yes
.endif
# Export methods
+.if defined(WITHOUT_SOCKEXPORT)
+SCONS_ARGS+= socket_export=no
+.endif
-# Won't build
-#.if defined(WITHOUT_SOCKEXPORT)
-#SCONS_ARGS+= socket_export=no
-#.endif
-
-# doesn't build; too many unsolvable problems with lib detection,
-# include paths etc.
-#.if defined(WITH_DBUS)
-#LIB_DEPENDS+= dbus:${PORTSDIR}/devel/dbus \
-# dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
-#SCONS_ARGS+= dbus_export=yes
-#.endif
+.if defined(WITH_DBUS)
+LIB_DEPENDS+= dbus:${PORTSDIR}/devel/dbus \
+ dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+SCONS_ARGS+= dbus_export=yes
+.endif
.if defined(WITHOUT_SHMEXPORT)
SCONS_ARGS+= shm_export=no
@@ -224,10 +220,9 @@ SCONS_ARGS+= usb=no
SCONS_ARGS+= ipv6=no
.endif
-# Won't build
-#.if defined(WITHOUT_NETFEED)
-#SCONS_ARGS+= netfeed=no
-#.endif
+.if defined(WITHOUT_NETFEED)
+SCONS_ARGS+= netfeed=no
+.endif
.if defined(WITHOUT_PASSTHROUGH)
SCONS_ARGS+= passthrough=no
@@ -253,10 +248,9 @@ SCONS_ARGS+= libQgpsmm=no
PLIST_SUB+= QTBIND="@comment "
.endif
-# Won't build
-#.if defined(WITHOUT_RECONFIGURE)
-#SCONS_ARGS+= reconfigure=no
-#.endif
+.if defined(WITHOUT_RECONFIGURE)
+SCONS_ARGS+= reconfigure=no
+.endif
.if defined(WITHOUT_CPPBIND)
SCONS_ARGS+= libgpsmm=no
diff --git a/astro/gpsd/distinfo b/astro/gpsd/distinfo
index 7a5b3ea77813..fefcfd876a60 100644
--- a/astro/gpsd/distinfo
+++ b/astro/gpsd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gpsd-3.0.tar.gz) = 542ed7a5885205604eb60e2d0895b9d6cdefb30fc2028d2ba4ebfe5ba01d95e7
-SIZE (gpsd-3.0.tar.gz) = 2133361
+SHA256 (gpsd-3.1.tar.gz) = 8cf936ec19bd6106a8f18479c15558a807fe558028c2561393b525391dc6dfe3
+SIZE (gpsd-3.1.tar.gz) = 2137792
diff --git a/astro/gpsd/files/patch-SConstruct b/astro/gpsd/files/patch-SConstruct
index e9573e72a455..cd150208a83c 100644
--- a/astro/gpsd/files/patch-SConstruct
+++ b/astro/gpsd/files/patch-SConstruct
@@ -1,58 +1,16 @@
---- SConstruct.orig 2011-08-19 09:36:28.000000000 +0400
-+++ SConstruct 2011-08-24 14:13:54.000000000 +0400
-@@ -155,7 +155,10 @@
- j = i
- if i == "LD":
- i = "SHLINK"
-- env[j]=os.getenv(i)
-+ if i == "CFLAGS" or i == "CCFLAGS":
-+ env.Replace(**{j: Split(os.getenv(i))})
-+ else:
-+ env.Replace(**{j: os.getenv(i)})
- for flags in ["LDFLAGS", "CPPFLAGS"]:
- if os.environ.has_key(flags):
- env.MergeFlags([os.getenv(flags)])
-@@ -173,7 +176,7 @@
- else:
- pkg_config = lambda pkg: ['!pkg-config --cflags --libs --static %s' %(pkg, )]
-
--if env['CC'] == 'gcc':
-+if env['CC'] == 'gcc' or env['CC'] == 'cc':
- # Enable all GCC warnings except uninitialized and
- # missing-field-initializers, which we can't help triggering because
- # of the way some of the JSON-parsing code is generated.
-@@ -326,22 +329,12 @@
- confdefs.append("/* #undef HAVE_%s */\n" % f.upper())
-
+--- SConstruct.orig 2011-08-28 15:14:24.000000000 +0400
++++ SConstruct 2011-08-29 23:47:35.000000000 +0400
+@@ -346,12 +346,7 @@
+ # are like FreeBSD.
+ ncurseslibs= []
if env['ncurses']:
- if config.CheckPKG('ncurses'):
- ncurseslibs = pkg_config('ncurses')
- elif config.CheckExecutable('ncurses5-config --version', 'ncurses5-config'):
- ncurseslibs = ['!ncurses5-config --libs --cflags']
-- else:
-- ncurseslibs= []
-+ ncurseslibs= [ '/usr/lib/libncurses.so' ]
- else:
- ncurseslibs= []
-
--if env['usb'] and config.CheckPKG('libusb-1.0'):
-- confdefs.append("#define HAVE_LIBUSB 1\n")
-- try:
-- usblibs = pkg_config('libusb-1.0')
-- except OSError:
-- print "pkg_config is confused about the state of libusb-1.0."
-- usblibs = []
-+if env['usb']:
-+ usblibs = [ "-lusb" ]
- else:
- confdefs.append("/* #undef HAVE_LIBUSB */\n")
- usblibs = []
-@@ -950,7 +943,7 @@
- python_progs_install,
- python_egg_info_install]
-
--pkgconfigdir = os.path.join(installdir('libdir'), 'pkgconfig')
-+pkgconfigdir = os.path.join(env['prefix'], 'libdata', 'pkgconfig')
- pc_install = [ env.Install(pkgconfigdir, x) for x in ("libgps.pc", "libgpsd.pc") ]
+- elif sys.platform.startswith('freebsd'):
+- ncurseslibs= [ '-lncurses' ]
++ ncurseslibs= [ '-lncurses' ]
- maninstall = []
+ if env['usb']:
+ # In FreeBSD except version 7, USB libraries are in the base system