aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2006-09-15 16:17:11 +0800
committerlinimon <linimon@FreeBSD.org>2006-09-15 16:17:11 +0800
commitf2d8437c35c46dc1131c982c1f25abcd7d641fb3 (patch)
tree61136cc420c647223541df746f011f5307a7b184 /astro
parent6c16383d95de00351d4ecaf674a95f310d209a6b (diff)
downloadfreebsd-ports-gnome-f2d8437c35c46dc1131c982c1f25abcd7d641fb3.tar.gz
freebsd-ports-gnome-f2d8437c35c46dc1131c982c1f25abcd7d641fb3.tar.zst
freebsd-ports-gnome-f2d8437c35c46dc1131c982c1f25abcd7d641fb3.zip
Modify these files to reflect bsd.lua.mk as tested on the cluster.
PR: ports/101612 Submitted by: alepulver Hat: portmgr
Diffstat (limited to 'astro')
-rw-r--r--astro/celestia/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 18f8c76151e2..7dd2e7b31608 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -26,9 +26,9 @@ WANT_GNOME= yes
USE_X_PREFIX= yes
CONFIGURE_ARGS= --program-prefix=""
-CONFIGURE_ENV= \
- LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib -lm ${PTHREAD_LIBS}" \
- CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CPPFLAGS= -I${X11BASE}/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${X11BASE}/lib -L${LOCALBASE}/lib -lm ${PTHREAD_LIBS}
UI_LIST= glut gtk gnome
CELESTIA_UI?= glut
@@ -77,8 +77,10 @@ IGNORE= does not compile on FreeBSD 4.x
.endif
.if defined(WITH_LUA)
-LIB_DEPENDS+= lua.5:${PORTSDIR}/lang/lua50
+USE_LUA= 5.0
CONFIGURE_ARGS+= --with-lua
+CPPFLAGS+= -I${LUA_INCDIR}
+LDFLAGS+= -L${LUA_LIBDIR}
.endif
pre-patch: