aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-11-22 20:55:18 +0800
committermakc <makc@FreeBSD.org>2013-11-22 20:55:18 +0800
commit9a1c12c35ce45ac3ef0446aeeb9d78a85d351753 (patch)
treee5d8fb03dadf7c4332a432be715b65ed71eed93f /astro
parent6a8fa025703756528837f1ccf220676f5c3848f0 (diff)
downloadfreebsd-ports-gnome-9a1c12c35ce45ac3ef0446aeeb9d78a85d351753.tar.gz
freebsd-ports-gnome-9a1c12c35ce45ac3ef0446aeeb9d78a85d351753.tar.zst
freebsd-ports-gnome-9a1c12c35ce45ac3ef0446aeeb9d78a85d351753.zip
- Convert to USES=qmake
- Use options helpers - Convert LIB_DEPENDS to new style Approved by: portmgr (blanket approval)
Diffstat (limited to 'astro')
-rw-r--r--astro/merkaartor/Makefile45
1 files changed, 14 insertions, 31 deletions
diff --git a/astro/merkaartor/Makefile b/astro/merkaartor/Makefile
index 21774b74e7c7..71cba5e23ec0 100644
--- a/astro/merkaartor/Makefile
+++ b/astro/merkaartor/Makefile
@@ -9,46 +9,33 @@ MASTER_SITES= http://merkaartor.be/attachments/download/301/ \
https://secure.ohos.nl/downloads/
MAINTAINER= dev2@heesakkers.info
-COMMENT= An openstreetmap mapping program
+COMMENT= Openstreetmap mapping program
LICENSE= GPLv2
-LIB_DEPENDS= gdal:${PORTSDIR}/graphics/gdal \
- proj:${PORTSDIR}/graphics/proj
+LIB_DEPENDS= libgdal.so:${PORTSDIR}/graphics/gdal \
+ libproj.so:${PORTSDIR}/graphics/proj
-NO_STAGE= yes
USE_BZIP2= yes
USE_LDCONFIG= yes
-USE_QT4= qmake_build uic_build moc_build rcc_build \
+USE_QT4= uic_build moc_build rcc_build \
gui network svg webkit xml imageformats script scripttools
-.if exists(${LOCALBASE}/bin/gnome-session)
-INSTALLS_ICONS= yes
-.endif
-
-QMAKEFLAGS= PREFIX=${PREFIX}
-
-OPTIONS_DEFINE= GEOIMAGE ZBAR DEBUG
-GEOIMAGE_DESC= Enable geotagged images (needs exiv2)
-ZBAR_DESC= Read barcodes from walking papers
+OPTIONS_DEFINE= GEOIMAGE ZBAR DEBUG NLS
OPTIONS_DEFAULT= GEOIMAGE
-.include <bsd.port.options.mk>
+GEOIMAGE_DESC= Enable geotagged images (needs exiv2)
+GEOIMAGE_QMAKE_ON= GEOIMAGE=1
+GEOIMAGE_LIB_DEPENDS= libexiv2.so:${PORTSDIR}/graphics/exiv2
-.if ${PORT_OPTIONS:MGEOIMAGE}
-QMAKEFLAGS+= GEOIMAGE=1
-LIB_DEPENDS+= exiv2:${PORTSDIR}/graphics/exiv2
-.endif
+ZBAR_DESC= Read barcodes from walking papers
+ZBAR_QMAKE_ON= ZBAR=1
+ZBAR_LIB_DEPENDS= libzbar.so:${PORTSDIR}/graphics/zbar
-.if ${PORT_OPTIONS:MZBAR}
-QMAKEFLAGS+= ZBAR=1
-LIB_DEPENDS+= zbar:${PORTSDIR}/graphics/zbar
-.endif
+DEBUG_QMAKE_OFF= NODEBUG=1 RELEASE=1
-.if empty(PORT_OPTIONS:MDEBUG)
-QMAKEFLAGS+= NODEBUG=1 RELEASE=1
-.endif
+.include <bsd.port.options.mk>
.if empty(PORT_OPTIONS:MNLS)
PLIST_SUB+= NLS="@comment "
@@ -57,11 +44,7 @@ PLIST_SUB+= NLS=""
USE_QT4+= linguist_build
pre-build:
- @cd ${WRKSRC}/translations && lrelease-qt4 ../src/src.pro
+ @cd ${WRKSRC}/translations && ${LRELEASE} ../src/src.pro
.endif
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} ${QMAKEFLAGS}
-
.include <bsd.port.mk>