aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-07-28 00:27:31 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-07-28 00:27:31 +0800
commitcfb1947d5cd00d8e1abf8cd57a1f44e83a424ba4 (patch)
tree194ddd8cf9c83cb63dc540eb4948d143fcbe6788 /astro
parent089fb87f3981f49e66cf641e0f9f91346257759f (diff)
downloadfreebsd-ports-gnome-cfb1947d5cd00d8e1abf8cd57a1f44e83a424ba4.tar.gz
freebsd-ports-gnome-cfb1947d5cd00d8e1abf8cd57a1f44e83a424ba4.tar.zst
freebsd-ports-gnome-cfb1947d5cd00d8e1abf8cd57a1f44e83a424ba4.zip
- Cleanup Makefile
Diffstat (limited to 'astro')
-rw-r--r--astro/py-metar/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/astro/py-metar/Makefile b/astro/py-metar/Makefile
index 7c78e1e5e43f..6b74630e4c4f 100644
--- a/astro/py-metar/Makefile
+++ b/astro/py-metar/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= astro python geography
MASTER_SITES= http://www.schwarzvogel.de/pkgs/ \
LOCAL/sunpoet
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= ${REALPORTNAME}-${PORTVERSION}
+DISTNAME= py${PORTNAME}-${PORTVERSION}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Python module that provides access to NOAA METAR weather reports
@@ -25,13 +25,11 @@ USES= shebangfix
PORTDOCS= COPYING README THANKS librarydoc.txt
-REALPORTNAME= pymetar
-
-SHEBANG_FILES= bin/${REALPORTNAME}
+SHEBANG_FILES= bin/py${PORTNAME}
python_CMD= ${PYTHON_CMD}
post-patch:
@${REINPLACE_CMD} -e 's|share/\(man/man1\)|\1|' \
- -e 's|"share/doc/pymetar-%s"%pymetar.__version__|"${DOCSDIR}"|' ${WRKSRC}/${PYSETUP}
+ -e 's|"share/doc/pymetar-%s"%pymetar.__version__|"${DOCSDIR}"|' ${WRKSRC}/setup.py
.include <bsd.port.mk>