aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-07-27 09:53:42 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-07-27 09:53:42 +0800
commitff1667c0b06bf4b6945720383f1c30523692dd4a (patch)
tree129e3e8131967470c91fdf41f317277d894c1171 /astro
parentaec62b2dc914ff2eaf213048f8630bcbeaf95e3c (diff)
downloadfreebsd-ports-gnome-ff1667c0b06bf4b6945720383f1c30523692dd4a.tar.gz
freebsd-ports-gnome-ff1667c0b06bf4b6945720383f1c30523692dd4a.tar.zst
freebsd-ports-gnome-ff1667c0b06bf4b6945720383f1c30523692dd4a.zip
- Update to 4223
- Make webkit-image and thus Qt dependency optional
Diffstat (limited to 'astro')
-rw-r--r--astro/josm/Makefile25
-rw-r--r--astro/josm/distinfo4
2 files changed, 20 insertions, 9 deletions
diff --git a/astro/josm/Makefile b/astro/josm/Makefile
index 0cce26356b45..e13d3f76d5e9 100644
--- a/astro/josm/Makefile
+++ b/astro/josm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= josm
-PORTVERSION= 4064
+PORTVERSION= 4223
CATEGORIES= astro java
MASTER_SITES= http://josm.openstreetmap.de/download/:josm \
http://mirror.amdmi3.ru/distfiles/:josm \
@@ -20,10 +20,6 @@ COMMENT= A comprehensive editor for OpenStreetMap.org database
NO_WRKSUBDIR= yes
-USE_QT_VER= 4
-QT_COMPONENTS= corelib gui imageformats moc_build network script \
- rcc_build uic_build webkit
-
USE_JAVA= YES
JAVA_VERSION= 1.5+
@@ -33,8 +29,18 @@ SUB_LIST= JARNAME=${DISTNAME}
WEBKITIMG= webkit-image
WEBKITIMG_SRC= ${WEBKITIMG}.cpp
-PLIST_FILES= bin/josm ${JAVAJARDIR:C,${PREFIX}/?,,}/${DISTNAME} \
- bin/webkit-image
+PLIST_FILES= bin/josm ${JAVAJARDIR:C,${PREFIX}/?,,}/${DISTNAME}
+
+OPTIONS= WEBKIT_IMAGE "Build webkit-image (needed for Yahoo imagery)" on
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_WEBKIT_IMAGE)
+PLIST_FILES+= bin/webkit-image
+
+USE_QT_VER= 4
+QT_COMPONENTS= corelib gui imageformats moc_build network script \
+ rcc_build uic_build webkit
do-build:
cd ${WRKSRC} && \
@@ -42,11 +48,16 @@ do-build:
${CXX} ${CFLAGS} ${PTHREAD_LIBS} -I. -I${QT_INCDIR} -L${QT_LIBDIR} \
${DISTDIR}/${WEBKITIMG_SRC} -o ${WEBKITIMG} -lQtCore -lQtWebKit \
-lQtGui
+.else
+NO_BUILD= yes
+.endif
do-install:
${MKDIR} ${JAVAJARDIR}/
${INSTALL_DATA} ${DISTDIR}/${DISTNAME} ${JAVAJARDIR}/
${INSTALL_SCRIPT} ${WRKDIR}/josm.sh ${PREFIX}/bin/josm
+.if defined(WITH_WEBKIT_IMAGE)
${INSTALL_PROGRAM} ${WRKDIR}/${WEBKITIMG} ${PREFIX}/bin
+.endif
.include <bsd.port.mk>
diff --git a/astro/josm/distinfo b/astro/josm/distinfo
index dc078dfd9d79..ad0001bd2598 100644
--- a/astro/josm/distinfo
+++ b/astro/josm/distinfo
@@ -1,4 +1,4 @@
-SHA256 (josm-snapshot-4064.jar) = 09fb7b2fd203cba3730f13104d21a2ddce3a3ae6a1dc54251c8ae2d18ea36357
-SIZE (josm-snapshot-4064.jar) = 6710490
+SHA256 (josm-snapshot-4223.jar) = c90c53734c0265814eaf1a75de0faafa3db670a493261c4dfca87badca0b8f80
+SIZE (josm-snapshot-4223.jar) = 6456517
SHA256 (webkit-image.cpp) = 431f5b956c0e3d1615289dd6cb64effb988b30ace7c80f5a51f9546aa80d300d
SIZE (webkit-image.cpp) = 2718