aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-01-08 01:49:52 +0800
committerwill <will@FreeBSD.org>2001-01-08 01:49:52 +0800
commit17fc78c61a40e51c25675da0e3d99e222c1abdd3 (patch)
treea8b19a050dd6847de35f8b185751c1b52138d171 /astro
parent98a4931c0a8138d6f6fb6de52d4fd949a15ae520 (diff)
downloadfreebsd-ports-gnome-17fc78c61a40e51c25675da0e3d99e222c1abdd3.tar.gz
freebsd-ports-gnome-17fc78c61a40e51c25675da0e3d99e222c1abdd3.tar.zst
freebsd-ports-gnome-17fc78c61a40e51c25675da0e3d99e222c1abdd3.zip
Clean up inefficient perl invocations; use multiple REs in the same call.
Diffstat (limited to 'astro')
-rw-r--r--astro/pyweather/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/astro/pyweather/Makefile b/astro/pyweather/Makefile
index f99cc4759126..36b3d5358ea1 100644
--- a/astro/pyweather/Makefile
+++ b/astro/pyweather/Makefile
@@ -20,8 +20,8 @@ NO_BUILD= yes
PYTHON?= ${LOCALBASE}/bin/python
pre-install:
- @${PERL} -pi -e "s:/usr/bin/python:${PYTHON}:g" ${WRKSRC}/pyWeather.py
- @${PERL} -pi -e "s:pyWeather.py:pyWeather:g" ${WRKSRC}/pyWeather.py
+ @${PERL} -pi -e "s:/usr/bin/python:${PYTHON}:g ; \
+ s:pyWeather.py:pyWeather:g" ${WRKSRC}/pyWeather.py
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/pyWeather.py ${PREFIX}/bin/pyWeather