aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-04-30 03:46:07 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-04-30 03:46:07 +0800
commit20b804f08a68c46b0bcaddc1678fc08e485ab75c (patch)
tree279154d8c73cbb4a9bd67b5d24ad59957f978c14 /astro
parent0e20423417f5e975a42a886b8a3000108e75ac98 (diff)
downloadfreebsd-ports-gnome-20b804f08a68c46b0bcaddc1678fc08e485ab75c.tar.gz
freebsd-ports-gnome-20b804f08a68c46b0bcaddc1678fc08e485ab75c.tar.zst
freebsd-ports-gnome-20b804f08a68c46b0bcaddc1678fc08e485ab75c.zip
Add py-metar 1.5.0
Metar is a python package for interpreting METAR and SPECI weather reports. This module extracts the data recorded in the main-body groups of reports that follow the WMO spec or the US conventions, except for the runway state and trend groups, which are parsed but ignored. The most useful remark groups defined in the US spec are parsed, as well, such as the cumulative precipitation, min/max temperature, peak wind and sea-level pressure groups. No other regional conventions are formally supported, but a large number of variant formats found in international reports are accepted. WWW: https://pypi.org/project/metar/ WWW: https://github.com/tomp/python-metar
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/py-metar/Makefile19
-rw-r--r--astro/py-metar/distinfo3
-rw-r--r--astro/py-metar/pkg-descr12
4 files changed, 35 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 891330279e09..1a87a2273ce5 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -87,6 +87,7 @@
SUBDIR += py-astLib
SUBDIR += py-astropy
SUBDIR += py-horoscopegenerator
+ SUBDIR += py-metar
SUBDIR += py-metpy
SUBDIR += py-pymetar
SUBDIR += py-pywapi
diff --git a/astro/py-metar/Makefile b/astro/py-metar/Makefile
new file mode 100644
index 000000000000..21d9492e06d9
--- /dev/null
+++ b/astro/py-metar/Makefile
@@ -0,0 +1,19 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= metar
+PORTVERSION= 1.5.0
+CATEGORIES= astro python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Parse METAR-coded weather reports
+
+LICENSE= MIT
+
+NO_ARCH= yes
+USE_PYTHON= autoplist concurrent distutils
+USES= python
+
+.include <bsd.port.mk>
diff --git a/astro/py-metar/distinfo b/astro/py-metar/distinfo
new file mode 100644
index 000000000000..54319d4300ea
--- /dev/null
+++ b/astro/py-metar/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1524959591
+SHA256 (metar-1.5.0.tar.gz) = 1a1cc2047b7fe0fd3444ad0fb4d432c2950bc67e9904f29cc4349270802c287a
+SIZE (metar-1.5.0.tar.gz) = 24058
diff --git a/astro/py-metar/pkg-descr b/astro/py-metar/pkg-descr
new file mode 100644
index 000000000000..1f1616163526
--- /dev/null
+++ b/astro/py-metar/pkg-descr
@@ -0,0 +1,12 @@
+Metar is a python package for interpreting METAR and SPECI weather reports.
+
+This module extracts the data recorded in the main-body groups of reports that
+follow the WMO spec or the US conventions, except for the runway state and trend
+groups, which are parsed but ignored. The most useful remark groups defined in
+the US spec are parsed, as well, such as the cumulative precipitation, min/max
+temperature, peak wind and sea-level pressure groups. No other regional
+conventions are formally supported, but a large number of variant formats found
+in international reports are accepted.
+
+WWW: https://pypi.org/project/metar/
+WWW: https://github.com/tomp/python-metar