aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2018-05-06 23:39:46 +0800
committerriggs <riggs@FreeBSD.org>2018-05-06 23:39:46 +0800
commit29fa3acd9cdba460fd260a5abd11c0cc17223e38 (patch)
tree69c5ecacc71381391cd5b19e10a270a594092b67 /astro
parentfc10c7ce42ebf816b139ccd9ecb6314101def269 (diff)
downloadfreebsd-ports-gnome-29fa3acd9cdba460fd260a5abd11c0cc17223e38.tar.gz
freebsd-ports-gnome-29fa3acd9cdba460fd260a5abd11c0cc17223e38.tar.zst
freebsd-ports-gnome-29fa3acd9cdba460fd260a5abd11c0cc17223e38.zip
Update to upstream version 1.5.4; use QT5 instead of QT4
PR: 227538 Submitted by: cmt Approved by: Maintainer timeout
Diffstat (limited to 'astro')
-rw-r--r--astro/gpsbabel/Makefile8
-rw-r--r--astro/gpsbabel/distinfo5
-rw-r--r--astro/gpsbabel/files/patch-exif.cc26
-rw-r--r--astro/gpsbabel/files/patch-garmin__device__xml.cc11
-rw-r--r--astro/gpsbabel/files/patch-gpx.cc50
-rw-r--r--astro/gpsbabel/files/patch-lowranceusr.cc11
-rw-r--r--astro/gpsbabel/files/patch-magproto.cc17
-rw-r--r--astro/gpsbabel/files/patch-psitrex.cc11
-rw-r--r--astro/gpsbabel/files/patch-tef_xml.cc57
-rw-r--r--astro/gpsbabel/files/patch-unicsv.cc20
10 files changed, 184 insertions, 32 deletions
diff --git a/astro/gpsbabel/Makefile b/astro/gpsbabel/Makefile
index fdfa36144cc5..3dfbbef3751d 100644
--- a/astro/gpsbabel/Makefile
+++ b/astro/gpsbabel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gpsbabel
DISTVERSIONPREFIX= ${PORTNAME}_
-DISTVERSION= 1_5_3
+DISTVERSION= 1_5_4
CATEGORIES= astro geography
MAINTAINER= dev2@heesakkers.info
@@ -19,7 +19,7 @@ USE_GITHUB= yes
CONFLICTS= gpsbabel14-[0-9]*
-USE_QT4= corelib qmake_build
+USE_QT5= core qmake_build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-zlib=system
USES= localbase
@@ -28,8 +28,8 @@ OPTIONS_DEFINE= GUI
OPTIONS_SUB= yes
GUI_ALL_TARGET= gui
-GUI_USE= QT4=gui,xml,network,webkit
-GUI_USE+= QT4=linguisttools_build,moc_build,rcc_build,uic_build
+GUI_USE= QT5=gui,xml,network,webkit
+GUI_USE+= QT5=linguisttools_build,moc_build,rcc_build,uic_build
GUI_VARS= MAKE_JOBS_UNSAFE=yes
post-patch:
diff --git a/astro/gpsbabel/distinfo b/astro/gpsbabel/distinfo
index 314b22737120..1ff9520671d9 100644
--- a/astro/gpsbabel/distinfo
+++ b/astro/gpsbabel/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gpsbabel-gpsbabel-gpsbabel_1_5_3_GH0.tar.gz) = 10b7aaca44ce557fa1175fec37297b8df55611ab2c51cb199753a22dbf2d3997
-SIZE (gpsbabel-gpsbabel-gpsbabel_1_5_3_GH0.tar.gz) = 8516277
+TIMESTAMP = 1523450580
+SHA256 (gpsbabel-gpsbabel-gpsbabel_1_5_4_GH0.tar.gz) = 8cd740db0b92610abff71e942e8a987df58cd6ca5f25cca86e15f2b00e190704
+SIZE (gpsbabel-gpsbabel-gpsbabel_1_5_4_GH0.tar.gz) = 9121510
diff --git a/astro/gpsbabel/files/patch-exif.cc b/astro/gpsbabel/files/patch-exif.cc
deleted file mode 100644
index 9252fc5ccd3c..000000000000
--- a/astro/gpsbabel/files/patch-exif.cc
+++ /dev/null
@@ -1,26 +0,0 @@
---- exif.cc.orig 2016-01-03 02:09:17 UTC
-+++ exif.cc
-@@ -1100,7 +1100,7 @@ exif_find_wpt_by_time(const Waypoint* wp
-
- if (exif_wpt_ref == NULL) {
- exif_wpt_ref = wpt;
-- } else if (abs(exif_time_ref - wpt->creation_time.toTime_t()) < abs(exif_time_ref - exif_wpt_ref->creation_time.toTime_t())) {
-+ } else if (qAbs(exif_time_ref - wpt->creation_time.toTime_t()) < qAbs(exif_time_ref - exif_wpt_ref->creation_time.toTime_t())) {
- exif_wpt_ref = wpt;
- }
- }
-@@ -1447,12 +1447,12 @@ exif_write(void)
-
- if (exif_wpt_ref == NULL) {
- warning(MYNAME ": No point with a valid timestamp found.\n");
-- } else if (abs(exif_time_ref - exif_wpt_ref->creation_time.toTime_t()) > frame) {
-+ } else if (qAbs(exif_time_ref - exif_wpt_ref->creation_time.toTime_t()) > frame) {
- warning(MYNAME ": No matching point found for image date %s!\n", qPrintable(str));
- if (exif_wpt_ref != NULL) {
- QString str = exif_time_str(exif_wpt_ref->creation_time.toTime_t());
- warning(MYNAME ": Best is from %s, %d second(s) away.\n",
-- qPrintable(str), abs(exif_time_ref - exif_wpt_ref->creation_time.toTime_t()));
-+ qPrintable(str), (int) qAbs(exif_time_ref - exif_wpt_ref->creation_time.toTime_t()));
- }
- exif_wpt_ref = NULL;
- }
diff --git a/astro/gpsbabel/files/patch-garmin__device__xml.cc b/astro/gpsbabel/files/patch-garmin__device__xml.cc
new file mode 100644
index 000000000000..0d4d589649fd
--- /dev/null
+++ b/astro/gpsbabel/files/patch-garmin__device__xml.cc
@@ -0,0 +1,11 @@
+--- garmin_device_xml.cc.orig 2018-04-11 18:10:39 UTC
++++ garmin_device_xml.cc
+@@ -41,7 +41,7 @@ jmp_buf gdx_jmp_buf;
+
+ void type_s(xg_string args, const QXmlStreamAttributes*)
+ {
+- type = args.compare("GPSData");
++ type = args.compare(QLatin1String("GPSData"));
+ }
+
+ void device_s(xg_string args, const QXmlStreamAttributes*)
diff --git a/astro/gpsbabel/files/patch-gpx.cc b/astro/gpsbabel/files/patch-gpx.cc
new file mode 100644
index 000000000000..323cfdf55e2e
--- /dev/null
+++ b/astro/gpsbabel/files/patch-gpx.cc
@@ -0,0 +1,50 @@
+--- gpx.cc.orig 2018-04-11 18:10:39 UTC
++++ gpx.cc
+@@ -494,7 +494,7 @@
+ {
+ cache_descr_is_html = 0;
+ if (attr.hasAttribute("html")) {
+- if (attr.value("html").toString().compare("True") == 0) {
++ if (attr.value("html").compare(QLatin1String("True")) == 0) {
+ cache_descr_is_html = 1;
+ }
+ }
+@@ -509,16 +509,16 @@
+ gc_data->id = attr.value("id").toString().toInt();
+ }
+ if (attr.hasAttribute("available")) {
+- if (attr.value("available").toString().compare("True", Qt::CaseInsensitive) == 0) {
++ if (attr.value("available").compare(QLatin1String("True"), Qt::CaseInsensitive) == 0) {
+ gc_data->is_available = status_true;
+- } else if (attr.value("available").toString().compare("False", Qt::CaseInsensitive) == 0) {
++ } else if (attr.value("available").compare(QLatin1String("False"), Qt::CaseInsensitive) == 0) {
+ gc_data->is_available = status_false;
+ }
+ }
+ if (attr.hasAttribute("archived")) {
+- if (attr.value("archived").toString().compare("True", Qt::CaseInsensitive) == 0) {
++ if (attr.value("archived").compare(QLatin1String("True"), Qt::CaseInsensitive) == 0) {
+ gc_data->is_archived = status_true;
+- } else if (attr.value("archived").toString().compare("False", Qt::CaseInsensitive) == 0) {
++ } else if (attr.value("archived").compare(QLatin1String("False"), Qt::CaseInsensitive) == 0) {
+ gc_data->is_archived = status_false;
+ }
+ }
+@@ -972,7 +972,7 @@
+ * last date we saw in this log.
+ */
+ case tt_cache_log_type:
+- if ((cdatastr.compare("Found it") == 0) &&
++ if ((cdatastr.compare(QLatin1String("Found it")) == 0) &&
+ (0 == wpt_tmp->gc_data->last_found.toTime_t())) {
+ wpt_tmp->AllocGCData()->last_found = gc_log_date;
+ }
+@@ -1423,7 +1423,7 @@
+ fprint_xml_chain(tag->child, wpt);
+ }
+ if (wpt && wpt->gc_data->exported.isValid() &&
+- tag->tagname.compare("groundspeak:cache") == 0) {
++ tag->tagname.compare(QLatin1String("groundspeak:cache")) == 0) {
+ writer->writeTextElement("time",
+ wpt->gc_data->exported.toPrettyString());
+ }
diff --git a/astro/gpsbabel/files/patch-lowranceusr.cc b/astro/gpsbabel/files/patch-lowranceusr.cc
new file mode 100644
index 000000000000..a43279a946b0
--- /dev/null
+++ b/astro/gpsbabel/files/patch-lowranceusr.cc
@@ -0,0 +1,11 @@
+--- lowranceusr.cc.orig 2018-04-11 18:16:00 UTC
++++ lowranceusr.cc
+@@ -767,7 +767,7 @@ lowranceusr_waypt_disp(const Waypoint* w
+
+ gbfputint32(Time, file_out);
+
+- if (get_cache_icon(wpt) && wpt->icon_descr.compare("Geocache Found") == 0) {
++ if (get_cache_icon(wpt) && wpt->icon_descr.compare(QLatin1String("Geocache Found")) == 0) {
+ SymbolId = lowranceusr_find_icon_number_from_desc(get_cache_icon(wpt));
+ } else {
+ SymbolId = lowranceusr_find_icon_number_from_desc(wpt->icon_descr);
diff --git a/astro/gpsbabel/files/patch-magproto.cc b/astro/gpsbabel/files/patch-magproto.cc
new file mode 100644
index 000000000000..9457363d4d55
--- /dev/null
+++ b/astro/gpsbabel/files/patch-magproto.cc
@@ -0,0 +1,17 @@
+--- magproto.cc.orig 2018-04-11 18:16:46 UTC
++++ magproto.cc
+@@ -819,11 +819,11 @@ mag_rd_init_common(const QString& portna
+ */
+ QString exten = QFileInfo(curfname).suffix();
+ if (exten.length() > 0) {
+- if (0 == exten.compare("upt", Qt::CaseInsensitive)) {
++ if (0 == exten.compare(QLatin1String("upt"), Qt::CaseInsensitive)) {
+ extension_hint = WPTDATAMASK;
+- } else if (0 == exten.compare("log", Qt::CaseInsensitive)) {
++ } else if (0 == exten.compare(QLatin1String("log"), Qt::CaseInsensitive)) {
+ extension_hint = TRKDATAMASK;
+- } else if (0 == exten.compare("rte", Qt::CaseInsensitive)) {
++ } else if (0 == exten.compare(QLatin1String("rte"), Qt::CaseInsensitive)) {
+ extension_hint = RTEDATAMASK;
+ }
+ }
diff --git a/astro/gpsbabel/files/patch-psitrex.cc b/astro/gpsbabel/files/patch-psitrex.cc
new file mode 100644
index 000000000000..0c9ef0076d94
--- /dev/null
+++ b/astro/gpsbabel/files/patch-psitrex.cc
@@ -0,0 +1,11 @@
+--- psitrex.cc.orig 2018-04-11 18:17:53 UTC
++++ psitrex.cc
+@@ -363,7 +363,7 @@ psit_waypoint_w(gbfile* psit_file, const
+
+ icon = gt_find_icon_number_from_desc(wpt->icon_descr, PCX);
+
+- if (get_cache_icon(wpt) && wpt->icon_descr.compare("Geocache Found") != 0) {
++ if (get_cache_icon(wpt) && wpt->icon_descr.compare(QLatin1String("Geocache Found")) != 0) {
+ icon = gt_find_icon_number_from_desc(get_cache_icon(wpt), PCX);
+ }
+
diff --git a/astro/gpsbabel/files/patch-tef_xml.cc b/astro/gpsbabel/files/patch-tef_xml.cc
new file mode 100644
index 000000000000..53902dc4496b
--- /dev/null
+++ b/astro/gpsbabel/files/patch-tef_xml.cc
@@ -0,0 +1,57 @@
+--- tef_xml.cc.orig 2018-04-11 18:10:39 UTC
++++ tef_xml.cc
+@@ -72,11 +72,11 @@
+ bool valid = false;
+
+ foreach(QXmlStreamAttribute attr, *attrv) {
+- if (attr.name().compare("Comment", Qt::CaseInsensitive) == 0) {
+- if (attr.value().compare("TourExchangeFormat", Qt::CaseInsensitive) == 0) {
++ if (attr.name().compare(QLatin1String("Comment"), Qt::CaseInsensitive) == 0) {
++ if (attr.value().compare(QLatin1String("TourExchangeFormat"), Qt::CaseInsensitive) == 0) {
+ valid = true;
+ }
+- } else if (attr.name().compare("Version", Qt::CaseInsensitive) == 0) {
++ } else if (attr.name().compare(QLatin1String("Version"), Qt::CaseInsensitive) == 0) {
+ version = attr.value().toString().toDouble();
+ }
+ }
+@@ -95,9 +95,9 @@
+ {
+ route = route_head_alloc();
+ foreach(QXmlStreamAttribute attr, *attrv) {
+- if (attr.name().compare("Name", Qt::CaseInsensitive) == 0) {
++ if (attr.name().compare(QLatin1String("Name"), Qt::CaseInsensitive) == 0) {
+ route->rte_name = attr.value().toString().trimmed();
+- } else if (attr.name().compare("Software", Qt::CaseInsensitive) == 0) {
++ } else if (attr.name().compare(QLatin1String("Software"), Qt::CaseInsensitive) == 0) {
+ route->rte_desc = attr.value().toString().trimmed();
+ }
+ }
+@@ -248,20 +248,20 @@
+ QString attrstr = attr.value().toString();
+ QByteArray attrtext = attrstr.toUtf8();
+
+- if (attr.name().compare("SegDescription", Qt::CaseInsensitive) == 0) {
++ if (attr.name().compare(QLatin1String("SegDescription"), Qt::CaseInsensitive) == 0) {
+ wpt_tmp->shortname = attrstr.trimmed();
+- } else if (attr.name().compare("PointDescription", Qt::CaseInsensitive) == 0) {
++ } else if (attr.name().compare(QLatin1String("PointDescription"), Qt::CaseInsensitive) == 0) {
+ wpt_tmp->description = attrstr.trimmed();
+- } else if (attr.name().compare("ViaStation", Qt::CaseInsensitive) == 0 &&
+- attr.value().compare("true", Qt::CaseInsensitive) == 0) {
++ } else if (attr.name().compare(QLatin1String("ViaStation"), Qt::CaseInsensitive) == 0 &&
++ attr.value().compare(QLatin1String("true"), Qt::CaseInsensitive) == 0) {
+ wpt_tmp->wpt_flags.fmt_use = 1; /* only a flag */
+
+ /* new in TEF V2 */
+- } else if (attr.name().compare("Instruction", Qt::CaseInsensitive) == 0) {
++ } else if (attr.name().compare(QLatin1String("Instruction"), Qt::CaseInsensitive) == 0) {
+ wpt_tmp->description = attrstr.trimmed();
+- } else if (attr.name().compare("Altitude", Qt::CaseInsensitive) == 0) {
++ } else if (attr.name().compare(QLatin1String("Altitude"), Qt::CaseInsensitive) == 0) {
+ wpt_tmp->altitude = attrstr.toDouble();
+- } else if (attr.name().compare("TimeStamp", Qt::CaseInsensitive) == 0) {
++ } else if (attr.name().compare(QLatin1String("TimeStamp"), Qt::CaseInsensitive) == 0) {
+ /* nothing for the moment */
+ }
+ }
diff --git a/astro/gpsbabel/files/patch-unicsv.cc b/astro/gpsbabel/files/patch-unicsv.cc
new file mode 100644
index 000000000000..70762525370c
--- /dev/null
+++ b/astro/gpsbabel/files/patch-unicsv.cc
@@ -0,0 +1,20 @@
+--- unicsv.cc.orig 2018-04-11 18:21:19 UTC
++++ unicsv.cc
+@@ -430,13 +430,13 @@ unicsv_parse_time(const QString& str, in
+ static status_type
+ unicsv_parse_status(const QString& str)
+ {
+- if (str.compare("true", Qt::CaseInsensitive) == 0 ||
+- str.compare("yes", Qt::CaseInsensitive) == 0 ||
++ if (str.compare(QLatin1String("true"), Qt::CaseInsensitive) == 0 ||
++ str.compare(QLatin1String("yes"), Qt::CaseInsensitive) == 0 ||
+ str == "1") {
+ return status_true;
+ }
+- if (str.compare("false", Qt::CaseInsensitive) == 0 ||
+- str.compare("no", Qt::CaseInsensitive) == 0 ||
++ if (str.compare(QLatin1String("false"), Qt::CaseInsensitive) == 0 ||
++ str.compare(QLatin1String("no"), Qt::CaseInsensitive) == 0 ||
+ str == "0") {
+ return status_false;
+ }