aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-01-06 01:27:29 +0800
committerpav <pav@FreeBSD.org>2009-01-06 01:27:29 +0800
commit6eb721976122cec5dc4f68d03663c569490e76b2 (patch)
treed35b575ab8f13de2b3da1f0869be1ebae3bad396 /astro
parent3afadc02a311b171583adca2cf5da95a05850c5a (diff)
downloadfreebsd-ports-gnome-6eb721976122cec5dc4f68d03663c569490e76b2.tar.gz
freebsd-ports-gnome-6eb721976122cec5dc4f68d03663c569490e76b2.tar.zst
freebsd-ports-gnome-6eb721976122cec5dc4f68d03663c569490e76b2.zip
- Remove conditional checks relevant only on FreeBSD 5.x and older
Diffstat (limited to 'astro')
-rw-r--r--astro/boinc-einsteinathome/Makefile13
-rw-r--r--astro/gpsman/Makefile4
-rw-r--r--astro/libnova/Makefile8
-rw-r--r--astro/xmoontool/Makefile8
4 files changed, 8 insertions, 25 deletions
diff --git a/astro/boinc-einsteinathome/Makefile b/astro/boinc-einsteinathome/Makefile
index b6747e2e61fb..b106c59778b2 100644
--- a/astro/boinc-einsteinathome/Makefile
+++ b/astro/boinc-einsteinathome/Makefile
@@ -15,16 +15,11 @@ DISTNAME= einstein_S5R3_${PORTVERSION}_i386-unknown-freebsd
MAINTAINER= pav@FreeBSD.org
COMMENT= Search for gravitational waves, a distributed computing project
-.include <bsd.port.pre.mk>
+LIB_DEPENDS= c.5:${PORTSDIR}/misc/compat5x
+RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
ONLY_FOR_ARCHS= i386 amd64
-.if ${OSVERSION} >= 600000
-LIB_DEPENDS+= c.5:${PORTSDIR}/misc/compat5x
-.endif
-
-RUN_DEPENDS+= boinc_client:${PORTSDIR}/net/boinc-client
-
NO_BUILD= yes
NO_WRKSUBDIR= yes
STRIP= #
@@ -37,7 +32,9 @@ BOINC_HOME?= /var/db/boinc
EINSTEIN_SITE= einstein.phys.uwm.edu
EINSTEIN_BINARY=${DISTNAME}
-.if ${ARCH} == amd64 && ${OSVERSION} >= 600000
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == amd64
AMD64= ""
.else
AMD64= "@comment "
diff --git a/astro/gpsman/Makefile b/astro/gpsman/Makefile
index c99b0b3cb7a4..592620009e02 100644
--- a/astro/gpsman/Makefile
+++ b/astro/gpsman/Makefile
@@ -27,9 +27,7 @@ NO_BUILD= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600000
-GPSMAN_DEFAULT_PORT?= /dev/cuaa0
-.elif ${OSVERSION} < 800045
+.if ${OSVERSION} < 800045
GPSMAN_DEFAULT_PORT?= /dev/cuad0
.else
GPSMAN_DEFAULT_PORT?= /dev/cuau0
diff --git a/astro/libnova/Makefile b/astro/libnova/Makefile
index 204677fdfe5a..3a1bf68ae927 100644
--- a/astro/libnova/Makefile
+++ b/astro/libnova/Makefile
@@ -21,16 +21,10 @@ USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 503000
-IGNORE= requires FreeBSD 5.3 or higher
-.endif
-
#post-extract:
# @${TAR} xf ${WRKDIR}/${PORTNAME}/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} -C ${WRKDIR}
post-patch:
@${REINPLACE_CMD} -e 's|^CFLAGS=|#CFLAGS=|g' ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/astro/xmoontool/Makefile b/astro/xmoontool/Makefile
index 522e062073d4..3f6d1d30e82c 100644
--- a/astro/xmoontool/Makefile
+++ b/astro/xmoontool/Makefile
@@ -20,12 +20,6 @@ MAN1= xmoontool.1
PORTDOCS= NOTES
PLIST_FILES= bin/xmoontool
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 503000 # libnova currently not available here!
-WITHOUT_LIBNOVA= yes
-.endif
-
.if defined(WITHOUT_LIBNOVA)
MAKE_ENV+= WITHOUT_LIBNOVA=yes
.else
@@ -59,4 +53,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>