aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorreg <reg@FreeBSD.org>2000-10-05 14:57:56 +0800
committerreg <reg@FreeBSD.org>2000-10-05 14:57:56 +0800
commitcea38f8422a3eeac06b3ce4a5828580a5812d2cc (patch)
tree9703d7928f2f462fdf308bf7d14164f8f8459828 /astro
parent4495def283d3b8c777e1eb5b958cedb25b1aa16b (diff)
downloadfreebsd-ports-gnome-cea38f8422a3eeac06b3ce4a5828580a5812d2cc.tar.gz
freebsd-ports-gnome-cea38f8422a3eeac06b3ce4a5828580a5812d2cc.tar.zst
freebsd-ports-gnome-cea38f8422a3eeac06b3ce4a5828580a5812d2cc.zip
Implement WANT_IMLIB and USE_IMLIB.
Diffstat (limited to 'astro')
-rw-r--r--astro/xplanet/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/astro/xplanet/Makefile b/astro/xplanet/Makefile
index 8255252b02a9..8b1c80efed54 100644
--- a/astro/xplanet/Makefile
+++ b/astro/xplanet/Makefile
@@ -16,20 +16,19 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= will@FreeBSD.org
-LIB_DEPENDS= Imlib.5:${PORTSDIR}/graphics/imlib \
- jpeg.9:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
USE_X_PREFIX= yes
USE_MESA= yes
USE_GMAKE= yes
+USE_IMLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-map-extension=jpg
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
- CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm"
-MAKE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
- CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
+MAKE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm"
+
MAN1= xplanet.1 xplanetbg.1 tkxplanet.1 tzcoord.pl.1
.include <bsd.port.pre.mk>