aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-06-22 07:52:37 +0800
committerlinimon <linimon@FreeBSD.org>2018-06-22 07:52:37 +0800
commitd92159e623f6d6aa22976afecb662f299f46dc25 (patch)
tree43e3e96b51c1b5ffe0081b680c450409ce4bb954 /astro
parent173ef5b72bc329eaf5be116b2994334e00137d30 (diff)
downloadfreebsd-ports-gnome-d92159e623f6d6aa22976afecb662f299f46dc25.tar.gz
freebsd-ports-gnome-d92159e623f6d6aa22976afecb662f299f46dc25.tar.zst
freebsd-ports-gnome-d92159e623f6d6aa22976afecb662f299f46dc25.zip
Mark as broken on aarch64, and, where appropriate, armvX.
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'astro')
-rw-r--r--astro/astrometry/Makefile6
-rw-r--r--astro/boinc-setiathome/Makefile6
2 files changed, 10 insertions, 2 deletions
diff --git a/astro/astrometry/Makefile b/astro/astrometry/Makefile
index f80ab948dd34..95855275bc39 100644
--- a/astro/astrometry/Makefile
+++ b/astro/astrometry/Makefile
@@ -13,6 +13,10 @@ COMMENT= Software for describing astronomical images
LICENSE= GPLv2
+BROKEN_aarch64= fails to link: os-features-test.c:10: undefined symbol 'canonicalize_file_name'
+BROKEN_armv6= fails to link: os-features-test.c:10: undefined symbol 'canonicalize_file_name'
+BROKEN_armv7= fails to link: os-features-test.c:10: undefined symbol 'canonicalize_file_name'
+
BUILD_DEPENDS= ${PYNUMPY}
LIB_DEPENDS= libcairo.so:graphics/cairo \
libcfitsio.so:astro/cfitsio \
@@ -27,7 +31,7 @@ ALL_TARGET= all extra
MAKE_ENV= INSTALL_DIR=${STAGEDIR}${PREFIX}/${PORTNAME}
MAKE_JOBS_UNSAFE= yes
SUB_FILES= pkg-message
-LDFLAGS= -lz
+LDFLAGS+= -lz
post-patch:
@${REINPLACE_CMD} -E 's,python (setup|-c),${PYTHON_CMD} \1,' \
diff --git a/astro/boinc-setiathome/Makefile b/astro/boinc-setiathome/Makefile
index 6b657ad9a161..3fa9b1c055d4 100644
--- a/astro/boinc-setiathome/Makefile
+++ b/astro/boinc-setiathome/Makefile
@@ -14,7 +14,11 @@ COMMENT= Setiathome Enhanced for BOINC
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= does not compile: analyzeFuncs_altivec.cpp: CoreServices/CoreServices.h: No such file or directory
+BROKEN_aarch64= fails to link: vector/analyzeFuncs_vector.cpp:(.data+0x38): undefined symbol 'vfp_GetPowerSpectrum(float (*) [2], float*, int)'
+BROKEN_armv6= fails to compile: vector/analyzeFuncs_neon.S:178:17: invalid instruction, did you mean: neg?
+BROKEN_armv7= fails to compile: vector/analyzeFuncs_neon.S:178:17: invalid instruction, did you mean: neg?
+BROKEN_powerpc64= fails to compile: analyzeFuncs_altivec.cpp: CoreServices/CoreServices.h: No such file or directory
+
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:math/fftw3
RUN_DEPENDS= boinc_client:net/boinc-client
LIB_DEPENDS= libfftw3f.so:math/fftw3-float