aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-31 12:53:11 +0800
committeredwin <edwin@FreeBSD.org>2003-08-31 12:53:11 +0800
commite0904f3685c360d5ccb77b2336732a16271cd1e8 (patch)
tree0d83cf654f022170c6f84823f139ed3c53b8e53d /astro
parent5b3cb1a25424786767cfe1365eac3ee03d61fe4a (diff)
downloadfreebsd-ports-gnome-e0904f3685c360d5ccb77b2336732a16271cd1e8.tar.gz
freebsd-ports-gnome-e0904f3685c360d5ccb77b2336732a16271cd1e8.tar.zst
freebsd-ports-gnome-e0904f3685c360d5ccb77b2336732a16271cd1e8.zip
perl -> reinplace
PR: ports/47652 Submitted by: Simon 'portlint' Schubert <corecode@corecode.ath.cx>
Diffstat (limited to 'astro')
-rw-r--r--astro/spacechart/Makefile3
-rw-r--r--astro/starplot/Makefile5
2 files changed, 5 insertions, 3 deletions
diff --git a/astro/spacechart/Makefile b/astro/spacechart/Makefile
index 540fbb467fa2..0180c5048c62 100644
--- a/astro/spacechart/Makefile
+++ b/astro/spacechart/Makefile
@@ -18,13 +18,14 @@ COMMENT= SpaceChart is a star chart viewer for GNOME
LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext
USE_X_PREFIX= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomelibs
CONFIGURE_ARGS= --without-included-gettext --datadir=${PREFIX}/share
# trick it into using ports installed gettext
post-patch:
- @${PERL} -pi -ne "s|(INTLLIBS =).*$$|\1-I${LOCALBASE}/lib -lintl|" \
+ @${REINPLACE_CMD} -e 's|\(INTLLIBS =\).*$$|\1-I${LOCALBASE}/lib -lintl|' \
${WRKSRC}/src/Makefile.in
pre-build:
diff --git a/astro/starplot/Makefile b/astro/starplot/Makefile
index aa4d23eeb15b..7147e4a436e2 100644
--- a/astro/starplot/Makefile
+++ b/astro/starplot/Makefile
@@ -14,6 +14,7 @@ MAINTAINER= pat@FreeBSD.org
COMMENT= 3-dimensional viewer for star charts
USE_X_PREFIX= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
USE_GNOME= gtk12
USE_XPM= yes
@@ -23,10 +24,10 @@ MAKE_ENV= DATADIR="${DATADIR}" \
MAN1= starplot.1 starconvert.1
pre-patch:
- @${PERL} -pi.orig -e 's|DATADIR|${DATADIR}|; s|DOCDIR|${DOCSDIR}|; \
+ @${REINPLACE_CMD} -e 's|DATADIR|${DATADIR}|; s|DOCDIR|${DOCSDIR}|; \
s|BINARYNAME|${PORTNAME}|; s|CONVERTNAME|starconvert|' \
${WRKSRC}/doc/man/*
- @${PERL} -pi.orig -e 's|/usr/local/share/starplot|${DATADIR}|; \
+ @${REINPLACE_CMD} -e 's|/usr/local/share/starplot|${DATADIR}|; \
s|/usr/local/share/doc/starplot|${DOCSDIR}|' \
${WRKSRC}/gui/starplot.h