aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /astro
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'astro')
-rw-r--r--astro/celestia/Makefile4
-rw-r--r--astro/fowsr/Makefile5
-rw-r--r--astro/glunarclock/Makefile6
-rw-r--r--astro/gpsdrive/Makefile4
-rw-r--r--astro/libroadnav/Makefile3
-rw-r--r--astro/mymoon/Makefile4
-rw-r--r--astro/nightfall/Makefile4
-rw-r--r--astro/nova/Makefile4
-rw-r--r--astro/openuniverse/Makefile6
-rw-r--r--astro/rmap/Makefile4
-rw-r--r--astro/roadnav/Makefile3
-rw-r--r--astro/starplot/Makefile4
-rw-r--r--astro/viking/Makefile4
-rw-r--r--astro/xplanet/Makefile4
-rw-r--r--astro/xtide/Makefile5
15 files changed, 32 insertions, 32 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 93c9d90d6de4..7e3948e2b5c6 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -27,8 +27,8 @@ USE_LUA= 5.0+ # should be optional, but the build fails without it
WANT_GNOME= yes
CXXFLAGS+= -fsigned-char # fix text rendering (see Gentoo bug 316573)
-CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
UI_LIST= glut gtk gnome kde
CELESTIA_UI?= glut
diff --git a/astro/fowsr/Makefile b/astro/fowsr/Makefile
index 703bfc341f44..d7b50d4827b6 100644
--- a/astro/fowsr/Makefile
+++ b/astro/fowsr/Makefile
@@ -38,9 +38,8 @@ do-install:
.if ${OSVERSION} < 800069
LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
-CFLAGS+= -I${PREFIX}/include
-LDFLAGS+= "-L${PREFIX}/lib"
-MAKE_ENV+= "LDFLAGS=${LDFLAGS}"
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.endif
.include <bsd.port.post.mk>
diff --git a/astro/glunarclock/Makefile b/astro/glunarclock/Makefile
index 23043b791cc2..db464fb286d6 100644
--- a/astro/glunarclock/Makefile
+++ b/astro/glunarclock/Makefile
@@ -20,9 +20,9 @@ USE_GNOME= gnomehack gnomepanel gnomeprefix intlhack libgnomeui
USE_GMAKE= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include `pkg-config --cflags libgnomeui-2.0`" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- LIBS="`pkg-config --libs libgnomeui-2.0`"
+CPPFLAGS+= -I${LOCALBASE}/include `pkg-config --cflags libgnomeui-2.0`
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= LIBS="`pkg-config --libs libgnomeui-2.0`"
INSTALLS_OMF= yes
PLIST_SUB= VERSION="${PORTVERSION:R}"
diff --git a/astro/gpsdrive/Makefile b/astro/gpsdrive/Makefile
index 3284c66b891f..68fbb18a8f9d 100644
--- a/astro/gpsdrive/Makefile
+++ b/astro/gpsdrive/Makefile
@@ -23,8 +23,8 @@ USE_GNOME= gtk20
USE_AUTOTOOLS= libtool
MAKE_JOBS_UNSAFE= yes
-CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
- LDFLAGS=-L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-garmin
USE_LDCONFIG= yes
diff --git a/astro/libroadnav/Makefile b/astro/libroadnav/Makefile
index 481ad4b6913f..720cac2e828c 100644
--- a/astro/libroadnav/Makefile
+++ b/astro/libroadnav/Makefile
@@ -21,7 +21,8 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-wx-prefix=${LOCALBASE} --with-wx-config=${WX_CONFIG}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= *
diff --git a/astro/mymoon/Makefile b/astro/mymoon/Makefile
index 6c5762f5842d..598602e846e3 100644
--- a/astro/mymoon/Makefile
+++ b/astro/mymoon/Makefile
@@ -23,8 +23,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/mymoon
diff --git a/astro/nightfall/Makefile b/astro/nightfall/Makefile
index f8bc9b620c7f..f7c58b1f542f 100644
--- a/astro/nightfall/Makefile
+++ b/astro/nightfall/Makefile
@@ -23,8 +23,8 @@ USE_PERL5= yes
USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-locale-prefix=${PREFIX}/share/locale
MAN1= nightfall.1
diff --git a/astro/nova/Makefile b/astro/nova/Makefile
index 3d8a6c8fbf4b..0dc70a18da4c 100644
--- a/astro/nova/Makefile
+++ b/astro/nova/Makefile
@@ -27,8 +27,8 @@ LIB_DEPENDS= sigc-1.2.5:${PORTSDIR}/devel/libsigc++12 \
RUN_DEPENDS= ${LOCALBASE}/share/nova/catalogs/sky2000.ncd:${PORTSDIR}/astro/sky2000
USE_AUTOTOOLS= libtool
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --datadir=${DATADIR}
.include <bsd.port.mk>
diff --git a/astro/openuniverse/Makefile b/astro/openuniverse/Makefile
index 4f0ec02377f6..cb1915fe1d93 100644
--- a/astro/openuniverse/Makefile
+++ b/astro/openuniverse/Makefile
@@ -25,9 +25,9 @@ USE_GMAKE= yes
CONFIGURE_ARGS= --includedir="${LOCALBASE}/include" \
--libdir="${LOCALBASE}/lib" \
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/GL -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lm" \
- LIBS="-lcompat" PTHREAD_LIBS="${PTHREAD_LIBS}"
+CONFIGURE_ENV= LIBS="-lcompat" PTHREAD_LIBS="${PTHREAD_LIBS}"
+CPPFLAGS+= -I${LOCALBASE}/include/GL -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lm
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
.include <bsd.port.mk>
diff --git a/astro/rmap/Makefile b/astro/rmap/Makefile
index a7dd8ad844a6..c5f94e38e534 100644
--- a/astro/rmap/Makefile
+++ b/astro/rmap/Makefile
@@ -20,7 +20,7 @@ MAN1= rmap.1
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CPPFLAGS= -I${LOCALBASE}/include
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>
diff --git a/astro/roadnav/Makefile b/astro/roadnav/Makefile
index ef93ff369dd2..b3f6127c6b15 100644
--- a/astro/roadnav/Makefile
+++ b/astro/roadnav/Makefile
@@ -23,7 +23,8 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-wx-prefix=${LOCALBASE} --with-wx-config=${WX_CONFIG}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= *
diff --git a/astro/starplot/Makefile b/astro/starplot/Makefile
index 5c2d45b88b37..1a4b46958f92 100644
--- a/astro/starplot/Makefile
+++ b/astro/starplot/Makefile
@@ -18,8 +18,8 @@ USE_GNOME= gnomehack gtk20
USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAN1= starconvert.1 starpkg.1 starplot.1
diff --git a/astro/viking/Makefile b/astro/viking/Makefile
index 4d6d9f826a92..2cc97af5ec01 100644
--- a/astro/viking/Makefile
+++ b/astro/viking/Makefile
@@ -19,8 +19,8 @@ RUN_DEPENDS= gpsbabel:${PORTSDIR}/astro/gpsbabel
OPTIONS= GPSD "Enable realtime GPS tracking" off
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CPPFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CPPFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
diff --git a/astro/xplanet/Makefile b/astro/xplanet/Makefile
index 6db314e8a472..a07a84294885 100644
--- a/astro/xplanet/Makefile
+++ b/astro/xplanet/Makefile
@@ -17,8 +17,8 @@ GNU_CONFIGURE= yes
USE_XORG= xt xscrnsaver
USE_GNOME= #
CONFIGURE_ARGS= --with-map-extension=jpg
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lm"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -lm"
+CPPFLAGS+= -I${LOCALBASE}/include
OPTIONS= FREETYPE "Enable Freetype support" on \
PANGO "Enable PANGO support" on \
diff --git a/astro/xtide/Makefile b/astro/xtide/Makefile
index 6eb3a26c8868..e824482b68dd 100644
--- a/astro/xtide/Makefile
+++ b/astro/xtide/Makefile
@@ -24,13 +24,12 @@ LICENSE= GPLv3
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= tide.1
MAN8= xttpd.8
-CPPFLAGS= -I../${TCD_DISTNAME} -I${LOCALBASE}/include/libpng
-LDFLAGS= -L../${TCD_DISTNAME}/.libs -L${LOCALBASE}/lib
+CPPFLAGS+= -I../${TCD_DISTNAME} -I${LOCALBASE}/include/libpng
+LDFLAGS+= -L../${TCD_DISTNAME}/.libs -L${LOCALBASE}/lib
MAKE_JOBS_SAFE= yes
TCD_DISTNAME= libtcd-2.2.5