aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-08-31 05:32:04 +0800
committermarino <marino@FreeBSD.org>2014-08-31 05:32:04 +0800
commitf7e557b2b6e726140779c36b61c0658c751692f9 (patch)
tree553fb6f1038f520f3a8a6d7aead1dded5d3c9f82 /astro
parent94b56f363ed014f2bc1bb180f1a0b1d2d4296dc0 (diff)
downloadfreebsd-ports-gnome-f7e557b2b6e726140779c36b61c0658c751692f9.tar.gz
freebsd-ports-gnome-f7e557b2b6e726140779c36b61c0658c751692f9.tar.zst
freebsd-ports-gnome-f7e557b2b6e726140779c36b61c0658c751692f9.zip
Add new port astro/geographic lib
PR: 187280 Submitted by: Tatsuki Makino GeographicLib is a small set of C++ classes for performing conversions between geographic, UTM, UPS, MGRS, geocentric, and local cartesian coordinates, for gravity (e.g., EGM2008), geoid height, and geomagnetic field (e.g., WMM2010) calculations, and for solving geodesic problems. The library may be used from .NET applications using the NETGeographicLib wrapper library. It is a suitable replacement for the core functionality provided by geotrans.
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/geographiclib/Makefile91
-rw-r--r--astro/geographiclib/distinfo30
-rw-r--r--astro/geographiclib/pkg-descr10
-rw-r--r--astro/geographiclib/pkg-plist194
5 files changed, 326 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index ef7cbdd7d19e..dea231bd9ddb 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -18,6 +18,7 @@
SUBDIR += fowsr
SUBDIR += foxtrotgps
SUBDIR += garmindev
+ SUBDIR += geographiclib
SUBDIR += gkrellmoon2
SUBDIR += gmapcatcher
SUBDIR += google-earth
diff --git a/astro/geographiclib/Makefile b/astro/geographiclib/Makefile
new file mode 100644
index 000000000000..a73f015647ee
--- /dev/null
+++ b/astro/geographiclib/Makefile
@@ -0,0 +1,91 @@
+# Created by: Tatsuki Makino <tatsuki_makino@hotmail.com>
+# $FreeBSD$
+
+PORTNAME= geographiclib
+PORTVERSION= 1.37
+CATEGORIES= astro
+MASTER_SITES= SF/geographiclib/distrib \
+ SF/geographiclib:geoids,gravity,magnetic
+DISTNAME= GeographicLib-${PORTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
+DIST_SUBDIR= GeographicLib
+
+MAINTAINER= tatsuki_makino@hotmail.com
+COMMENT= Library for geographic projections
+
+LICENSE= MIT
+
+USES= gmake libtool python
+USE_GCC= any
+USE_AUTOTOOLS= autoconf
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+NO_WRKSUBDIR= yes
+INSTALL_TARGET= install-strip
+WRKSRC= ${WRKDIR}/${DISTNAME}
+MAKE_ARGS= pythondir=${PYTHON_SITELIBDIR}/geographiclib
+PORTDOCS= *
+
+OPTIONS_SUB= yes
+OPTIONS_DEFAULT= GEOID_EGM96_5 GRAVITY_EGM96 GRAVITY_WGS84 \
+ MAGNETIC_WMM2010 MAGNETIC_IGRF11
+
+GEOID_NAMES:= egm84-30 egm84-15 egm96-15 egm96-5 \
+ egm2008-5 egm2008-2_5 egm2008-1
+GRAVITY_NAMES:= egm84 egm96 egm2008 wgs84
+MAGNETIC_NAMES:= wmm2010 igrf11 emm2010
+
+.for n in ${GEOID_NAMES}
+OPTIONS_DEFINE+= GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}
+GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DESC= Install ${n} geoid dataset
+GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DISTFILES= geoids-distrib/${n}.tar.bz2:geoids
+MAKESUM_DISTFILES+= geoids-distrib/${n}.tar.bz2:geoids
+MAKESUM_OPTIONS_DEFAULT+= GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}
+.endfor
+.for n in ${GRAVITY_NAMES}
+OPTIONS_DEFINE+= GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}
+GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DESC= Install ${n} gravity model
+GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DISTFILES= gravity-distrib/${n}.tar.bz2:gravity
+MAKESUM_DISTFILES+= gravity-distrib/${n}.tar.bz2:gravity
+MAKESUM_OPTIONS_DEFAULT+= GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}
+.endfor
+.for n in ${MAGNETIC_NAMES}
+OPTIONS_DEFINE+= MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}
+MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DESC= Install ${n} magnetic model
+MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DISTFILES= magnetic-distrib/${n}.tar.bz2:magnetic
+MAKESUM_DISTFILES+= magnetic-distrib/${n}.tar.bz2:magnetic
+MAKESUM_OPTIONS_DEFAULT+= MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}
+.endfor
+
+# Memorandum: use "make fetch makesum" to makesum all distfiles.
+.ifmake makesum || distclean
+OPTIONS_DEFAULT= ${MAKESUM_OPTIONS_DEFAULT}
+.endif
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ ${REINPLACE_CMD} -e '/wget/s/wget -O/fetch -o /' \
+ ${WRKSRC}/tools/geographiclib-get-*.sh
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/geoids \
+ ${STAGEDIR}${DATADIR}/gravity \
+ ${STAGEDIR}${DATADIR}/magnetic
+ ${TOUCH} ${STAGEDIR}${DATADIR}/geoids/.keep \
+ ${STAGEDIR}${DATADIR}/gravity/.keep \
+ ${STAGEDIR}${DATADIR}/magnetic/.keep
+.if ${PORT_OPTIONS:MGEOID_*}
+ (cd ${WRKDIR}/geoids && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/geoids)
+.endif
+.if ${PORT_OPTIONS:MGRAVITY_*}
+ (cd ${WRKDIR}/gravity && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/gravity)
+.endif
+.if ${PORT_OPTIONS:MMAGNETIC_*}
+ (cd ${WRKDIR}/magnetic && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/magnetic)
+.endif
+
+.include <bsd.port.mk>
diff --git a/astro/geographiclib/distinfo b/astro/geographiclib/distinfo
new file mode 100644
index 000000000000..cf30c1432691
--- /dev/null
+++ b/astro/geographiclib/distinfo
@@ -0,0 +1,30 @@
+SHA256 (GeographicLib/GeographicLib-1.37.tar.gz) = ebf2dec42d8b738024eb29ad36976ff8ea550eb4c005a07cb1b2abbc2e4d3de5
+SIZE (GeographicLib/GeographicLib-1.37.tar.gz) = 1963202
+SHA256 (GeographicLib/geoids-distrib/egm2008-1.tar.bz2) = bdb382d0be7ece9142450eacc24b7b7f0889ee3e0ba4f535b04ec383f94c0fb5
+SIZE (GeographicLib/geoids-distrib/egm2008-1.tar.bz2) = 162388303
+SHA256 (GeographicLib/geoids-distrib/egm2008-2_5.tar.bz2) = d602e13446a4a4a23f39aecfe6a2a0760a1bc6c1b497482c2ebc9f7d513be699
+SIZE (GeographicLib/geoids-distrib/egm2008-2_5.tar.bz2) = 34927299
+SHA256 (GeographicLib/geoids-distrib/egm2008-5.tar.bz2) = 9a57c14330ac609132d324906822a9da9de265ad9b9087779793eb7080852970
+SIZE (GeographicLib/geoids-distrib/egm2008-5.tar.bz2) = 10414793
+SHA256 (GeographicLib/geoids-distrib/egm84-15.tar.bz2) = 579e3dad2f33b54f1fed16edb3ed9d4ae8cdad6ea064f7375af30d678eb2e51c
+SIZE (GeographicLib/geoids-distrib/egm84-15.tar.bz2) = 1475184
+SHA256 (GeographicLib/geoids-distrib/egm84-30.tar.bz2) = 18bc3e2b55c4f9f2f9ba8d14380dc47cc5c0d00dc2363b723d2305f30a91498e
+SIZE (GeographicLib/geoids-distrib/egm84-30.tar.bz2) = 416481
+SHA256 (GeographicLib/geoids-distrib/egm96-15.tar.bz2) = 8b1ebad1ebae0a045502d0edb9cc51553da1d3914f01e07470c11b3bed75048e
+SIZE (GeographicLib/geoids-distrib/egm96-15.tar.bz2) = 1490277
+SHA256 (GeographicLib/geoids-distrib/egm96-5.tar.bz2) = c46224f8f723dc915d97179f4e1580a98d6c742fe2b82cd8fef0ecaaad13e614
+SIZE (GeographicLib/geoids-distrib/egm96-5.tar.bz2) = 10225152
+SHA256 (GeographicLib/gravity-distrib/egm2008.tar.bz2) = 54c1f511892a3d6a1362fb91a8f65efb4bd56e1cf4ff205344e003bd5074ed91
+SIZE (GeographicLib/gravity-distrib/egm2008.tar.bz2) = 74456990
+SHA256 (GeographicLib/gravity-distrib/egm84.tar.bz2) = 7ebec3b2aa2e88581470cd776299942c2300d797316b431c7a7da4ac2c31d80e
+SIZE (GeographicLib/gravity-distrib/egm84.tar.bz2) = 258023
+SHA256 (GeographicLib/gravity-distrib/egm96.tar.bz2) = 6fea4c6bd56ff8ac53dbdad8d5dd505c855471d0354c4abc5c5fe048bf8350c1
+SIZE (GeographicLib/gravity-distrib/egm96.tar.bz2) = 2055724
+SHA256 (GeographicLib/gravity-distrib/wgs84.tar.bz2) = 4cf4f7e533261986b25f9e3c929d846044e0fb2b9c35f301df545c335491f2e7
+SIZE (GeographicLib/gravity-distrib/wgs84.tar.bz2) = 807
+SHA256 (GeographicLib/magnetic-distrib/emm2010.tar.bz2) = aa8782fddb505d8dc24e3dd26784712c1b1848227e23cdcb4e4f2d3ed49d9e14
+SIZE (GeographicLib/magnetic-distrib/emm2010.tar.bz2) = 3627692
+SHA256 (GeographicLib/magnetic-distrib/igrf11.tar.bz2) = 1289557fe660052c8fb42eb62d3307e8efd95a4d05031a1befd92f1f433f6457
+SIZE (GeographicLib/magnetic-distrib/igrf11.tar.bz2) = 6011
+SHA256 (GeographicLib/magnetic-distrib/wmm2010.tar.bz2) = a40aced2d5d36b3183f3efc759820d16a7daab81a33a0b81db0510e8d17dbb5e
+SIZE (GeographicLib/magnetic-distrib/wmm2010.tar.bz2) = 1442
diff --git a/astro/geographiclib/pkg-descr b/astro/geographiclib/pkg-descr
new file mode 100644
index 000000000000..0e6aa5579d34
--- /dev/null
+++ b/astro/geographiclib/pkg-descr
@@ -0,0 +1,10 @@
+GeographicLib is a small set of C++ classes for performing conversions
+between geographic, UTM, UPS, MGRS, geocentric, and local cartesian
+coordinates, for gravity (e.g., EGM2008), geoid height, and geomagnetic
+field (e.g., WMM2010) calculations, and for solving geodesic problems.
+
+The library may be used from .NET applications using the NETGeographicLib
+wrapper library. It is a suitable replacement for the core functionality
+provided by geotrans.
+
+WWW: http://geographiclib.sourceforge.net/
diff --git a/astro/geographiclib/pkg-plist b/astro/geographiclib/pkg-plist
new file mode 100644
index 000000000000..32dc14e5986d
--- /dev/null
+++ b/astro/geographiclib/pkg-plist
@@ -0,0 +1,194 @@
+bin/CartConvert
+bin/ConicProj
+bin/GeoConvert
+bin/GeodSolve
+bin/GeodesicProj
+bin/GeoidEval
+bin/Gravity
+bin/MagneticField
+bin/Planimeter
+bin/RhumbSolve
+bin/TransverseMercatorProj
+include/GeographicLib/Accumulator.hpp
+include/GeographicLib/AlbersEqualArea.hpp
+include/GeographicLib/AzimuthalEquidistant.hpp
+include/GeographicLib/CassiniSoldner.hpp
+include/GeographicLib/CircularEngine.hpp
+include/GeographicLib/Config.h
+include/GeographicLib/Constants.hpp
+include/GeographicLib/DMS.hpp
+include/GeographicLib/Ellipsoid.hpp
+include/GeographicLib/EllipticFunction.hpp
+include/GeographicLib/GeoCoords.hpp
+include/GeographicLib/Geocentric.hpp
+include/GeographicLib/Geodesic.hpp
+include/GeographicLib/GeodesicExact.hpp
+include/GeographicLib/GeodesicLine.hpp
+include/GeographicLib/GeodesicLineExact.hpp
+include/GeographicLib/Geohash.hpp
+include/GeographicLib/Geoid.hpp
+include/GeographicLib/Gnomonic.hpp
+include/GeographicLib/GravityCircle.hpp
+include/GeographicLib/GravityModel.hpp
+include/GeographicLib/LambertConformalConic.hpp
+include/GeographicLib/LocalCartesian.hpp
+include/GeographicLib/MGRS.hpp
+include/GeographicLib/MagneticCircle.hpp
+include/GeographicLib/MagneticModel.hpp
+include/GeographicLib/Math.hpp
+include/GeographicLib/NormalGravity.hpp
+include/GeographicLib/OSGB.hpp
+include/GeographicLib/PolarStereographic.hpp
+include/GeographicLib/PolygonArea.hpp
+include/GeographicLib/Rhumb.hpp
+include/GeographicLib/SphericalEngine.hpp
+include/GeographicLib/SphericalHarmonic.hpp
+include/GeographicLib/SphericalHarmonic1.hpp
+include/GeographicLib/SphericalHarmonic2.hpp
+include/GeographicLib/TransverseMercator.hpp
+include/GeographicLib/TransverseMercatorExact.hpp
+include/GeographicLib/UTMUPS.hpp
+include/GeographicLib/Utility.hpp
+lib/libGeographic.a
+lib/libGeographic.so
+lib/libGeographic.so.13
+lib/libGeographic.so.13.0.0
+%%PYTHON_SITELIBDIR%%/geographiclib/__init__.py
+%%PYTHON_SITELIBDIR%%/geographiclib/accumulator.py
+%%PYTHON_SITELIBDIR%%/geographiclib/constants.py
+%%PYTHON_SITELIBDIR%%/geographiclib/geodesic.py
+%%PYTHON_SITELIBDIR%%/geographiclib/geodesiccapability.py
+%%PYTHON_SITELIBDIR%%/geographiclib/geodesicline.py
+%%PYTHON_SITELIBDIR%%/geographiclib/geomath.py
+%%PYTHON_SITELIBDIR%%/geographiclib/polygonarea.py
+libexec/GeographicLib/matlab/cassini_fwd.m
+libexec/GeographicLib/matlab/cassini_inv.m
+libexec/GeographicLib/matlab/defaultellipsoid.m
+libexec/GeographicLib/matlab/ecc2flat.m
+libexec/GeographicLib/matlab/eqdazim_fwd.m
+libexec/GeographicLib/matlab/eqdazim_inv.m
+libexec/GeographicLib/matlab/flat2ecc.m
+libexec/GeographicLib/matlab/geocentricforward.cpp
+libexec/GeographicLib/matlab/geocentricforward.m
+libexec/GeographicLib/matlab/geocentricreverse.cpp
+libexec/GeographicLib/matlab/geocentricreverse.m
+libexec/GeographicLib/matlab/geodarea.m
+libexec/GeographicLib/matlab/geoddistance.m
+libexec/GeographicLib/matlab/geoddoc.m
+libexec/GeographicLib/matlab/geodesicdirect.cpp
+libexec/GeographicLib/matlab/geodesicdirect.m
+libexec/GeographicLib/matlab/geodesicinverse.cpp
+libexec/GeographicLib/matlab/geodesicinverse.m
+libexec/GeographicLib/matlab/geodesicline.cpp
+libexec/GeographicLib/matlab/geodesicline.m
+libexec/GeographicLib/matlab/geodproj.m
+libexec/GeographicLib/matlab/geodreckon.m
+libexec/GeographicLib/matlab/geographiclibinterface.m
+libexec/GeographicLib/matlab/geoidheight.cpp
+libexec/GeographicLib/matlab/geoidheight.m
+libexec/GeographicLib/matlab/gnomonic_fwd.m
+libexec/GeographicLib/matlab/gnomonic_inv.m
+libexec/GeographicLib/matlab/localcartesianforward.cpp
+libexec/GeographicLib/matlab/localcartesianforward.m
+libexec/GeographicLib/matlab/localcartesianreverse.cpp
+libexec/GeographicLib/matlab/localcartesianreverse.m
+libexec/GeographicLib/matlab/mgrsforward.cpp
+libexec/GeographicLib/matlab/mgrsforward.m
+libexec/GeographicLib/matlab/mgrsreverse.cpp
+libexec/GeographicLib/matlab/mgrsreverse.m
+libexec/GeographicLib/matlab/polygonarea.cpp
+libexec/GeographicLib/matlab/polygonarea.m
+libexec/GeographicLib/matlab/private/A1m1f.m
+libexec/GeographicLib/matlab/private/A2m1f.m
+libexec/GeographicLib/matlab/private/A3coeff.m
+libexec/GeographicLib/matlab/private/A3f.m
+libexec/GeographicLib/matlab/private/AngDiff.m
+libexec/GeographicLib/matlab/private/AngNormalize.m
+libexec/GeographicLib/matlab/private/AngNormalize2.m
+libexec/GeographicLib/matlab/private/AngRound.m
+libexec/GeographicLib/matlab/private/C1f.m
+libexec/GeographicLib/matlab/private/C1pf.m
+libexec/GeographicLib/matlab/private/C2f.m
+libexec/GeographicLib/matlab/private/C3coeff.m
+libexec/GeographicLib/matlab/private/C3f.m
+libexec/GeographicLib/matlab/private/C4coeff.m
+libexec/GeographicLib/matlab/private/C4f.m
+libexec/GeographicLib/matlab/private/SinCosNorm.m
+libexec/GeographicLib/matlab/private/SinCosSeries.m
+libexec/GeographicLib/matlab/private/atanhee.m
+libexec/GeographicLib/matlab/private/cbrt.m
+libexec/GeographicLib/matlab/private/cvmgt.m
+libexec/GeographicLib/matlab/private/sumx.m
+libexec/GeographicLib/matlab/private/swap.m
+libexec/GeographicLib/matlab/tranmerc_fwd.m
+libexec/GeographicLib/matlab/tranmerc_inv.m
+libexec/GeographicLib/matlab/utm_fwd.m
+libexec/GeographicLib/matlab/utm_inv.m
+libexec/GeographicLib/matlab/utmupsforward.cpp
+libexec/GeographicLib/matlab/utmupsforward.m
+libexec/GeographicLib/matlab/utmupsreverse.cpp
+libexec/GeographicLib/matlab/utmupsreverse.m
+man/man1/CartConvert.1.gz
+man/man1/ConicProj.1.gz
+man/man1/GeoConvert.1.gz
+man/man1/GeodSolve.1.gz
+man/man1/GeodesicProj.1.gz
+man/man1/GeoidEval.1.gz
+man/man1/Gravity.1.gz
+man/man1/MagneticField.1.gz
+man/man1/Planimeter.1.gz
+man/man1/RhumbSolve.1.gz
+man/man1/TransverseMercatorProj.1.gz
+sbin/geographiclib-get-geoids
+sbin/geographiclib-get-gravity
+sbin/geographiclib-get-magnetic
+%%DATADIR%%/geoids/.keep
+%%DATADIR%%/gravity/.keep
+%%DATADIR%%/magnetic/.keep
+%%GEOID_EGM2008_1%%%%DATADIR%%/geoids/egm2008-1.pgm
+%%GEOID_EGM2008_1%%%%DATADIR%%/geoids/egm2008-1.pgm.aux.xml
+%%GEOID_EGM2008_1%%%%DATADIR%%/geoids/egm2008-1.wld
+%%GEOID_EGM2008_2_5%%%%DATADIR%%/geoids/egm2008-2_5.pgm
+%%GEOID_EGM2008_2_5%%%%DATADIR%%/geoids/egm2008-2_5.pgm.aux.xml
+%%GEOID_EGM2008_2_5%%%%DATADIR%%/geoids/egm2008-2_5.wld
+%%GEOID_EGM2008_5%%%%DATADIR%%/geoids/egm2008-5.pgm
+%%GEOID_EGM2008_5%%%%DATADIR%%/geoids/egm2008-5.pgm.aux.xml
+%%GEOID_EGM2008_5%%%%DATADIR%%/geoids/egm2008-5.wld
+%%GEOID_EGM84_15%%%%DATADIR%%/geoids/egm84-15.pgm
+%%GEOID_EGM84_15%%%%DATADIR%%/geoids/egm84-15.pgm.aux.xml
+%%GEOID_EGM84_15%%%%DATADIR%%/geoids/egm84-15.wld
+%%GEOID_EGM84_30%%%%DATADIR%%/geoids/egm84-30.pgm
+%%GEOID_EGM84_30%%%%DATADIR%%/geoids/egm84-30.pgm.aux.xml
+%%GEOID_EGM84_30%%%%DATADIR%%/geoids/egm84-30.wld
+%%GEOID_EGM96_15%%%%DATADIR%%/geoids/egm96-15.pgm
+%%GEOID_EGM96_15%%%%DATADIR%%/geoids/egm96-15.pgm.aux.xml
+%%GEOID_EGM96_15%%%%DATADIR%%/geoids/egm96-15.wld
+%%GEOID_EGM96_5%%%%DATADIR%%/geoids/egm96-5.pgm
+%%GEOID_EGM96_5%%%%DATADIR%%/geoids/egm96-5.pgm.aux.xml
+%%GEOID_EGM96_5%%%%DATADIR%%/geoids/egm96-5.wld
+%%GRAVITY_EGM2008%%%%DATADIR%%/gravity/egm2008.egm
+%%GRAVITY_EGM2008%%%%DATADIR%%/gravity/egm2008.egm.cof
+%%GRAVITY_EGM84%%%%DATADIR%%/gravity/egm84.egm
+%%GRAVITY_EGM84%%%%DATADIR%%/gravity/egm84.egm.cof
+%%GRAVITY_EGM96%%%%DATADIR%%/gravity/egm96.egm
+%%GRAVITY_EGM96%%%%DATADIR%%/gravity/egm96.egm.cof
+%%GRAVITY_WGS84%%%%DATADIR%%/gravity/wgs84.egm
+%%GRAVITY_WGS84%%%%DATADIR%%/gravity/wgs84.egm.cof
+%%MAGNETIC_EMM2010%%%%DATADIR%%/magnetic/emm2010.wmm
+%%MAGNETIC_EMM2010%%%%DATADIR%%/magnetic/emm2010.wmm.cof
+%%MAGNETIC_IGRF11%%%%DATADIR%%/magnetic/igrf11.wmm
+%%MAGNETIC_IGRF11%%%%DATADIR%%/magnetic/igrf11.wmm.cof
+%%MAGNETIC_WMM2010%%%%DATADIR%%/magnetic/wmm2010.wmm
+%%MAGNETIC_WMM2010%%%%DATADIR%%/magnetic/wmm2010.wmm.cof
+share/cmake/GeographicLib/FindGeographicLib.cmake
+@dirrm include/GeographicLib
+@dirrm %%PYTHON_SITELIBDIR%%/geographiclib
+@dirrm libexec/GeographicLib/matlab/private
+@dirrm libexec/GeographicLib/matlab
+@dirrm libexec/GeographicLib
+@dirrm %%DATADIR%%/geoids
+@dirrm %%DATADIR%%/gravity
+@dirrm %%DATADIR%%/magnetic
+@dirrm %%DATADIR%%
+@dirrm share/cmake/GeographicLib
+@dirrmtry share/cmake