aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-08-26 23:05:31 +0800
committersat <sat@FreeBSD.org>2006-08-26 23:05:31 +0800
commit1f8d7ec8d479a087f734ef05e061dcd7ea529945 (patch)
tree2545f73461ff155289c54d82f571283d37fe6b85 /astro
parent28fa7554367ac463092adffcb800ae5a3d10704d (diff)
downloadfreebsd-ports-gnome-1f8d7ec8d479a087f734ef05e061dcd7ea529945.tar.gz
freebsd-ports-gnome-1f8d7ec8d479a087f734ef05e061dcd7ea529945.tar.zst
freebsd-ports-gnome-1f8d7ec8d479a087f734ef05e061dcd7ea529945.zip
Add port astro/ptiger:
ptiger is a Tcl/Tk/Tkgeomap script that uses wdgeomap to display U.S. Census Burea populated places on an interactive geographic map. To run it, type ptiger on the command line. After a few seconds, a map should appear. Adjust the view by Dragging or Double-Clicking. As the cursor moves, a label below the map displays the cursor location and the azimuth and range from the + marker to the cursor. Move the + marker by Right-Double-Clicking. The map has dots at places with population greater than a user selected threshold. Moving the cursor over a dot labels the place with its name and displays the population in another label below the map. In addition to the wdgeomap menus, a Places menu enables adjustment of the population threshold and dot size. There is also a Find menu that does a case insensitive regular expression search for a named place. WWW: http://www.tkgeomap.org/ptiger.html Author: Gordon Carrie <tkgeomap@users.sourceforge.net>
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/ptiger/Makefile31
-rw-r--r--astro/ptiger/distinfo3
-rw-r--r--astro/ptiger/pkg-descr17
-rw-r--r--astro/ptiger/pkg-plist76
5 files changed, 128 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 4983b1d067f7..6124f04beb4d 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -48,6 +48,7 @@
SUBDIR += phoon
SUBDIR += planets
SUBDIR += pp3
+ SUBDIR += ptiger
SUBDIR += py-metar
SUBDIR += pyweather
SUBDIR += rmap
diff --git a/astro/ptiger/Makefile b/astro/ptiger/Makefile
new file mode 100644
index 000000000000..de8aa6dd4b70
--- /dev/null
+++ b/astro/ptiger/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ptiger
+# Date created: 26 August 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ptiger
+PORTVERSION= 2.2
+CATEGORIES= astro tk84
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= tkgeomap
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Displays U.S. Census Burea populated places on a map
+
+LIB_DEPENDS= tkgeomap2.9.0:${PORTSDIR}/astro/tkgeomap
+
+USE_XLIB= yes
+USE_TK= yes
+NO_BUILD= yes
+
+post-patch:
+ @${REINPLACE_CMD} -Ee 's,\[pwd\],${DATADIR}/src,;s,(lines/|places/|src/),${DATADIR}/\1,g;s,wish,${WISH},' ${WRKSRC}/src/PTiger.tcl
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/src/PTiger.tcl ${PREFIX}/bin/${PORTNAME}
+ @${INSTALL} -d ${DATADIR}
+ @${CP} -Rf ${WRKSRC}/lines ${WRKSRC}/places ${WRKSRC}/src ${DATADIR}/
+
+.include <bsd.port.mk>
diff --git a/astro/ptiger/distinfo b/astro/ptiger/distinfo
new file mode 100644
index 000000000000..70b0a7efe466
--- /dev/null
+++ b/astro/ptiger/distinfo
@@ -0,0 +1,3 @@
+MD5 (ptiger-2.2.tar.gz) = 1e6a1051ec7c21aae0d948b94cd08d60
+SHA256 (ptiger-2.2.tar.gz) = abdf7d68d728a424014ed507bdda78768f1b8be9be0c48c354072822ddc0b63f
+SIZE (ptiger-2.2.tar.gz) = 4300581
diff --git a/astro/ptiger/pkg-descr b/astro/ptiger/pkg-descr
new file mode 100644
index 000000000000..58d8093a754a
--- /dev/null
+++ b/astro/ptiger/pkg-descr
@@ -0,0 +1,17 @@
+ptiger is a Tcl/Tk/Tkgeomap script that uses wdgeomap to display U.S.
+Census Burea populated places on an interactive geographic map.
+
+To run it, type ptiger on the command line. After a few seconds, a map
+should appear. Adjust the view by Dragging or Double-Clicking. As the
+cursor moves, a label below the map displays the cursor location and
+the azimuth and range from the + marker to the cursor. Move the + marker
+by Right-Double-Clicking. The map has dots at places with population
+greater than a user selected threshold. Moving the cursor over a dot
+labels the place with its name and displays the population in another
+label below the map. In addition to the wdgeomap menus, a Places menu
+enables adjustment of the population threshold and dot size. There is
+also a Find menu that does a case insensitive regular expression search
+for a named place.
+
+WWW: http://www.tkgeomap.org/ptiger.html
+Author: Gordon Carrie <tkgeomap@users.sourceforge.net>
diff --git a/astro/ptiger/pkg-plist b/astro/ptiger/pkg-plist
new file mode 100644
index 000000000000..b743d75ef646
--- /dev/null
+++ b/astro/ptiger/pkg-plist
@@ -0,0 +1,76 @@
+bin/ptiger
+%%DATADIR%%/lines/highways/interstate.xdr
+%%DATADIR%%/lines/states/Alabama.xdr
+%%DATADIR%%/lines/states/Alaska.xdr
+%%DATADIR%%/lines/states/American Samoa.xdr
+%%DATADIR%%/lines/states/Arizona.xdr
+%%DATADIR%%/lines/states/Arkansas.xdr
+%%DATADIR%%/lines/states/California.xdr
+%%DATADIR%%/lines/states/Canada.xdr
+%%DATADIR%%/lines/states/Colorado.xdr
+%%DATADIR%%/lines/states/Connecticut.xdr
+%%DATADIR%%/lines/states/Delaware.xdr
+%%DATADIR%%/lines/states/District of Columbia.xdr
+%%DATADIR%%/lines/states/Florida.xdr
+%%DATADIR%%/lines/states/Georgia.xdr
+%%DATADIR%%/lines/states/Guam.xdr
+%%DATADIR%%/lines/states/Hawaii.xdr
+%%DATADIR%%/lines/states/Idaho.xdr
+%%DATADIR%%/lines/states/Illinois.xdr
+%%DATADIR%%/lines/states/Indiana.xdr
+%%DATADIR%%/lines/states/Iowa.xdr
+%%DATADIR%%/lines/states/Kansas.xdr
+%%DATADIR%%/lines/states/Kentucky.xdr
+%%DATADIR%%/lines/states/Louisiana.xdr
+%%DATADIR%%/lines/states/Maine.xdr
+%%DATADIR%%/lines/states/Marianas.xdr
+%%DATADIR%%/lines/states/Maryland.xdr
+%%DATADIR%%/lines/states/Massachusetts.xdr
+%%DATADIR%%/lines/states/Mexico.xdr
+%%DATADIR%%/lines/states/Michigan.xdr
+%%DATADIR%%/lines/states/Midway.xdr
+%%DATADIR%%/lines/states/Minnesota.xdr
+%%DATADIR%%/lines/states/Mississippi.xdr
+%%DATADIR%%/lines/states/Missouri.xdr
+%%DATADIR%%/lines/states/Montana.xdr
+%%DATADIR%%/lines/states/Nebraska.xdr
+%%DATADIR%%/lines/states/Nevada.xdr
+%%DATADIR%%/lines/states/New Hampshire.xdr
+%%DATADIR%%/lines/states/New Jersey.xdr
+%%DATADIR%%/lines/states/New Mexico.xdr
+%%DATADIR%%/lines/states/New York.xdr
+%%DATADIR%%/lines/states/North Carolina.xdr
+%%DATADIR%%/lines/states/North Dakota.xdr
+%%DATADIR%%/lines/states/Ohio.xdr
+%%DATADIR%%/lines/states/Oklahoma.xdr
+%%DATADIR%%/lines/states/Oregon.xdr
+%%DATADIR%%/lines/states/Pennsylvania.xdr
+%%DATADIR%%/lines/states/Puerto Rico.xdr
+%%DATADIR%%/lines/states/Rhode Island.xdr
+%%DATADIR%%/lines/states/South Carolina.xdr
+%%DATADIR%%/lines/states/South Dakota.xdr
+%%DATADIR%%/lines/states/Tennessee.xdr
+%%DATADIR%%/lines/states/Texas.xdr
+%%DATADIR%%/lines/states/Utah.xdr
+%%DATADIR%%/lines/states/Vermont.xdr
+%%DATADIR%%/lines/states/Virgin Islands.xdr
+%%DATADIR%%/lines/states/Virginia.xdr
+%%DATADIR%%/lines/states/Washington.xdr
+%%DATADIR%%/lines/states/West Virginia.xdr
+%%DATADIR%%/lines/states/Wisconsin.xdr
+%%DATADIR%%/lines/states/Wyoming.xdr
+%%DATADIR%%/lines/world/World.xdr
+%%DATADIR%%/places/places2k.sort
+%%DATADIR%%/src/Convert.tcl
+%%DATADIR%%/src/PTiger.tcl
+%%DATADIR%%/src/PTiger.tcl.bak
+%%DATADIR%%/src/pkgIndex.tcl
+%%DATADIR%%/src/plus.bm
+%%DATADIR%%/src/us_census.tcl
+@dirrm %%DATADIR%%/lines/highways
+@dirrm %%DATADIR%%/lines/states
+@dirrm %%DATADIR%%/lines/world
+@dirrm %%DATADIR%%/lines
+@dirrm %%DATADIR%%/places
+@dirrm %%DATADIR%%/src
+@dirrm %%DATADIR%%