aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-09-06 03:23:42 +0800
committertijl <tijl@FreeBSD.org>2016-09-06 03:23:42 +0800
commit6255104baacfdd2c23e07550f90d2f9a7020ca87 (patch)
tree516db145d6cf5fd4d2666f811272aad577272ac5 /astro
parent016de2316ed16336a58b66dafd7f332614a041ac (diff)
downloadfreebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.tar.gz
freebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.tar.zst
freebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.zip
- Replace Mk/bsd.linux-apps.mk and Mk/bsd.linux-rpm.mk with
Mk/Uses/linux.mk. - Replace USE_LINUX=yes with USES+=linux and USE_LINUX=(.*) with USES+=linux:\1 in all ports. - Replace USE_LINUX_APPS with USE_LINUX in all ports. - Use INSTALL_SCRIPT instead of INSTALL_PROGRAM to install scripts in some ports. - When USE_LINUX_RPM is defined, simplify the way DISTFILES and EXTRACT_ONLY are defined. - Remove BRANDELF_DIRS and BRANDELF_FILES handling. In the very rare cases that it is still necessary ports can run ${BRANDELF} from post-patch. - Remove AUTOMATIC_PLIST handling. Only one port used it. - Fix Linux MASTER_SITES. - Replace OVERRIDE_LINUX_BASE_PORT and OVERRIDE_LINUX_NONBASE_PORTS with default versions framework. - bsd.port.mk: - Move Linux related bits to Uses/linux.mk, except USE_LINUX_PREFIX. - Put USE_LINUX_PREFIX handling after USES processing. - Define DOCSDIR, DATADIR, etc. after handling USE_LINUX_PREFIX so it can give these variables a different default value. - When a package needs to run Linux ldconfig check before installation if Linux support is enabled. - emulators/linux_base-*: - Use USES=linux and remove duplication. - Remove files/lp. FreeBSD or CUPS lp(1) should work. - Remove files/yp.conf. No longer seems to be used. - Remove pkg-deinstall and move pkg-install into pkg-plist. - Update pkg-descr and pkg-message. - Fix handling of ldconfig cache in pkg-plist. - devel/fb-adb: Use a Linux shell to run a Linux script but patch the script to use FreeBSD mkdir so mkdir -p $path creates $path and not /compat/linux/$path. PR: 211645 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'astro')
-rw-r--r--astro/google-earth/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/astro/google-earth/Makefile b/astro/google-earth/Makefile
index bf893b2db8b9..28abc87354ad 100644
--- a/astro/google-earth/Makefile
+++ b/astro/google-earth/Makefile
@@ -21,16 +21,15 @@ LINUX_DRI_DESC= libGL support via Linux DRI libraries
NVIDIA_GL_340_DESC= libGL support via nvidia-driver-340
NVIDIA_GL_304_DESC= libGL support via nvidia-driver-304
-USE_LINUX= yes
-USE_LINUX_APPS= xorglibs curl nss
-USES= desktop-file-utils makeself perl5 shared-mime-info
+USES= desktop-file-utils linux makeself perl5 shared-mime-info
+USE_LINUX= xorglibs curl nss
USE_PERL5= patch build
NO_WRKSUBDIR= yes
NVIDIA_GL_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
NVIDIA_GL_340_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver-340
NVIDIA_GL_304_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver-304
-LINUX_DRI_USE= LINUX_APPS=dri,libpciaccess
+LINUX_DRI_USE= LINUX=dri,libpciaccess
post-extract:
@cd ${WRKSRC} && ${TAR} -xf googleearth-data.tar && ${RM} googleearth-data.tar
@@ -62,7 +61,7 @@ do-install:
${STAGEDIR}${PREFIX}/share/mime/packages/
${INSTALL_DATA} ${WRKSRC}/Google-googleearth.desktop \
${STAGEDIR}${PREFIX}/share/applications/googleearth.desktop
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/googleearth ${STAGEDIR}${DATADIR}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/googleearth ${STAGEDIR}${DATADIR}/bin/
${INSTALL_PROGRAM} ${WRKSRC}/googleearth-bin ${STAGEDIR}${DATADIR}/
${RM} ${WRKSRC}/googleearth-mimetypes.xml \
${WRKSRC}/googleearth.desktop \