aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-08-05 15:09:55 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-08-05 15:09:55 +0800
commit97c682b7f72c8ce3eab7a0f521a5d6857c59477d (patch)
treeb64ffea33166604039221da9d21d07d51565e75e /astro
parentea1373784b486fa65dd29bab4bcf411773219e35 (diff)
downloadfreebsd-ports-gnome-97c682b7f72c8ce3eab7a0f521a5d6857c59477d.tar.gz
freebsd-ports-gnome-97c682b7f72c8ce3eab7a0f521a5d6857c59477d.tar.zst
freebsd-ports-gnome-97c682b7f72c8ce3eab7a0f521a5d6857c59477d.zip
- Convert to new options framework
- Cosmetic change
Diffstat (limited to 'astro')
-rw-r--r--astro/py-metar/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/astro/py-metar/Makefile b/astro/py-metar/Makefile
index d5d3f4ecb6bc..a458afa568d0 100644
--- a/astro/py-metar/Makefile
+++ b/astro/py-metar/Makefile
@@ -14,15 +14,17 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= ${REALPORTNAME}-${PORTVERSION}
MAINTAINER= sunpoet@FreeBSD.org
-COMMENT= Python module that provides access to NOAA's METAR weather reports
+COMMENT= Python module that provides access to NOAA METAR weather reports
LICENSE= GPLv2
-DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+OPTIONS_DEFINE= DOCS
+
PYDISTUTILS_PKGNAME= ${REALPORTNAME}
USE_PYDISTUTILS= yes
USE_PYTHON= -2.7
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
PLIST_FILES= bin/${REALPORTNAME} \
%%PYTHON_SITELIBDIR%%/${REALPORTNAME}.py \
%%PYTHON_SITELIBDIR%%/${REALPORTNAME}.pyc \
@@ -31,10 +33,12 @@ PORTDOCS= COPYING README THANKS librarydoc.txt
REALPORTNAME= pymetar
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -E '1 s|/usr/bin/(env *)?python|${PYTHON_CMD}|' \
${WRKSRC}/setup.py ${WRKSRC}/bin/${REALPORTNAME}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} \
-e 's|"share/doc/pymetar-%s/"%pymetar.__version__|"${DOCSDIR}"|' \
${WRKSRC}/setup.py