aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2009-08-07 00:41:35 +0800
committernox <nox@FreeBSD.org>2009-08-07 00:41:35 +0800
commit092239fb78271f3c145f4adba01fe0a6c2fff3ff (patch)
tree1d0e2cf92015094fc6a45ddf59899b1aaa98acd0 /astro
parent01e17c734f65b467d06dded9b6731daf154d7c12 (diff)
downloadfreebsd-ports-gnome-092239fb78271f3c145f4adba01fe0a6c2fff3ff.tar.gz
freebsd-ports-gnome-092239fb78271f3c145f4adba01fe0a6c2fff3ff.tar.zst
freebsd-ports-gnome-092239fb78271f3c145f4adba01fe0a6c2fff3ff.zip
- Limit the stack size for Google Earth. Linux glibc threading behaves
slightly differently with a smaller stack size and Google Earth (like the Flash plugins) relies on this behaviour. [1] - Bump PORTREVISION. Reported by: scf [1]
Diffstat (limited to 'astro')
-rw-r--r--astro/google-earth/Makefile6
-rw-r--r--astro/google-earth/files/patch-stacksize10
2 files changed, 14 insertions, 2 deletions
diff --git a/astro/google-earth/Makefile b/astro/google-earth/Makefile
index a7b9b1b96c96..9b107074d6ef 100644
--- a/astro/google-earth/Makefile
+++ b/astro/google-earth/Makefile
@@ -7,6 +7,7 @@
PORTNAME= google-earth
PORTVERSION= 5.0.11733.9347
+PORTREVISION= 1
CATEGORIES= astro deskutils geography
MASTER_SITES= http://dl.google.com/earth/client/current/
DISTNAME= GoogleEarthLinux
@@ -45,7 +46,7 @@ do-extract:
@cd ${WRKSRC} && ${TAR} xf googleearth-data.tar && ${RM} -f googleearth-data.tar
@cd ${WRKSRC} && ${TAR} xf googleearth-linux-x86.tar && ${RM} -f googleearth-linux-x86.tar
-do-patch:
+pre-patch:
@${REINPLACE_CMD} -i "" -e 's|^# Set the home.*|GOOGLEEARTH_DATA_PATH=${DATADIR}|' ${WRKSRC}/bin/googleearth
@${REINPLACE_CMD} -i "" -e "s|^# Let's boogie.*|rm -f \$${HOME}/.googleearth/instance-running-lock|" ${WRKSRC}/bin/googleearth
@${REINPLACE_CMD} -i "" -e 's/^TMPPATH.*/exit 0/' ${WRKSRC}/postinstall.sh
@@ -54,7 +55,8 @@ do-patch:
do-build:
@${SETENV} SETUP_INSTALLPATH=${DATADIR} ${WRKSRC}/postinstall.sh
- @cd ${WRKSRC} && ${RM} -rf setup.* preuninstall.sh postinstall.sh
+ @cd ${WRKSRC} && ${RM} -rf setup.* preuninstall.sh postinstall.sh \
+ bin/googleearth.orig
pre-su-install:
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${WRKSRC}
diff --git a/astro/google-earth/files/patch-stacksize b/astro/google-earth/files/patch-stacksize
new file mode 100644
index 000000000000..1927d545a67e
--- /dev/null
+++ b/astro/google-earth/files/patch-stacksize
@@ -0,0 +1,10 @@
+Index: bin/googleearth
+@@ -34,6 +34,8 @@
+ dirname $fullpath
+ }
+
++ulimit -s 32768 2>/dev/null
++
+ GOOGLEEARTH_DATA_PATH=/usr/local/share/google-earth
+ if [ "${GOOGLEEARTH_DATA_PATH}" = "" ]; then
+ GOOGLEEARTH_DATA_PATH="`FindPath $0`"