aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-12-30 06:42:34 +0800
committerbapt <bapt@FreeBSD.org>2012-12-30 06:42:34 +0800
commitd02c7d47c14cc5ce34c299cc17a2e3b74b1ff569 (patch)
tree2e96aaa7bb70a45629ac810a51c9cb2e36755d9c /astro
parente48f1081f7ac8fa2b3041e0f1bd72508e5d5968d (diff)
downloadfreebsd-ports-gnome-d02c7d47c14cc5ce34c299cc17a2e3b74b1ff569.tar.gz
freebsd-ports-gnome-d02c7d47c14cc5ce34c299cc17a2e3b74b1ff569.tar.zst
freebsd-ports-gnome-d02c7d47c14cc5ce34c299cc17a2e3b74b1ff569.zip
Convert to new options framework
Trim headers PR: ports/173816 Submitted by: Chris Petrik <c.petrik.sosa@gmail.com> Approved by: maintainer timeout (1 month)
Diffstat (limited to 'astro')
-rw-r--r--astro/xtide/Makefile23
1 files changed, 9 insertions, 14 deletions
diff --git a/astro/xtide/Makefile b/astro/xtide/Makefile
index 7ba149111cc1..d6b5da2c4363 100644
--- a/astro/xtide/Makefile
+++ b/astro/xtide/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xtide
-# Date created: 30 August 1997
-# Whom: Brion Moss <brion@queeg.com>
-#
+# Created by: Brion Moss <brion@queeg.com>
# $FreeBSD$
-#
PORTNAME= xtide
PORTVERSION= 2.12.1
@@ -37,19 +33,18 @@ TCD_DISTNAME= libtcd-2.2.5
HARM_DISTNAME= harmonics-dwf-20120302
WVS_DISTNAME= wvs
-OPTIONS= WVS "Use world vector shoreline data (big file!)" Off
+OPTIONS_DEFINE= WVS X11
+WVS_DESC= Use world vector shoreline data (big file!)
.include <bsd.port.options.mk>
-.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_WVS)
+.if ${PORT_OPTIONS:MWVS}
DISTFILES+= ${WVS_DISTNAME}${EXTRACT_SUFX}
PLIST_SUB+= WVS=""
-.else
-PLIST_SUB+= WVS="@comment "
+.elsePLIST_SUB+= WVS="@comment "
.endif
-.if defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
PKGNAMESUFFIX+= -nox11
ALL_TARGET+= tide xttpd
PLIST_SUB+= X11="@comment "
@@ -83,7 +78,7 @@ post-configure:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tide ${PREFIX}/bin
-.if !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
${INSTALL_PROGRAM} ${WRKSRC}/xtide ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/xtide.1 ${MANPREFIX}/man/man1
.endif
@@ -100,7 +95,7 @@ post-install:
${CHMOD} 644 ${PREFIX}/etc/xtide.conf
.endif
-.if !defined(WITHOUT_WVS)
+.if ${PORT_OPTIONS:MWVS}
@${MKDIR} ${DATADIR}/wvs
${INSTALL_DATA} ${WRKDIR}/wvs1.dat ${DATADIR}/wvs
${INSTALL_DATA} ${WRKDIR}/wvs12.dat ${DATADIR}/wvs
@@ -110,4 +105,4 @@ post-install:
${INSTALL_DATA} ${WRKDIR}/wvsfull.dat ${DATADIR}/wvs
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>