aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2007-08-04 19:41:30 +0800
committergabor <gabor@FreeBSD.org>2007-08-04 19:41:30 +0800
commit1f31ff34b514d77244257a9a94391d3aae8edab0 (patch)
treea676504f8edaca31196a243aa7393f33f26078fa /astro
parentfb4c30cf2c9bc123dc0c05a0e070f2c48e83be57 (diff)
downloadfreebsd-ports-gnome-1f31ff34b514d77244257a9a94391d3aae8edab0.tar.gz
freebsd-ports-gnome-1f31ff34b514d77244257a9a94391d3aae8edab0.tar.zst
freebsd-ports-gnome-1f31ff34b514d77244257a9a94391d3aae8edab0.zip
- Remove the DESTDIR modifications from individual ports as we have a new,
fully chrooted DESTDIR, which does not need such any more. Sponsored by: Google Summer of Code 2007 Approved by: portmgr (pav)
Diffstat (limited to 'astro')
-rw-r--r--astro/aa/Makefile4
-rw-r--r--astro/p5-Astro-Catalog/Makefile6
-rw-r--r--astro/weatherspect/Makefile2
3 files changed, 6 insertions, 6 deletions
diff --git a/astro/aa/Makefile b/astro/aa/Makefile
index fe352e5f34ee..94828c18d240 100644
--- a/astro/aa/Makefile
+++ b/astro/aa/Makefile
@@ -31,8 +31,8 @@ post-patch:
@${REINPLACE_CMD} 's|CFLAGS= -O2|CFLAGS+=|' ${WRKSRC}/makefile
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/aa ${TARGETDIR}/bin
- @${INSTALL_DATA} ${WRKSRC}/aa.ini ${TARGETDIR}/etc/aa.ini.default
+ @${INSTALL_PROGRAM} ${WRKSRC}/aa ${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/aa.ini ${PREFIX}/etc/aa.ini.default
post-install:
.if !defined(NOPORTDOCS)
diff --git a/astro/p5-Astro-Catalog/Makefile b/astro/p5-Astro-Catalog/Makefile
index 2bab29aff640..d028ec281443 100644
--- a/astro/p5-Astro-Catalog/Makefile
+++ b/astro/p5-Astro-Catalog/Makefile
@@ -70,9 +70,9 @@ post-patch:
post-install:
.for f in ${CONFIG}
- ${INSTALL_DATA} ${WRKSRC}/etc/${f} ${TARGETDIR}/etc/${f}.default
-.if !exists(${TARGETDIR}/etc/${f})
- ${INSTALL_DATA} ${WRKSRC}/etc/${f} ${TARGETDIR}/etc/${f}
+ ${INSTALL_DATA} ${WRKSRC}/etc/${f} ${PREFIX}/etc/${f}.default
+.if !exists(${PREFIX}/etc/${f})
+ ${INSTALL_DATA} ${WRKSRC}/etc/${f} ${PREFIX}/etc/${f}
.endif
.endfor
diff --git a/astro/weatherspect/Makefile b/astro/weatherspect/Makefile
index 5d895ea132b6..4fdf5927696f 100644
--- a/astro/weatherspect/Makefile
+++ b/astro/weatherspect/Makefile
@@ -23,6 +23,6 @@ NO_BUILD= yes
PLIST_FILES= bin/weatherspect
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${TARGETDIR}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
.include <bsd.port.mk>