aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-10-10 06:34:10 +0800
committermakc <makc@FreeBSD.org>2010-10-10 06:34:10 +0800
commit38aed6dddcb957bee222ad785588492c2e95206f (patch)
treeab2a835c74f52a66ce9b0d0cbc79d763ac70e09d /astro
parentcb849302ee17dcdf3c1846de314f048110bbc971 (diff)
downloadfreebsd-ports-gnome-38aed6dddcb957bee222ad785588492c2e95206f.tar.gz
freebsd-ports-gnome-38aed6dddcb957bee222ad785588492c2e95206f.tar.zst
freebsd-ports-gnome-38aed6dddcb957bee222ad785588492c2e95206f.zip
Fix build on 6.x
PR: ports/151235 Submitted by: Sébastien Santoro (maintainer)
Diffstat (limited to 'astro')
-rw-r--r--astro/astrometry/Makefile8
-rw-r--r--astro/astrometry/files/os-features-config.h (renamed from astro/astrometry/files/gnu-specific-config.h)1
2 files changed, 6 insertions, 3 deletions
diff --git a/astro/astrometry/Makefile b/astro/astrometry/Makefile
index 74c9cca85fbb..23952963b19a 100644
--- a/astro/astrometry/Makefile
+++ b/astro/astrometry/Makefile
@@ -28,8 +28,12 @@ MAKE_ENV= INSTALL_DIR=${PREFIX}/astrometry
MAKE_JOBS_UNSAFE= yes
SUB_FILES= pkg-message
+.include <bsd.port.pre.mk>
+
post-extract:
- ${CP} ${FILESDIR}/gnu-specific-config.h ${WRKSRC}/util/
+.if ${OSVERSION} < 700000 && ${ARCH} == "amd64"
+ ${CP} ${FILESDIR}/os-features-config.h ${WRKSRC}/util/
+.endif
post-patch:
${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
@@ -38,8 +42,6 @@ post-patch:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
-
.if ${ARCH} == "sparc64"
BROKEN= Does not build on sparc64
.endif
diff --git a/astro/astrometry/files/gnu-specific-config.h b/astro/astrometry/files/os-features-config.h
index 401234faf8d8..c6eaeaa2f07c 100644
--- a/astro/astrometry/files/gnu-specific-config.h
+++ b/astro/astrometry/files/os-features-config.h
@@ -2,3 +2,4 @@
#define NEED_DECLARE_QSORT_R 1
#define NEED_QSORT_R 0
#define NEED_SWAP_QSORT_R 0
+#define HAVE_NETPBM 0