aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-09-16 22:29:28 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-09-16 22:29:28 +0800
commit3dd1ab64392c414e9dea3e37394999f1a4a973a0 (patch)
treecac827545dd7dfca0b8cde05d97662d62243dd1e /astro
parentba461e8800f1c0f52782c4074a49cedbf95d6d58 (diff)
downloadfreebsd-ports-gnome-3dd1ab64392c414e9dea3e37394999f1a4a973a0.tar.gz
freebsd-ports-gnome-3dd1ab64392c414e9dea3e37394999f1a4a973a0.tar.zst
freebsd-ports-gnome-3dd1ab64392c414e9dea3e37394999f1a4a973a0.zip
- Install script from astro/prune as bin/prune${PORTVERSION} (currently bin/prune7) instead of bin/prune to avoid conflict with graphviz
- Bump portrevision - Drop CONFLICTS Suggested by: Oliver Brandmueller <ob at e-Gitt dot NET> Feature safe: yes
Diffstat (limited to 'astro')
-rw-r--r--astro/prune/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/astro/prune/Makefile b/astro/prune/Makefile
index 5ceecd305cb6..7a6397fa1df6 100644
--- a/astro/prune/Makefile
+++ b/astro/prune/Makefile
@@ -7,7 +7,7 @@
PORTNAME= prune
PORTVERSION= 7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= astro java
MASTER_SITES= http://activityworkshop.net/software/prune/ \
http://mirror.amdmi3.ru/distfiles/
@@ -18,8 +18,6 @@ EXTRACT_ONLY= # empty
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Application for viewing, editing and converting GPS coordinate data
-CONFLICTS= graphviz-[0-9]*
-
NO_WRKSUBDIR= yes
NO_BUILD= yes
@@ -29,11 +27,11 @@ JAVA_VERSION= 1.5+
SUB_FILES= prune.sh
SUB_LIST= JARNAME=${DISTNAME}
-PLIST_FILES= bin/prune ${JAVAJARDIR:C,${PREFIX}/?,,}/${DISTNAME}
+PLIST_FILES= bin/prune${PORTVERSION} ${JAVAJARDIR:C,${PREFIX}/?,,}/${DISTNAME}
do-install:
${MKDIR} ${JAVAJARDIR}/
${INSTALL_DATA} ${DISTDIR}/${DISTNAME} ${JAVAJARDIR}/
- ${INSTALL_SCRIPT} ${WRKDIR}/prune.sh ${PREFIX}/bin/prune
+ ${INSTALL_SCRIPT} ${WRKDIR}/prune.sh ${PREFIX}/bin/prune${PORTVERSION}
.include <bsd.port.mk>