aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-06-11 22:49:59 +0800
committertijl <tijl@FreeBSD.org>2014-06-11 22:49:59 +0800
commit67f12d415fec83113a7ddfbc9655db98b4e70a28 (patch)
treec4f78cbaf45ab044db3e157be708afd711a4e841 /astro
parent2088f53b95d04c86b1aece3d66aaca36ec5aaec2 (diff)
downloadfreebsd-ports-gnome-67f12d415fec83113a7ddfbc9655db98b4e70a28.tar.gz
freebsd-ports-gnome-67f12d415fec83113a7ddfbc9655db98b4e70a28.tar.zst
freebsd-ports-gnome-67f12d415fec83113a7ddfbc9655db98b4e70a28.zip
Support LIBS like LDFLAGS.
- Add LIBS="${LIBS}" to MAKE_ENV and CONFIGURE_ENV. - Add an option helper for LIBS. - Adjust all ports that already use LIBS. Also remove references to PTHREAD_CFLAGS and PTHREAD_LIBS while here. - Some ports did not support having a LIBS environment variable and required additional patches. Somewhat simplified a linker command line looks like: ${CC} ${src_LDFLAGS} ${LDFLAGS} ${src_LIBS} ${LIBS} where src_LDFLAGS and src_LIBS are controlled by upstream and LDFLAGS and LIBS can be controlled by us. If possible -L and -l flags need to be added to LIBS to make sure they appear after any -L and -l flags set by upstream. Many ports currently add -L${LOCALBASE}/lib to LDFLAGS but this may appear too early on the command line causing installed libraries to be linked in instead of freshly built ones. Additional changes: benchmarks/netio: Replace WITH_IPV6 with an IPV6 option. comms/gnokii: Replace some patches with USES=pathfix. Also remove -fPIC. graphics/gimageview: USES=libtool and install desktop file in DESKTOPDIR. graphics/visionworkbench: Remove FreeBSD 7 support. multimedia/libmovtar: New LIB_DEPENDS syntax. multimedia/opencinematools: Use standard do-build. net/siproxd: USES=libtool:keepla (port actually needs .la files for plugins) net-mgmt/nagios: Remove -fPIC. net-mgmt/nagios4: Remove -fPIC. print/cups-base: Only add -lssp_nonshared on i386 and OSVERSION < 1000036. security/p11-kit: Replace PTHREAD_LIBS in CONFIGURE_ENV with ac_cv_func_pthread_mutexattr_init=no in CONFIGURE_ARGS. This skips a test in configure that falsely detects pthread_mutexattr_init in our libc. sysutils/dar: Fix iconv detection. x11/rxvt-unicode: Remove -lstdc++ and patch configure to remove a FreeBSD hack and use $CXX as linker as on other platforms. PR: 190592 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'astro')
-rw-r--r--astro/cfitsio/Makefile2
-rw-r--r--astro/openuniverse/Makefile3
-rw-r--r--astro/roadmap/Makefile3
-rw-r--r--astro/xplanet/Makefile2
4 files changed, 6 insertions, 4 deletions
diff --git a/astro/cfitsio/Makefile b/astro/cfitsio/Makefile
index a14921a55095..1a08cf6ba5d2 100644
--- a/astro/cfitsio/Makefile
+++ b/astro/cfitsio/Makefile
@@ -23,8 +23,8 @@ OPTIONS_DEFINE= DOCS
ALL_TARGET= libcfitsio.a shared
CFLAGS+= -I${INCLUDEDIR}
+LIBS+= -L${LIBDIR} -lz
CONFIGURE_ARGS= ac_cv_prog_FC=f2c
-CONFIGURE_ENV= LIBS="-L${LIBDIR} -lz"
GNU_CONFIGURE= yes
MAKE_ARGS= ZLIB_SOURCES="zlib/zcompress.c zlib/zuncompress.c"
USE_LDCONFIG= yes
diff --git a/astro/openuniverse/Makefile b/astro/openuniverse/Makefile
index 2c60c3b87eba..a56edee8094e 100644
--- a/astro/openuniverse/Makefile
+++ b/astro/openuniverse/Makefile
@@ -21,8 +21,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --includedir="${LOCALBASE}/include" \
--libdir="${LOCALBASE}/lib" \
-CONFIGURE_ENV= LIBS="-lcompat"
CPPFLAGS+= -I${LOCALBASE}/include/GL -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lm
+LIBS+= -L${LOCALBASE}/lib -lm -lcompat
.include <bsd.port.mk>
diff --git a/astro/roadmap/Makefile b/astro/roadmap/Makefile
index 7415be6b49c0..4adfe6dfc580 100644
--- a/astro/roadmap/Makefile
+++ b/astro/roadmap/Makefile
@@ -52,6 +52,9 @@ post-patch:
s|/usr/include|${LOCALBASE}/include|g ; \
s|/usr/local/include|${LOCALBASE}/include|g ; \
s|/usr/local/lib|${LOCALBASE}/lib|g' ${WRKSRC}/src/options.mk
+ @${ECHO_CMD} 'CFLAGS=${CFLAGS}' > ${WRKSRC}/src/overrides.mk
+ @${ECHO_CMD} 'LDFLAGS=${LDFLAGS}' >> ${WRKSRC}/src/overrides.mk
+ @${ECHO_CMD} 'LIBS=${LIBS}' >> ${WRKSRC}/src/overrides.mk
do-install:
.for _BIN in ${BINS}
diff --git a/astro/xplanet/Makefile b/astro/xplanet/Makefile
index d9cf1135a763..d231b64cc898 100644
--- a/astro/xplanet/Makefile
+++ b/astro/xplanet/Makefile
@@ -14,8 +14,8 @@ GNU_CONFIGURE= yes
USES= iconv
USE_XORG= xt xscrnsaver
CONFIGURE_ARGS= --with-map-extension=jpg
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -lm"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib -lm
OPTIONS_DEFINE= FREETYPE PANGO GIF JPEG PNG PNM TIFF
OPTIONS_DEFAULT= FREETYPE PANGO GIF JPEG PNG PNM TIFF