aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-07-23 17:36:51 +0800
committerrafan <rafan@FreeBSD.org>2007-07-23 17:36:51 +0800
commitb028b113ef13fa7972bb45d681d7a0abe47c40a6 (patch)
treea76a27ca09341f754b493c264ee71c912a553d89 /astro
parent855b1df39bc3a6f03abf878d9c99b5ba0838ba35 (diff)
downloadfreebsd-ports-gnome-b028b113ef13fa7972bb45d681d7a0abe47c40a6.tar.gz
freebsd-ports-gnome-b028b113ef13fa7972bb45d681d7a0abe47c40a6.tar.zst
freebsd-ports-gnome-b028b113ef13fa7972bb45d681d7a0abe47c40a6.zip
- Set --mandir and --infodir in CONFIGURE_ARGS if the configure script
supports them. This is determined by running ``configure --help'' in do-configure target and set the shell variable _LATE_CONFIGURE_ARGS which is then passed to CONFIGURE_ARGS. - Remove --mandir and --infodir in ports' Makefile where applicable Few ports use REINPLACE_CMD to achieve the same effect, remove them too. - Correct some manual pages location from PREFIX/man to MANPREFIX/man - Define INFO_PATH where necessary - Document that .info files are installed in a subdirectory relative to PREFIX/INFO_PATH and slightly change add-plist-info to use INFO_PATH and subdirectory detection. PR: ports/111470 Approved by: portmgr Discussed with: stas (Mk/*), gerald (info related stuffs) Tested by: pointyhat exp run
Diffstat (limited to 'astro')
-rw-r--r--astro/starplot/Makefile1
-rw-r--r--astro/tclgeomap/Makefile3
-rw-r--r--astro/tkgeomap/Makefile1
3 files changed, 1 insertions, 4 deletions
diff --git a/astro/starplot/Makefile b/astro/starplot/Makefile
index 454b2e16c714..a4f4025fd3bb 100644
--- a/astro/starplot/Makefile
+++ b/astro/starplot/Makefile
@@ -20,7 +20,6 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
MAKE_ENV= DOCSDIR="${DOCSDIR}" EXAMPLESDIR="${EXAMPLESDIR}"
MAN1= starconvert.1 starpkg.1 starplot.1
diff --git a/astro/tclgeomap/Makefile b/astro/tclgeomap/Makefile
index 229f5218eb8b..a3db6278e3e0 100644
--- a/astro/tclgeomap/Makefile
+++ b/astro/tclgeomap/Makefile
@@ -15,8 +15,7 @@ COMMENT= Read, manipulate and display geo data
USE_TCL= 82+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} --with-tclinclude=${TCL_INCLUDEDIR} \
- --mandir=${MANPREFIX}/man
+CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} --with-tclinclude=${TCL_INCLUDEDIR}
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
TKPKG= ${PORTNAME}
PLIST_SUB= INC=include/${TKPKG} LIB=lib/${TKPKG}
diff --git a/astro/tkgeomap/Makefile b/astro/tkgeomap/Makefile
index e9d7da6411cd..34b6a13d0b15 100644
--- a/astro/tkgeomap/Makefile
+++ b/astro/tkgeomap/Makefile
@@ -18,7 +18,6 @@ LIB_DEPENDS= tclgeomap.0:${PORTSDIR}/astro/tclgeomap
CONFIGURE_ARGS= --with-tclgeomap-include=${LOCALBASE}/include/tclgeomap --with-x \
--with-tcl=${TCL_LIBDIR} --with-tclinclude=${TCL_INCLUDEDIR} \
--with-tk=${TK_LIBDIR} --with-tkinclude=${TK_INCLUDEDIR} \
- --mandir=${MANPREFIX}/man \
--x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
CONFIGURE_ENV= TCLGEOMAP_LIB=${LOCALBASE}/lib/tclgeomap
USE_TK= 82+