aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-12 03:17:42 +0800
committertijl <tijl@FreeBSD.org>2014-09-12 03:17:42 +0800
commitc7315ae9c194cde6fd0980e9bb33b1958f57c788 (patch)
tree9a643af267dd674c0e2b17191ab8420b50ac37bd /astro
parent30056fc4bc9c407417cca0410c7889296ab76ae5 (diff)
downloadfreebsd-ports-gnome-c7315ae9c194cde6fd0980e9bb33b1958f57c788.tar.gz
freebsd-ports-gnome-c7315ae9c194cde6fd0980e9bb33b1958f57c788.tar.zst
freebsd-ports-gnome-c7315ae9c194cde6fd0980e9bb33b1958f57c788.zip
- Add USES=libtool
- Replace pre-configure with standard USE_AUTOTOOLS - Remove CFLAGS that are already default - pkg-plist fixes
Diffstat (limited to 'astro')
-rw-r--r--astro/boinc-astropulse/Makefile22
-rw-r--r--astro/boinc-astropulse/pkg-plist4
2 files changed, 9 insertions, 17 deletions
diff --git a/astro/boinc-astropulse/Makefile b/astro/boinc-astropulse/Makefile
index 26d98fe9a112..23897ca98b11 100644
--- a/astro/boinc-astropulse/Makefile
+++ b/astro/boinc-astropulse/Makefile
@@ -3,7 +3,7 @@
PORTNAME= boinc-astropulse
PORTVERSION= 6.01
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= astro
MASTER_SITES= ${MASTER_SITE_LOCAL} \
ftp://rene-ladan.nl/pub/distfiles/
@@ -21,16 +21,14 @@ BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3 \
RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
LIB_DEPENDS= libfftw3f.so:${PORTSDIR}/math/fftw3-float
-USES= tar:xz gmake pkgconfig
-USE_AUTOTOOLS= autoconf:env automake:env libtool
GNU_CONFIGURE= yes
+USES= gmake libtool pkgconfig tar:xz
+USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
+AUTOMAKE_ARGS= -a -c -f
WRKSRC= ${WRKDIR}/${DISTNAME}/client
-CFLAGS+= -O2 -I${LOCALBASE}/include/boinc -I${LOCALBASE}/include \
- -L${LOCALBASE}/lib
-.if defined(CPUTYPE)
-CFLAGS+= -march=${CPUTYPE}
-.endif
+CPPFLAGS+= -I${LOCALBASE}/include/boinc -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
# these must match settings in ${PORTSDIR}/net/boinc-client/Makefile
BOINC_CLIENT_USER?= boinc
@@ -54,11 +52,6 @@ X11_CONFIGURE_ENABLE= graphics
BUILD_DEPENDS+= ${LOCALBASE}/include/boinc/std_fixes.h:${PORTSDIR}/net/boinc-client
.endif
-.if ${ARCH} == amd64 || ${ARCH} == i386
-# comment out if world is built with clang and port with gcc
-CFLAGS+= -mtune=native
-.endif
-
SETI_WORK!= cd ${.CURDIR}/../boinc-setiathome-v7 && ${MAKE} -V WRKSRC
CONFIGURE_ENV+= BOINCDIR="${NONEXISTENT}" \
BOINC_DIR="${NONEXISTENT}" \
@@ -82,9 +75,6 @@ PLIST_SUB+= AP_BINARY=${AP_BINARY} \
BOINC_CLIENT_USER=${BOINC_CLIENT_USER} \
BOINC_CLIENT_GROUP=${BOINC_CLIENT_GROUP}
-pre-configure:
- (cd ${WRKSRC} ; ./_autosetup)
-
do-install:
${INSTALL} -d ${STAGEDIR}${BOINC_CLIENT_HOME}/projects
${INSTALL} -d ${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}
diff --git a/astro/boinc-astropulse/pkg-plist b/astro/boinc-astropulse/pkg-plist
index c61d982e7bd7..828d927af157 100644
--- a/astro/boinc-astropulse/pkg-plist
+++ b/astro/boinc-astropulse/pkg-plist
@@ -5,4 +5,6 @@ projects/%%SETI_SITE%%/%%AP_BINARY%%
%%X11%%projects/%%SETI_SITE%%/ap_graphics
@dirrmtry projects/%%SETI_SITE%%
@dirrmtry projects
-@exec chown -R %%BOINC_CLIENT_USER%%:%%BOINC_CLIENT_GROUP%% projects/
+@owner root
+@group wheel
+@cwd