aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2009-10-20 03:35:15 +0800
committernox <nox@FreeBSD.org>2009-10-20 03:35:15 +0800
commitd885645337eb41ec6b75a6574716705679eddf80 (patch)
treecaf48bddf62f0e725985d26623c6a31e09d6f79f /astro
parent7464e67b808fc4ca242da50cdbacb99ec989701d (diff)
downloadfreebsd-ports-gnome-d885645337eb41ec6b75a6574716705679eddf80.tar.gz
freebsd-ports-gnome-d885645337eb41ec6b75a6574716705679eddf80.tar.zst
freebsd-ports-gnome-d885645337eb41ec6b75a6574716705679eddf80.zip
Add a conditional IGNORE so people using a too old Linux base get a
(hopefully) more meaningful error message than a link errror at start. Discussed on: freebsd-emulation@, see this thread: http://lists.freebsd.org/pipermail/freebsd-emulation/2009-October/006970.html
Diffstat (limited to 'astro')
-rw-r--r--astro/google-earth/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/astro/google-earth/Makefile b/astro/google-earth/Makefile
index aab4e75a9731..fc14ac653ec0 100644
--- a/astro/google-earth/Makefile
+++ b/astro/google-earth/Makefile
@@ -38,6 +38,14 @@ RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
USE_LINUX_APPS+= dri
.endif
+.if ${OSVERSION}<700055
+IGNORE= FreeBSD>=7.X is needed with Linux emulation 2.6.x.
+.elif ${OSVERSION}<800076 && \
+ ! defined (OVERRIDE_LINUX_NONBASE_PORTS) || \
+ ! (${OVERRIDE_LINUX_NONBASE_PORTS} == f10)
+IGNORE= needs non-default linux ports (define OVERRIDE_LINUX_BASE_PORT=f10 and OVERRIDE_LINUX_NONBASE_PORTS=f10)
+.endif
+
do-extract:
@${MKDIR} ${WRKSRC}
@${CP} ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES} ${WRKSRC}