aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2009-03-28 00:52:58 +0800
committernaddy <naddy@FreeBSD.org>2009-03-28 00:52:58 +0800
commitf911c8e90e03a71a0e4b7af45e25f147c27ce4a6 (patch)
treefb234673b88a080397dd78083c8454a69e6df269 /astro
parentf6b0611dcc0eb4238cbd8b0f522e19b30654b59e (diff)
downloadfreebsd-ports-gnome-f911c8e90e03a71a0e4b7af45e25f147c27ce4a6.tar.gz
freebsd-ports-gnome-f911c8e90e03a71a0e4b7af45e25f147c27ce4a6.tar.zst
freebsd-ports-gnome-f911c8e90e03a71a0e4b7af45e25f147c27ce4a6.zip
Mark MAKE_JOBS_SAFE and squash some warnings.
Diffstat (limited to 'astro')
-rw-r--r--astro/xworld/Makefile1
-rw-r--r--astro/xworld/files/patch-compile_world.c10
-rw-r--r--astro/xworld/files/patch-pad.c10
3 files changed, 21 insertions, 0 deletions
diff --git a/astro/xworld/Makefile b/astro/xworld/Makefile
index b22cfe4beb34..fbdfada06d8a 100644
--- a/astro/xworld/Makefile
+++ b/astro/xworld/Makefile
@@ -23,6 +23,7 @@ CONFIGURE_ENV= CAT=${CAT} \
INCLUDES="-I${LOCALBASE}/include" \
LDLIBS="-lm -L${LOCALBASE}/lib -lX11" \
MORELIBS=""
+MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/xworld
STRIP= #don't strip out image data on install
diff --git a/astro/xworld/files/patch-compile_world.c b/astro/xworld/files/patch-compile_world.c
new file mode 100644
index 000000000000..9c457be19215
--- /dev/null
+++ b/astro/xworld/files/patch-compile_world.c
@@ -0,0 +1,10 @@
+--- compile_world.c.orig 2009-03-27 17:51:01.000000000 +0100
++++ compile_world.c 2009-03-27 17:51:15.000000000 +0100
+@@ -33,6 +33,7 @@
+ #include <sys/types.h>
+ #include <sys/mman.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "Sphere.h"
+ #include "SphereDim.h"
+
diff --git a/astro/xworld/files/patch-pad.c b/astro/xworld/files/patch-pad.c
new file mode 100644
index 000000000000..f132d1983ae8
--- /dev/null
+++ b/astro/xworld/files/patch-pad.c
@@ -0,0 +1,10 @@
+--- pad.c.orig 2009-03-27 17:49:37.000000000 +0100
++++ pad.c 2009-03-27 17:50:01.000000000 +0100
+@@ -35,6 +35,7 @@
+ #include <fcntl.h>
+ #include <unistd.h>
+ #include <stdio.h>
++#include <stdlib.h>
+
+ #define roundup(x, y) ((((x)+((y)-1))/(y))*(y))
+