aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-08-09 06:22:39 +0800
committerpav <pav@FreeBSD.org>2008-08-09 06:22:39 +0800
commitd16ed0edd65f239e3521d203d11b18d97a775e0b (patch)
tree62ae5fbdb6030536d133a7bd56228b14df3c25cd /astro
parent06e80f9a7447f040586e611c39f8fa832f416497 (diff)
downloadfreebsd-ports-gnome-d16ed0edd65f239e3521d203d11b18d97a775e0b.tar.gz
freebsd-ports-gnome-d16ed0edd65f239e3521d203d11b18d97a775e0b.tar.zst
freebsd-ports-gnome-d16ed0edd65f239e3521d203d11b18d97a775e0b.zip
Milkyway@home is a research project that uses Internet-connected computers to
do research in modeling and determining the evolution of the Milkyway galaxy. WWW: http://milkyway.cs.rpi.edu/milkyway/
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/boinc-milkyway/Makefile67
-rw-r--r--astro/boinc-milkyway/distinfo6
-rw-r--r--astro/boinc-milkyway/files/app_info.xml.in17
-rw-r--r--astro/boinc-milkyway/files/pkg-message.in22
-rw-r--r--astro/boinc-milkyway/pkg-descr4
-rw-r--r--astro/boinc-milkyway/pkg-plist4
7 files changed, 121 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index f7a0214b0b17..3d5034564a8f 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -6,6 +6,7 @@
SUBDIR += aa
SUBDIR += accrete
SUBDIR += boinc-einsteinathome
+ SUBDIR += boinc-milkyway
SUBDIR += boinc-setiathome-enhanced
SUBDIR += celestia
SUBDIR += celestia-gnome
diff --git a/astro/boinc-milkyway/Makefile b/astro/boinc-milkyway/Makefile
new file mode 100644
index 000000000000..db2deab83447
--- /dev/null
+++ b/astro/boinc-milkyway/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: boinc-milkyway
+# Date created: 8 August 2008
+# Whom: Pav Lucistnik <pav@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= boinc-milkyway
+PORTVERSION= 1.21
+CATEGORIES= astro
+MASTER_SITES= http://milkyway.cs.rpi.edu/milkyway/download/
+DISTNAME= astronomy_${PORTVERSION}_${ARCH}-unknown-freebsd
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= Modelling the evolution of the Milkyway Galaxy
+
+EXTRACT_SUFX= #
+
+.include <bsd.port.pre.mk>
+
+ONLY_FOR_ARCHS= i386 amd64
+
+.if ${OSVERSION} >= 700000
+LIB_DEPENDS+= c.6:${PORTSDIR}/misc/compat6x
+.endif
+
+RUN_DEPENDS+= boinc_client:${PORTSDIR}/net/boinc-client
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+STRIP= #
+
+# these must match settings in ${PORTSDIR}/net/boinc-client/Makefile
+BOINC_USER?= boinc
+BOINC_GROUP?= nobody
+BOINC_HOME?= /var/db/boinc
+
+MILKYWAY_SITE= milkyway.cs.rpi.edu_milkyway
+MILKYWAY_URL= milkyway.cs.rpi.edu/milkyway
+MILKYWAY_BINARY=${DISTNAME}
+
+.if ${ARCH} == amd64 && ${OSVERSION} >= 600000
+AMD64= ""
+.else
+AMD64= "@comment "
+.endif
+
+SUB_FILES= pkg-message app_info.xml
+SUB_LIST= AMD64=${AMD64} MILKYWAY_VERSION=${PORTVERSION:S/.//} MILKYWAY_BINARY="${MILKYWAY_BINARY}"
+
+PLIST_SUB= MILKYWAY_BINARY="${MILKYWAY_BINARY}" MILKYWAY_SITE=${MILKYWAY_SITE} \
+ BOINC_HOME=${BOINC_HOME}
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${CP} ${DISTDIR}/${DISTNAME} ${WRKDIR}
+
+do-install:
+ ${INSTALL} -d -o ${BOINC_USER} -g ${BOINC_GROUP} ${BOINC_HOME}/projects
+ ${INSTALL} -d -o ${BOINC_USER} -g ${BOINC_GROUP} ${BOINC_HOME}/projects/${MILKYWAY_SITE}
+ ${INSTALL_DATA} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKDIR}/app_info.xml ${BOINC_HOME}/projects/${MILKYWAY_SITE}
+ ${INSTALL_PROGRAM} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKDIR}/${MILKYWAY_BINARY} ${BOINC_HOME}/projects/${MILKYWAY_SITE}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/astro/boinc-milkyway/distinfo b/astro/boinc-milkyway/distinfo
new file mode 100644
index 000000000000..03ba6e78bc95
--- /dev/null
+++ b/astro/boinc-milkyway/distinfo
@@ -0,0 +1,6 @@
+MD5 (astronomy_1.21_amd64-unknown-freebsd) = b0e2def4033f1d6931b9aea552c6abe6
+SHA256 (astronomy_1.21_amd64-unknown-freebsd) = fe17316df1de0916af60e23b8953be4329514ba1dd0fb691df1b46801a7a464d
+SIZE (astronomy_1.21_amd64-unknown-freebsd) = 315101
+MD5 (astronomy_1.21_i386-unknown-freebsd) = 0c7db6aec0895c2ff2bb071b2b202797
+SHA256 (astronomy_1.21_i386-unknown-freebsd) = 5e1a1af979c18c1056df905a81174374add773c1d746127a0304b76f2fd58bd5
+SIZE (astronomy_1.21_i386-unknown-freebsd) = 288688
diff --git a/astro/boinc-milkyway/files/app_info.xml.in b/astro/boinc-milkyway/files/app_info.xml.in
new file mode 100644
index 000000000000..2f98574f77b1
--- /dev/null
+++ b/astro/boinc-milkyway/files/app_info.xml.in
@@ -0,0 +1,17 @@
+<app_info>
+<app>
+<name>astronomy</name>
+</app>
+<file_info>
+<name>%%MILKYWAY_BINARY%%</name>
+<executable/>
+</file_info>
+<app_version>
+<app_name>astronomy</app_name>
+<version_num>%%MILKYWAY_VERSION%%</version_num>
+<file_ref>
+<file_name>%%MILKYWAY_BINARY%%</file_name>
+<main_program/>
+</file_ref>
+</app_version>
+</app_info>
diff --git a/astro/boinc-milkyway/files/pkg-message.in b/astro/boinc-milkyway/files/pkg-message.in
new file mode 100644
index 000000000000..4929ccf9b2f5
--- /dev/null
+++ b/astro/boinc-milkyway/files/pkg-message.in
@@ -0,0 +1,22 @@
+*****************************************************************************
+ATTACHING PROJECT
+
+Just run boinc_gui, choose Attach, and follow instructions.
+Project URL is milkyway.cs.rpi.edu/milkyway
+
+MANUAL INSTALLATION
+ *) If this is your first time in any BOINC project, create a new account at
+ http://milkyway.cs.rpi.edu/milkyway/create_account_form.php
+
+ *) Or get your account key at http://milkyway.cs.rpi.edu/milkyway/get_passwd.php
+
+ *) Attach to the project:
+ cd /var/db/boinc
+ boinc_cmd --project_attach milkyway.cs.rpi.edu/milkyway <account key>
+*****************************************************************************
+%%AMD64%% IMPORTANT NOTICE FOR AMD64 USERS RUNNING 6.X:
+%%AMD64%%
+%%AMD64%% You have to have this line in /etc/libmap32.conf:
+%%AMD64%% libpthread.so.1 libc_r.so.5
+%%AMD64%% before you attach the project. Otherwise it will not work.
+%%AMD64%%*****************************************************************************
diff --git a/astro/boinc-milkyway/pkg-descr b/astro/boinc-milkyway/pkg-descr
new file mode 100644
index 000000000000..4a47739fec2f
--- /dev/null
+++ b/astro/boinc-milkyway/pkg-descr
@@ -0,0 +1,4 @@
+Milkyway@home is a research project that uses Internet-connected computers to
+do research in modeling and determining the evolution of the Milkyway galaxy.
+
+WWW: http://milkyway.cs.rpi.edu/milkyway/
diff --git a/astro/boinc-milkyway/pkg-plist b/astro/boinc-milkyway/pkg-plist
new file mode 100644
index 000000000000..eec65e7c89d2
--- /dev/null
+++ b/astro/boinc-milkyway/pkg-plist
@@ -0,0 +1,4 @@
+@cwd %%BOINC_HOME%%
+projects/%%MILKYWAY_SITE%%/app_info.xml
+projects/%%MILKYWAY_SITE%%/%%MILKYWAY_BINARY%%
+@unexec rmdir %D/projects/%%MILKYWAY_SITE%% 2>/dev/null || true