aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-09-29 01:20:42 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-09-29 01:20:42 +0800
commitff2e1513055cac9087cc18a9abf2580c32f0498b (patch)
treeacb73643f4fe5f57790ed056215bc1db842b57ce /astro
parentcca6c325aeb2ff3ff53127a2b3a415a6273ef856 (diff)
downloadfreebsd-ports-gnome-ff2e1513055cac9087cc18a9abf2580c32f0498b.tar.gz
freebsd-ports-gnome-ff2e1513055cac9087cc18a9abf2580c32f0498b.tar.zst
freebsd-ports-gnome-ff2e1513055cac9087cc18a9abf2580c32f0498b.zip
Implemented complete support for test target.
You can now `make test' on any port to run test sequence, no-op by default. If a port defines TEST_TARGET, it'll run sub-make with specified target, usually `check' or `test', useful if upstream supports that. The port may instead define custom do-test target, as well as usual satellite targets: {pre,do,post}-test, {pre,do,post}-test-OPT, {pre,do,post}-test-OPT-off `make test' builds and stages port first, so test may use both WRKDIR and STAGEDIR, and both BUILD and RUN depends are available for test target. Additionally, TEST_DEPENDS is now properly supported and may be used to define additional depends specifically for testing. Framework may define default tests for specific cases. For instance, perl5.mk and cran.mk already provide default test target on their own. This commit also converts my ports which have tests to this new framework. Approved by: portmgr (bapt) Differential Revision: D3680
Diffstat (limited to 'astro')
-rw-r--r--astro/osmium/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/astro/osmium/Makefile b/astro/osmium/Makefile
index 261d5e25691c..49dcc925bac1 100644
--- a/astro/osmium/Makefile
+++ b/astro/osmium/Makefile
@@ -46,9 +46,6 @@ do-build-DOXYGEN-on:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKR_ARGS} doc
-regression-test:
- cd ${WRKSRC}/test && ${SETENV} ${MAKE_ENV} ${SH} run_tests.sh
-
do-install:
cd ${WRKSRC}/include && ${COPYTREE_SHARE} '${PORTNAME} ${PORTNAME}.hpp' \
${STAGEDIR}${PREFIX}/include/
@@ -58,4 +55,7 @@ do-install:
do-install-DOXYGEN-on:
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR}/
+do-test:
+ cd ${WRKSRC}/test && ${SETENV} ${MAKE_ENV} ${SH} run_tests.sh
+
.include <bsd.port.mk>