aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorler <ler@FreeBSD.org>2018-01-14 14:57:10 +0800
committerler <ler@FreeBSD.org>2018-01-14 14:57:10 +0800
commit46e36301e1a298994d4c7c7be970d8e8f7ff1277 (patch)
tree082d40d078482d66f5b92dd3177136a8b14329b5 /astro
parent39cc3beb81391d1aacd05e359d2e1bfc0d3613f8 (diff)
downloadfreebsd-ports-gnome-46e36301e1a298994d4c7c7be970d8e8f7ff1277.tar.gz
freebsd-ports-gnome-46e36301e1a298994d4c7c7be970d8e8f7ff1277.tar.zst
freebsd-ports-gnome-46e36301e1a298994d4c7c7be970d8e8f7ff1277.zip
clang 6 generates some new warnings, suppress them for now.
Diffstat (limited to 'astro')
-rw-r--r--astro/boinc-setiathome-v7/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/astro/boinc-setiathome-v7/Makefile b/astro/boinc-setiathome-v7/Makefile
index f096d4863ae3..71ea466e4ed4 100644
--- a/astro/boinc-setiathome-v7/Makefile
+++ b/astro/boinc-setiathome-v7/Makefile
@@ -3,7 +3,7 @@
PORTNAME= boinc-setiathome-v7
PORTVERSION= 7.00
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= astro
MASTER_SITES= LOCAL/rene
DISTNAME= setiathome-svn-1924 # modified archive, see leftout in top directory
@@ -19,7 +19,7 @@ RUN_DEPENDS= boinc_client:net/boinc-client
LIB_DEPENDS= libfftw3f.so:math/fftw3-float
GNU_CONFIGURE= yes
-USES= autoreconf gmake libtool pkgconfig tar:xz
+USES= autoreconf compiler gmake libtool pkgconfig ssl tar:xz
CFLAGS+= -O2 -I${LOCALBASE}/include/boinc -I${LOCALBASE}/include \
-L${LOCALBASE}/lib
@@ -53,6 +53,12 @@ CFLAGS_amd64= -mtune=native
CONFIGURE_ARGS+= --enable-altivec
.endif
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} == 60
+CFLAGS+= -Wno-reserved-user-defined-literal -Wno-unused-command-line-argument
+.endif
+
CONFIGURE_ENV+= BOINCDIR="${NONEXISTENT}"
CONFIGURE_ARGS+= --disable-static-client --disable-server \
@@ -97,4 +103,4 @@ do-install-X11-on:
${INSTALL_PROGRAM} ${WRKSRC}/client/seti_graphics \
${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>