aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2015-10-01 11:53:02 +0800
committervanilla <vanilla@FreeBSD.org>2015-10-01 11:53:02 +0800
commit49cce949821514b696dbad3085691e87f64f0bf2 (patch)
treedee3e377a28f90cd1ef63baf9c248255200db82b /astro
parent43daf719b25d3a696a2c0c7a6fc1cddb1da1e4a2 (diff)
downloadfreebsd-ports-gnome-49cce949821514b696dbad3085691e87f64f0bf2.tar.gz
freebsd-ports-gnome-49cce949821514b696dbad3085691e87f64f0bf2.tar.zst
freebsd-ports-gnome-49cce949821514b696dbad3085691e87f64f0bf2.zip
Upgrade to 1.86, and regen patches.
Diffstat (limited to 'astro')
-rw-r--r--astro/nightfall/Makefile3
-rw-r--r--astro/nightfall/distinfo4
-rw-r--r--astro/nightfall/files/patch-Light.c6
-rw-r--r--astro/nightfall/files/patch-Light.h6
-rw-r--r--astro/nightfall/files/patch-LightGLAnimate.c4
-rw-r--r--astro/nightfall/files/patch-LightGnome.c6
-rw-r--r--astro/nightfall/files/patch-distribute.c16
7 files changed, 30 insertions, 15 deletions
diff --git a/astro/nightfall/Makefile b/astro/nightfall/Makefile
index 26aacf404e52..f837b45cde4a 100644
--- a/astro/nightfall/Makefile
+++ b/astro/nightfall/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= nightfall
-PORTVERSION= 1.70
-PORTREVISION= 12
+PORTVERSION= 1.86
CATEGORIES= astro
MASTER_SITES= http://www.la-samhna.de/nightfall/
diff --git a/astro/nightfall/distinfo b/astro/nightfall/distinfo
index 712d42e3a4af..0d7319ee7b9d 100644
--- a/astro/nightfall/distinfo
+++ b/astro/nightfall/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nightfall-1.70.tar.gz) = d282b3d5f90e51284cbfb1619ab54184549eb2a21422ee452d794cded58c14de
-SIZE (nightfall-1.70.tar.gz) = 1457748
+SHA256 (nightfall-1.86.tar.gz) = 2394133c77d512f048198da91a9bf9378887997c4df1a7283e6b91f08dd54e80
+SIZE (nightfall-1.86.tar.gz) = 1479521
diff --git a/astro/nightfall/files/patch-Light.c b/astro/nightfall/files/patch-Light.c
index b2f9217bed87..509591a83a40 100644
--- a/astro/nightfall/files/patch-Light.c
+++ b/astro/nightfall/files/patch-Light.c
@@ -1,6 +1,6 @@
---- Light.c.orig Thu Oct 20 22:54:11 2005
-+++ Light.c Wed Dec 7 02:43:38 2005
-@@ -275,8 +275,10 @@
+--- Light.c.orig 2014-09-25 08:03:26 UTC
++++ Light.c
+@@ -252,8 +252,10 @@ int main(int argc, char *argv[])
/* >>>>>>>>>>>>>>>> ALLOCATE MEMORY <<<<<<<<<<<<<<<<<<<<< */
diff --git a/astro/nightfall/files/patch-Light.h b/astro/nightfall/files/patch-Light.h
index ee425a24f47f..bd73f74cb55f 100644
--- a/astro/nightfall/files/patch-Light.h
+++ b/astro/nightfall/files/patch-Light.h
@@ -1,6 +1,6 @@
---- Light.h.orig Thu Oct 20 22:18:52 2005
-+++ Light.h Wed Dec 7 02:47:16 2005
-@@ -805,7 +805,9 @@
+--- Light.h.orig 2014-09-25 09:25:17 UTC
++++ Light.h
+@@ -935,7 +935,9 @@ void DefineAxis(double *Min, double *Max
/* */
/**************************************************************************/
diff --git a/astro/nightfall/files/patch-LightGLAnimate.c b/astro/nightfall/files/patch-LightGLAnimate.c
index 310eef55e86a..96a5b299da9b 100644
--- a/astro/nightfall/files/patch-LightGLAnimate.c
+++ b/astro/nightfall/files/patch-LightGLAnimate.c
@@ -1,5 +1,5 @@
---- LightGLAnimate.c.orig Tue Nov 25 00:21:36 2003
-+++ LightGLAnimate.c Tue Nov 25 00:24:22 2003
+--- LightGLAnimate.c.orig 2014-05-13 08:45:46 UTC
++++ LightGLAnimate.c
@@ -25,6 +25,7 @@
#include <stdio.h>
#include <stdlib.h>
diff --git a/astro/nightfall/files/patch-LightGnome.c b/astro/nightfall/files/patch-LightGnome.c
index fcbba3da3294..55c6ac5a1769 100644
--- a/astro/nightfall/files/patch-LightGnome.c
+++ b/astro/nightfall/files/patch-LightGnome.c
@@ -1,6 +1,6 @@
---- LightGnome.c.orig Thu Oct 27 21:46:52 2005
-+++ LightGnome.c Wed Dec 7 02:44:36 2005
-@@ -335,7 +335,11 @@
+--- LightGnome.c.orig 2011-11-18 12:47:36 UTC
++++ LightGnome.c
+@@ -333,7 +333,11 @@ gint
FileType *dataFile = FileList;
char path[256];
diff --git a/astro/nightfall/files/patch-distribute.c b/astro/nightfall/files/patch-distribute.c
new file mode 100644
index 000000000000..bed840d97aa4
--- /dev/null
+++ b/astro/nightfall/files/patch-distribute.c
@@ -0,0 +1,16 @@
+--- distribute.c.orig 2012-01-25 13:36:01 UTC
++++ distribute.c
+@@ -36,11 +36,11 @@ static char * build_cmdline(int full)
+ {
+ int i;
+ char temp[512];
+- size_t size = strlen(program_invocation_name) + 1;
++ size_t size = strlen(g_get_prgname()) + 1;
+ size_t len;
+ char * cmdline = malloc(size);
+
+- strncpy(cmdline, program_invocation_name, size);
++ strncpy(cmdline, g_get_prgname(), size);
+
+ if (full)
+ {
'insertions'>+4 * . Update to tzupdater 1.3.6.glewis2008-07-142-6/+6 * . Update to 1.4.2_18.glewis2008-07-143-6/+7 * . Update to 1.5.0_16.glewis2008-07-143-6/+7 * . Update to Update 7.glewis2008-07-133-6/+274 * . Update to tzupdater 1.3.6.glewis2008-07-132-6/+6 * . Update to tzupdater 1.3.6.glewis2008-07-132-6/+6 * . Update to tzupdater 1.3.6.glewis2008-07-134-12/+12 * - Fix buildmiwi2008-07-092-335/+325 * - Mark BROKEN: does not packagepav2008-07-091-0/+2 * - Change mantainership to Brad Clawsieanray2008-07-051-1/+1 * - Update to 1.3.18nivit2008-07-032-5/+4 * (1) Fix bindings dependencies when WITH_FREEBSD_SUBVERSION is setlev2008-07-021-1/+1 * . Update to 1.4.2_17.glewis2008-07-023-7/+7 * . Report when the time zone data is being updated.glewis2008-07-012-4/+6 * Fix CATEGORIES for subversion & binding ports.lev2008-06-301-1/+1 * Add subversion-java: high-level bindings for Java and subversion VCS.lev2008-06-304-0/+56 * - respect NOPORTDOCS and NOPORTEXAMPLESitetcu2008-06-282-31/+32 * - s/NOPORTDOCS/NO_INSTALL_MANPAGES/ where neededitetcu2008-06-282-3/+6 * Unbreak and make fetchable again.olgeni2008-06-266-14/+42 * . Don't cheat on BUILD_DEPENDS in regards to a bootstrap JDK as thisglewis2008-06-251-4/+3 * - Remove java/bsh port after repocopy to lang/bsh, changing your main category.lippe2008-06-235-48/+0 * - Update to 1.4.1gahr2008-06-232-6/+5 * - Fix buildmiwi2008-06-231-2/+2 * - Mark BROKEN: unfetchablepav2008-06-232-0/+4 * - Fix build with jdk16miwi2008-06-212-3/+5 * JTiger is a unit test framework and tools for the Java 2 Platform. Themiwi2008-06-205-0/+712 * - Update to 1.1.1gahr2008-06-192-7/+6 * - This port has been BROKEN for more than 6 months. It will be removed unlesspav2008-06-191-0/+2 * Set IGNORE if NOPORTDOCS is set: this port installs only documentation.ale2008-06-081-0/+4 * - Update to 5.12.0.4. [1]araujo2008-06-072-6/+5 * Bump portrevision due to upgrade of devel/gettext.edwin2008-06-06132-97/+132 * Update to 1.4.0 and unbreak.itetcu2008-06-052-9/+6 * Broken, The URL to manually fetch the DISTFILES gives a 404.itetcu2008-06-051-0/+2 * - Fix buidmiwi2008-05-262-2/+3 * - Fix buildmiwi2008-05-222-4/+13 * - Update to 1.3.17nivit2008-05-212-4/+4 * - Fix build/install problemsmiwi2008-05-183-5576/+5611 * Upgrade from 3.2.13 to 3.2.76.mi2008-05-172-6/+5 * . Enable system tray support for Enlightenment.glewis2008-05-161-0/+13 * Upgrade to version 6.1.olgeni2008-05-156-26/+24 * Add support for running module suites in place on FreeBSD.olgeni2008-05-152-0/+28 * . Update to Eclipse 3.3.2.glewis2008-05-1087-1834/+1276 * . Update to tzupdater 1.3.5. This patch is based on that submitted in theglewis2008-05-062-7/+7 * - Update to version 4.4 [1]hq2008-05-062-13/+8 * Drop maintainership, as it looks like i am motivated enough to fix this port.arved2008-05-041-1/+1 * . Update to tzupdater 1.3.5. This patch is based on that submitted in theglewis2008-05-032-6/+7 * . Update to tzupdater 1.3.5. This patch is based on that submitted in theglewis2008-05-032-6/+7 * . Use the correct specifier for printing a size_t.glewis2008-05-031-0/+13 * - Does not configure: configure: error: cannot find jni.hpav2008-05-031-0/+2 * . Update to tzupdater 1.3.5. This patch is based on that submitted in theglewis2008-05-033-9/+12 * . Update to tzupdater 1.3.5. This patch is based on that submitted in theglewis2008-05-033-9/+12 * - Update to 2.5.4miwi2008-05-012-4/+4 * Try jman(1) from ports/japanese/man instead of man(1) for japanese manualjkim2008-05-012-3/+8 * . Update to 1.6.0_06/6u6.glewis2008-04-293-5/+7 * . Update to 1.5.0_15.glewis2008-04-292-4/+4 * - Add support for 1.6 VMs.jkim2008-04-282-8/+11 * - Update to 2.5.3miwi2008-04-272-4/+4 * - Fix patch reject after xorg cleanupmiwi2008-04-261-11/+11 * Update to 0.7.3hq2008-04-242-5/+4 * - Fix build after xorg cleanupmiwi2008-04-201-2/+2 * - Fix build after xorg cleanupmiwi2008-04-201-2/+2 * - Remove unneeded dependency from gtk12/gtk20 [1]miwi2008-04-2047-102/+101 * . Point people to the archive for Update 14.glewis2008-04-131-1/+1 * - Update to 1.1.6.009905nivit2008-04-114-10/+10 * - Update to 1.3.15nivit2008-04-112-4/+4 * - Update to 1.4.2gahr2008-04-083-6/+6 * Update to version 1.1hq2008-04-062-4/+4 * - Cleanup directoriespav2008-04-052-0/+2 * JamVM is an extremely small Java Virtual Machine which conforms to thepav2008-04-045-0/+93 * - Adapt for new libffi, and various fixespav2008-04-041-5/+8 * - Update to 0.93, last that can be built with jikespav2008-04-044-21/+96 * Distfile re-rolled, but no changes.ale2008-04-031-3/+3 * . Fix build by correctly setting the arch on recent FreeBSD/pc98 versions.glewis2008-04-021-5/+12 * - Update to 1.3.14nivit2008-04-012-4/+4 * Update to 1.39 release:ale2008-03-313-10/+33 * - Update to 3.0.2miwi2008-03-302-18/+15 * . Update to 1.1.3.glewis2008-03-246-93/+37 * - Fix typogahr2008-03-191-1/+2 * Update to 4.2 release.ale2008-03-182-4/+4 * - Update to 0.4.6gahr2008-03-183-86/+83 * - Update to 1.3.2.20080222gahr2008-03-182-8/+9 * - Update to 2.5.2rafan2008-03-102-4/+4 * - Update to 0.6.0miwi2008-03-073-46/+17 * Update to third edition.ale2008-02-282-8/+6 * 2007-12-12 net-im/wildfire: Use net-im/openfire instead of this portmiwi2008-02-288-247/+0 * Apache Commons project are no longer hosted under MASTER_SITES_APACHEehaupt2008-02-2711-22/+22 * - Update to 1.1.3.007983nivit2008-02-264-8/+8 * . Fix a crash caused by the "Open File" dialogue.glewis2008-02-222-1/+40 * - Use devel/libffi instead of devel/libffi-develmiwi2008-02-211-3/+3 * - Update to 2.5.1miwi2008-02-192-4/+4 * . Update to patchset 4.glewis2008-02-179-66/+50 * - Update to 1.1.2.007725nivit2008-02-164-8/+8 * - Add backup mirrormiwi2008-02-161-1/+2 * . Update to 1.5.0_14 and patchset 8.glewis2008-02-154-776/+18 * Upgrade to version 6.0.1.olgeni2008-02-124-10/+10 * - Bump PORTREVISION for previous commitpav2008-02-081-0/+1 * . Fix locale generation and hence locale handling in general.glewis2008-02-042-1/+16 * Mark BROKEN: does not fetcherwin2008-02-031-0/+2 * Fix pkg-plist, use USE_RC_SUBR instead.vanilla2008-02-013-41/+46 * Add avis 1.2.0, elvin Publish/Subscribe Message Bus server based on thevanilla2008-01-299-0/+160 * The Spring Framework is the leading full stack Java/JEE applicationmiwi2008-01-234-0/+131 * - Update to 1.1.0.007007 (from 004323)nivit2008-01-234-10/+12 * PyDev is a plugin that enables users to use Eclipse for Python and Jythonnivit2008-01-235-0/+60 * . Make CUPS a build depends only and depend on the header file searchedglewis2008-01-211-2/+2 * - Mark BROKEN: unfetchablepav2008-01-211-0/+2 * - Update to 1.0.9.araujo2008-01-202-6/+5 * - Update to 1.0.12.araujo2008-01-202-5/+5 * . Force eclipse to use one of the jdk* ports rather than the diablo-jdk15glewis2008-01-172-1/+15 * . Make eclipse-devel.desktop point to eclipse-devel as it should ratherglewis2008-01-174-9/+19 * RDT is an open source Ruby IDE for the Eclipse platform.miwi2008-01-144-0/+84 * . Install the PKCS#11 JAR and build and install the PKCS#11 native library.glewis2008-01-143-1/+54 * . Update to 1.6.0_04/6u4.glewis2008-01-143-76/+121 * . Update to 1.5.0_14.glewis2008-01-132-5/+5 * . Update to 1.4.2_16.glewis2008-01-133-7/+12 * . Update to tzupdater 1.3.3.glewis2008-01-132-7/+7 * . Update to tzupdater 1.3.3.glewis2008-01-132-7/+7 * . Implement OpenFileDescriptorCount for BSD. This requires fdescfs.glewis2008-01-131-3/+55 * . Update to tzupdater 1.3.3.glewis2008-01-132-6/+7 * . Update to tzupdater 1.3.3.glewis2008-01-136-14/+42 * - Update to 1.0.8a.araujo2008-01-022-5/+4 * - Update to 1.0.10.araujo2008-01-022-5/+4 * . Implement or fix more of the OS specific statistics gathering functions.glewis2008-01-022-1/+122 * o Switch to a static PLIST instead of a install time generated timelioux2007-12-252-4/+508 * New port eclipse-hibernatetools "x-mas" :) version 3.2.0 beta9a:lioux2007-12-255-0/+388 * o Update to 1.5.1_101607lioux2007-12-243-19/+57 * Aptana Studio is an IDE, designed for web developers and providesnivit2007-12-227-0/+127 * Commonclipse is an eclipse plugin for jakarta commons-lang users.miwi2007-12-215-0/+49 * upgrade to 4.4ijliao2007-12-202-7/+6 * Fix path for grep and gconftool-2 in startup script.olgeni2007-12-204-0/+118 * Upgrade to version 6.0.olgeni2007-12-196-26/+22 * Update to 4.1 release.ale2007-12-192-4/+4 * - Register conflicts against sablevm-classpathpav2007-12-161-0/+2 * - Update to 1.13pav2007-12-1611-2915/+5705 * - update to 5.5.1nemoliu2007-12-142-9/+6 * - Update to 4.2.2rafan2007-12-132-5/+5 * Remove obsolete JDK versions 1.1 and 1.2, and the ports depending on them.linimon2007-12-1246-6565/+0 * Update to 1.3.0.20071108lioux2007-12-122-11/+63 * Drop maintainershiplioux2007-12-121-1/+1 * Fix DESCRlioux2007-12-121-14/+2 * Update to 1.38 release.ale2007-12-122-4/+4 * Broken: leaves egg file behind on deinstall.linimon2007-11-251-0/+2 * . Update to patchset 3, based on 1.6.0_03 (aka 6u3).glewis2007-11-162-18/+16 * . Update to tzupdater 1.3.0 to fix the default build (the previous versionglewis2007-11-1610-28/+30 * . Chase the eclipse-emf upgrade.glewis2007-11-075-5/+5 * - Update to 6.0.6miwi2007-11-052-4/+4 * Change Java dependency to the lowest non-deprecated version.brueffer2007-11-021-1/+1 * Does not work with Java 1.6. the JVMPI interface used by this port haslinimon2007-10-291-1/+1 * . Update to patchset 2 (based on 1.6.0_02 aka 6u2)glewis2007-10-2916-942/+48 * Update to 3.1 release.ale2007-10-283-31/+19 * Remove 1.1 and 1.2 as supported Java versions. They are going away.linimon2007-10-281-1/+1 * - Only support emacs22 (cedet only does that as far as I can see)pav2007-10-281-14/+3 * Adding a port of the Sun Java Runtime Environment 1.6 for Linux.jkim2007-10-277-0/+944