aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2016-08-04 23:21:41 +0800
committerkevlo <kevlo@FreeBSD.org>2016-08-04 23:21:41 +0800
commit7ebacf465703973fd38fe30719aa3fc87f6451a8 (patch)
tree706369ee666d38f8817cb8e7a04a2012ffa5d701 /astro
parent960eb0877de3374a06812e5571da93b7c8da589c (diff)
downloadfreebsd-ports-gnome-7ebacf465703973fd38fe30719aa3fc87f6451a8.tar.gz
freebsd-ports-gnome-7ebacf465703973fd38fe30719aa3fc87f6451a8.tar.zst
freebsd-ports-gnome-7ebacf465703973fd38fe30719aa3fc87f6451a8.zip
Import py-pywapi 0.3.8
The pywapi module provides a python wrapper around the Yahoo! Weather, Weather.com and NOAA APIs.
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/py-pywapi/Makefile28
-rw-r--r--astro/py-pywapi/distinfo3
-rw-r--r--astro/py-pywapi/pkg-descr4
4 files changed, 36 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 8006d95d634c..7483cf4cf132 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -84,6 +84,7 @@
SUBDIR += py-astropy
SUBDIR += py-pyfits
SUBDIR += py-pymetar
+ SUBDIR += py-pywapi
SUBDIR += pyephem
SUBDIR += pyweather
SUBDIR += qlandkartegt
diff --git a/astro/py-pywapi/Makefile b/astro/py-pywapi/Makefile
new file mode 100644
index 000000000000..d2931dff08f5
--- /dev/null
+++ b/astro/py-pywapi/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= pywapi
+PORTVERSION= 0.3.8
+CATEGORIES= astro python
+MASTER_SITES= http://launchpad.net/python-weather-api/trunk/${PORTVERSION}/+download/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kevlo@FreeBSD.org
+COMMENT= Python wrapper around different weather APIs
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= distutils autoplist
+
+EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+PORTEXAMPLES= *
+
+OPTIONS_DEFINE= EXAMPLES
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
+
+.include <bsd.port.mk>
diff --git a/astro/py-pywapi/distinfo b/astro/py-pywapi/distinfo
new file mode 100644
index 000000000000..d8241c3ebaf4
--- /dev/null
+++ b/astro/py-pywapi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1470322438
+SHA256 (pywapi-0.3.8.tar.gz) = 3167e9864a6924870cb674743dc35352379d8af772280dfe2b35a00e940a4588
+SIZE (pywapi-0.3.8.tar.gz) = 25166
diff --git a/astro/py-pywapi/pkg-descr b/astro/py-pywapi/pkg-descr
new file mode 100644
index 000000000000..a230adc5c1bb
--- /dev/null
+++ b/astro/py-pywapi/pkg-descr
@@ -0,0 +1,4 @@
+The pywapi module provides a python wrapper around the Yahoo! Weather,
+Weather.com and NOAA APIs.
+
+WWW: https://code.google.com/archive/p/python-weather-api/