aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-04 04:22:16 +0800
committeradamw <adamw@FreeBSD.org>2014-07-04 04:22:16 +0800
commitf62ac3a0a5b53834b614178afcebeb2a6f0e386f (patch)
tree4d6545ed4bbfe77f0a67be711d86034f2bef8ed4 /astro
parentf8473fc44d4a0389299091429f5719e7e96f12ce (diff)
downloadfreebsd-ports-gnome-f62ac3a0a5b53834b614178afcebeb2a6f0e386f.tar.gz
freebsd-ports-gnome-f62ac3a0a5b53834b614178afcebeb2a6f0e386f.tar.zst
freebsd-ports-gnome-f62ac3a0a5b53834b614178afcebeb2a6f0e386f.zip
The do-install logic didn't work with stage.
Diffstat (limited to 'astro')
-rw-r--r--astro/ephem/Makefile14
-rw-r--r--astro/ephem/pkg-plist8
2 files changed, 11 insertions, 11 deletions
diff --git a/astro/ephem/Makefile b/astro/ephem/Makefile
index 479b62cd27ef..a73ddd77a7ef 100644
--- a/astro/ephem/Makefile
+++ b/astro/ephem/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ephem
PORTVERSION= 4.28
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= trevor
@@ -17,14 +18,13 @@ ALL_TARGET=
CFLAGS+= -Wno-implicit -Wno-return-type
do-install:
- -cd ${WRKSRC}; \
- ${INSTALL_PROGRAM} ephem ${STAGEDIR}${PREFIX}/bin; \
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/ephem; \
- ${INSTALL_DATA} Man.txt ${STAGEDIR}${PREFIX}/share/ephem/; \
- [ ! -f ${PREFIX}/share/ephem/ephem.db ] && ${INSTALL_DATA} ephem.db ${STAGEDIR}${PREFIX}/share/ephem/; \
- [ ! -f ${PREFIX}/share/ephem/ephem.cfg ] && ${INSTALL_DATA} ephem.cfg ${STAGEDIR}${PREFIX}/share/ephem/
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/ephem ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/Man.txt ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/ephem.cfg ${STAGEDIR}${DATADIR}/ephem.cfg.sample
+ ${INSTALL_DATA} ${WRKSRC}/ephem.db ${STAGEDIR}${DATADIR}/ephem.db.sample
post-install:
- @${ECHO_MSG} Don\'t forget to edit ${PREFIX}/share/ephem/ephem.cfg!
+ @${ECHO_MSG} "Don't forget to edit ${PREFIX}/share/ephem/ephem.cfg!"
.include <bsd.port.mk>
diff --git a/astro/ephem/pkg-plist b/astro/ephem/pkg-plist
index 73c19595390c..44970e8ec72a 100644
--- a/astro/ephem/pkg-plist
+++ b/astro/ephem/pkg-plist
@@ -1,5 +1,5 @@
bin/ephem
-share/ephem/Man.txt
-share/ephem/ephem.cfg
-share/ephem/ephem.db
-@dirrm share/ephem
+%%DATADIR%%/Man.txt
+@sample %%DATADIR%%/ephem.cfg.sample
+@sample %%DATADIR%%/ephem.db.sample
+@dirrm %%DATADIR%%