aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2015-06-23 02:33:20 +0800
committerantoine <antoine@FreeBSD.org>2015-06-23 02:33:20 +0800
commita271c81a691520343b54826252aba0c2600e31ab (patch)
treebdb6dbf3e5d4ada04784a3327eb91e0145530524 /astro
parent19ea8e358e68f9d94cca6a73917529e296948d19 (diff)
downloadfreebsd-ports-gnome-a271c81a691520343b54826252aba0c2600e31ab.tar.gz
freebsd-ports-gnome-a271c81a691520343b54826252aba0c2600e31ab.tar.zst
freebsd-ports-gnome-a271c81a691520343b54826252aba0c2600e31ab.zip
Convert to USES=jpeg
Diffstat (limited to 'astro')
-rw-r--r--astro/astrometry/Makefile3
-rw-r--r--astro/boinc-astropulse/Makefile2
-rw-r--r--astro/boinc-setiathome-v7/Makefile2
-rw-r--r--astro/celestia/Makefile5
-rw-r--r--astro/openuniverse/Makefile4
-rw-r--r--astro/sunclock/Makefile4
-rw-r--r--astro/xephem/Makefile5
-rw-r--r--astro/xplanet/Makefile2
8 files changed, 11 insertions, 16 deletions
diff --git a/astro/astrometry/Makefile b/astro/astrometry/Makefile
index 288484c46eb6..1dd89f2744e6 100644
--- a/astro/astrometry/Makefile
+++ b/astro/astrometry/Makefile
@@ -16,12 +16,11 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${PYNUMPY}
LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
libcfitsio.so:${PORTSDIR}/astro/cfitsio \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng.so:${PORTSDIR}/graphics/png \
libnetpbm.so:${PORTSDIR}/graphics/netpbm
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= gmake pkgconfig python tar:bzip2
+USES= gmake jpeg pkgconfig python tar:bzip2
USE_LDCONFIG= ${PREFIX}/${PORTNAME}/lib
ALL_TARGET= all extra
MAKE_ENV= INSTALL_DIR=${STAGEDIR}${PREFIX}/${PORTNAME}
diff --git a/astro/boinc-astropulse/Makefile b/astro/boinc-astropulse/Makefile
index 90582446716d..830c34b298cd 100644
--- a/astro/boinc-astropulse/Makefile
+++ b/astro/boinc-astropulse/Makefile
@@ -37,7 +37,7 @@ X11_DESC= Build screensaver (requires net/boinc-client with X11)
OPTIONS_SUB= yes
X11_BUILD_DEPENDS= ${LOCALBASE}/lib/libboinc_graphics2.a:${PORTSDIR}/net/boinc-client
-X11_LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
+X11_USES= jpeg
X11_USE= GL=gl,glu,glut \
XORG=ice,sm,x11,xau,xcb,xext,xi,xdamage,xdmcp,xfixes,xmu,xt,xxf86vm
X11_CONFIGURE_ENABLE= graphics
diff --git a/astro/boinc-setiathome-v7/Makefile b/astro/boinc-setiathome-v7/Makefile
index 892905baa051..54182fb4da35 100644
--- a/astro/boinc-setiathome-v7/Makefile
+++ b/astro/boinc-setiathome-v7/Makefile
@@ -40,7 +40,7 @@ X11_DESC= Build screensaver (requires net/boinc-client with X11)
OPTIONS_SUB= yes
X11_BUILD_DEPENDS= ${LOCALBASE}/lib/libboinc_graphics2.a:${PORTSDIR}/net/boinc-client
-X11_LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
+X11_USES= jpeg
X11_USE= GL=gl,glu,glut \
XORG=ice,sm,x11,xau,xcb,xext,xi,xdamage,xdmcp,xfixes,xmu,xt,xxf86vm
X11_CONFIGURE_ENABLE= graphics
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index d03e120509a4..16153975ad5c 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -13,10 +13,9 @@ COMMENT= Scriptable space flight simulator for X11
LICENSE= GPLv2
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
-USES= gettext gmake libtool lua pkgconfig
+USES= gettext gmake jpeg libtool lua pkgconfig
USE_GL= gl
GNU_CONFIGURE= yes
EXTRA_PATCHES= ${FILESDIR}/celestia-1.6.1-lua-5.2.patch:-p1 \
diff --git a/astro/openuniverse/Makefile b/astro/openuniverse/Makefile
index b2f2741cc2e9..e1a1328fb1a9 100644
--- a/astro/openuniverse/Makefile
+++ b/astro/openuniverse/Makefile
@@ -10,11 +10,9 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/1.0beta3
MAINTAINER= ports@FreeBSD.org
COMMENT= OpenGL Solar System simulator for X Window System
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
-
USE_GL= glut
-USES= gmake
+USES= gmake jpeg
USE_XORG= sm ice xmu xi xext x11
GNU_CONFIGURE= yes
diff --git a/astro/sunclock/Makefile b/astro/sunclock/Makefile
index 0c31592d61e5..248fd83ea5c7 100644
--- a/astro/sunclock/Makefile
+++ b/astro/sunclock/Makefile
@@ -13,11 +13,11 @@ COMMENT= Shows which portion of the Earth's surface is illuminated by the Sun
LICENSE= GPLv2
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USES= jpeg
USE_XORG= xpm
CPPFLAGS+= $$(libpng-config --I_opts) \
diff --git a/astro/xephem/Makefile b/astro/xephem/Makefile
index 2f125fbb35a2..6fb0e53f9099 100644
--- a/astro/xephem/Makefile
+++ b/astro/xephem/Makefile
@@ -10,10 +10,9 @@ MASTER_SITES= # http://www.clearskyinstitute.com/xephem/
MAINTAINER= jpaetzel@FreeBSD.org
COMMENT= Interactive astronomical ephemeris program
-LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
- libjpeg.so:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
-USES= gmake motif
+USES= gmake jpeg motif
LDFLAGS+= -lfontconfig
USE_XORG= xp xt xext xmu x11 xft
MAKE_JOBS_UNSAFE= yes
diff --git a/astro/xplanet/Makefile b/astro/xplanet/Makefile
index e44c75c0d732..72be1540b0c3 100644
--- a/astro/xplanet/Makefile
+++ b/astro/xplanet/Makefile
@@ -27,7 +27,7 @@ PANGO_USE= GNOME=pango
GIF_CONFIGURE_WITH= gif
GIF_LIB_DEPENDS= libgif.so:${PORTSDIR}/graphics/giflib
JPEG_CONFIGURE_WITH= jpeg
-JPEG_LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
+JPEG_USES= jpeg
PNG_CONFIGURE_WITH= png
PNG_LIB_DEPENDS+= libpng.so:${PORTSDIR}/graphics/png
PNM_CONFIGURE_WITH= pnm