aboutsummaryrefslogtreecommitdiffstats
path: root/audio/abraca
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2011-05-14 00:39:32 +0800
committerbeech <beech@FreeBSD.org>2011-05-14 00:39:32 +0800
commitb5a4d5853c0cd5300fbdd199ee390586af77e724 (patch)
tree5bb9f7ff2f4750a1c2d3f3c46ca7833a750649f7 /audio/abraca
parentec8f88a19e4b48a67c64ac96163e999dc5b23881 (diff)
downloadfreebsd-ports-gnome-b5a4d5853c0cd5300fbdd199ee390586af77e724.tar.gz
freebsd-ports-gnome-b5a4d5853c0cd5300fbdd199ee390586af77e724.tar.zst
freebsd-ports-gnome-b5a4d5853c0cd5300fbdd199ee390586af77e724.zip
-Update to 0.6.0
-Pass maintainership to submitter PR: ports/156685 Submitted by: Guido Falsi <mad@madpilot.net> Approved by: Olivier Smedts <olivier@gid0.org> (maintainer) itetcu (mentor)(implicit)
Diffstat (limited to 'audio/abraca')
-rw-r--r--audio/abraca/Makefile7
-rw-r--r--audio/abraca/distinfo4
-rw-r--r--audio/abraca/files/patch-src-components-collections-collections_view.vala23
-rw-r--r--audio/abraca/files/patch-src-components-playlist-playlist_model.vala14
-rw-r--r--audio/abraca/files/patch-src-medialib.vala19
5 files changed, 24 insertions, 43 deletions
diff --git a/audio/abraca/Makefile b/audio/abraca/Makefile
index 630fd9bd94e9..443039f3296b 100644
--- a/audio/abraca/Makefile
+++ b/audio/abraca/Makefile
@@ -6,18 +6,17 @@
#
PORTNAME= abraca
-PORTVERSION= 0.5.0
+PORTVERSION= 0.6.0
CATEGORIES= audio
-MASTER_SITES= http://abraca.xmms.se/attachments/download/128/
+MASTER_SITES= http://abraca.xmms.se/attachments/download/134/
-MAINTAINER= olivier@gid0.org
+MAINTAINER= mad@madpilot.net
COMMENT= Abraca is a GTK2 client for the XMMS2 music player
BUILD_DEPENDS= ${LOCALBASE}/bin/valac:${PORTSDIR}/lang/vala
LIB_DEPENDS= xmmsclient.6:${PORTSDIR}/audio/xmms2 \
gee.2:${PORTSDIR}/devel/libgee
-USE_BZIP2= yes
USE_SCONS= yes
USE_GNOME= gtk20
diff --git a/audio/abraca/distinfo b/audio/abraca/distinfo
index 925d2ea98d19..140a25fa5446 100644
--- a/audio/abraca/distinfo
+++ b/audio/abraca/distinfo
@@ -1,2 +1,2 @@
-SHA256 (abraca-0.5.0.tar.bz2) = c4caf88e9c0c8d5d51ac5c0df4cc9022a0aa2574a4ff791dea11c7e212b766e2
-SIZE (abraca-0.5.0.tar.bz2) = 402497
+SHA256 (abraca-0.6.0.tar.gz) = ff40ab90904036e9493658b446c1251135a2f507f9c00e2c7cf115db21a6be75
+SIZE (abraca-0.6.0.tar.gz) = 403184
diff --git a/audio/abraca/files/patch-src-components-collections-collections_view.vala b/audio/abraca/files/patch-src-components-collections-collections_view.vala
index 433aa0e90cc2..e69de29bb2d1 100644
--- a/audio/abraca/files/patch-src-components-collections-collections_view.vala
+++ b/audio/abraca/files/patch-src-components-collections-collections_view.vala
@@ -1,23 +0,0 @@
---- src/components/collections/collections_view.vala.orig 2010-04-03 04:19:53.000000000 +0200
-+++ src/components/collections/collections_view.vala 2010-11-12 20:11:48.471315596 +0100
-@@ -441,16 +441,11 @@
- Gtk.TreePath path = model.get_path(iter);
-
- if (path.get_depth() == 2) {
-- unowned GLib.List<Gtk.CellRenderer> renderers;
-- Gtk.CellRendererText renderer;
-- GLib.List<unowned Gtk.TreeViewColumn> cols;
-- Gtk.TreeViewColumn col;
-+ var cols = get_columns();
-+ var col = cols.data;
-
-- cols = get_columns();
-- col = cols.data;
--
-- renderers = col.get_cells();
-- renderer = (Gtk.CellRendererText) renderers.data;
-+ var renderers = col.get_cells();
-+ var renderer = (Gtk.CellRendererText) renderers.data;
-
- renderer.editable = true;
- set_cursor_on_cell(path, col, renderer, true);
diff --git a/audio/abraca/files/patch-src-components-playlist-playlist_model.vala b/audio/abraca/files/patch-src-components-playlist-playlist_model.vala
index e47d1c30a53e..e69de29bb2d1 100644
--- a/audio/abraca/files/patch-src-components-playlist-playlist_model.vala
+++ b/audio/abraca/files/patch-src-components-playlist-playlist_model.vala
@@ -1,14 +0,0 @@
---- src/components/playlist/playlist_model.vala.orig 2010-04-03 04:19:53.000000000 +0200
-+++ src/components/playlist/playlist_model.vala 2010-11-21 22:17:26.000000000 +0100
-@@ -136,9 +136,9 @@
- if (iter_nth_child (out iter, null, pos) &&
- iter_nth_child(out niter, null, npos)) {
- if (pos < npos) {
-- move_after (iter, niter);
-+ move_after (ref iter, niter);
- } else {
-- move_before (iter, niter);
-+ move_before (ref iter, niter);
- }
- }
- }
diff --git a/audio/abraca/files/patch-src-medialib.vala b/audio/abraca/files/patch-src-medialib.vala
new file mode 100644
index 000000000000..aad625a18a38
--- /dev/null
+++ b/audio/abraca/files/patch-src-medialib.vala
@@ -0,0 +1,19 @@
+--- src/medialib.vala.orig 2011-01-22 18:16:43.000000000 +0100
++++ src/medialib.vala 2011-05-11 15:02:36.000000000 +0200
+@@ -588,14 +588,14 @@
+ close.connect(on_close);
+ response.connect(on_response);
+
+- Configurable.register(this);
++/* Configurable.register(this); */
+ show_all();
+ }
+
+
+ private void on_close (Gtk.Dialog dialog)
+ {
+- Configurable.unregister(this);
++/* Configurable.unregister(this); */
+ }
+
+