aboutsummaryrefslogtreecommitdiffstats
path: root/audio/abraca
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-03-09 08:40:46 +0800
committermadpilot <madpilot@FreeBSD.org>2013-03-09 08:40:46 +0800
commitf45e446c076fcab4b213d3b3baeaa54ffd43b3b1 (patch)
tree164a016b59572c7aa4c378637457c8be1ab5b521 /audio/abraca
parenta7d5b93f64777d884098d353cf47c86639f12815 (diff)
downloadfreebsd-ports-gnome-f45e446c076fcab4b213d3b3baeaa54ffd43b3b1.tar.gz
freebsd-ports-gnome-f45e446c076fcab4b213d3b3baeaa54ffd43b3b1.tar.zst
freebsd-ports-gnome-f45e446c076fcab4b213d3b3baeaa54ffd43b3b1.zip
- Update to 0.7.1
- Shorten COMMENT
Diffstat (limited to 'audio/abraca')
-rw-r--r--audio/abraca/Makefile5
-rw-r--r--audio/abraca/distinfo4
-rw-r--r--audio/abraca/files/patch-src_components_collections_collections_model.vala29
3 files changed, 33 insertions, 5 deletions
diff --git a/audio/abraca/Makefile b/audio/abraca/Makefile
index 58451878a411..fcf349a01150 100644
--- a/audio/abraca/Makefile
+++ b/audio/abraca/Makefile
@@ -2,13 +2,12 @@
# $FreeBSD$
PORTNAME= abraca
-PORTVERSION= 0.7.0
-PORTREVISION= 2
+PORTVERSION= 0.7.1
CATEGORIES= audio
MASTER_SITES= http://cloud.github.com/downloads/Abraca/Abraca/
MAINTAINER= madpilot@FreeBSD.org
-COMMENT= Abraca is a GTK2 client for the XMMS2 music player
+COMMENT= GTK2 client for the XMMS2 music player
BUILD_DEPENDS= ${LOCALBASE}/bin/valac:${PORTSDIR}/lang/vala
LIB_DEPENDS= xmmsclient:${PORTSDIR}/audio/xmms2 \
diff --git a/audio/abraca/distinfo b/audio/abraca/distinfo
index 652e4da186a1..a8666b0ef42f 100644
--- a/audio/abraca/distinfo
+++ b/audio/abraca/distinfo
@@ -1,2 +1,2 @@
-SHA256 (abraca-0.7.0.tar.gz) = 4004e0aa2ec1e8422d3748e1bacb99d71823d0d5a4226c55771252cc6948ec27
-SIZE (abraca-0.7.0.tar.gz) = 684007
+SHA256 (abraca-0.7.1.tar.gz) = d8e5853f86f180701bc0ebaa1172541b1aab3b07703881519cd3866102977036
+SIZE (abraca-0.7.1.tar.gz) = 684007
diff --git a/audio/abraca/files/patch-src_components_collections_collections_model.vala b/audio/abraca/files/patch-src_components_collections_collections_model.vala
new file mode 100644
index 000000000000..08b8331c1180
--- /dev/null
+++ b/audio/abraca/files/patch-src_components_collections_collections_model.vala
@@ -0,0 +1,29 @@
+--- src/components/collections/collections_model.vala.orig 2012-06-17 19:04:56.000000000 +0200
++++ src/components/collections/collections_model.vala 2013-03-08 16:25:01.542854653 +0100
+@@ -157,7 +157,7 @@
+ */
+ public void remove_temporary_playlist ()
+ {
+- remove(_temporary_playlist_iter);
++ remove(ref _temporary_playlist_iter);
+ has_temporary_playlist = false;
+ }
+
+@@ -258,7 +258,7 @@
+ }
+
+ while (iter_children(out child, parent)) {
+- remove(child);
++ remove(ref child);
+ }
+
+ int pos = iter_n_children(parent);
+@@ -433,7 +433,7 @@
+
+ get(iter, Column.Name, out current);
+ if (name == current) {
+- remove(iter);
++ remove(ref iter);
+ break;
+ }
+ } while (iter_next(ref iter));