aboutsummaryrefslogtreecommitdiffstats
path: root/audio/alsa-lib
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-04-02 04:44:23 +0800
committerjbeich <jbeich@FreeBSD.org>2016-04-02 04:44:23 +0800
commite573b5d26f204c6a5fda8e70fae7d9a6117e875b (patch)
tree5b400f05d5e20266cffa307033a7809a07cde218 /audio/alsa-lib
parent6c71428892f70d198ed1b6e1166cf5a174dd71c3 (diff)
downloadfreebsd-ports-gnome-e573b5d26f204c6a5fda8e70fae7d9a6117e875b.tar.gz
freebsd-ports-gnome-e573b5d26f204c6a5fda8e70fae7d9a6117e875b.tar.zst
freebsd-ports-gnome-e573b5d26f204c6a5fda8e70fae7d9a6117e875b.zip
audio/alsa-*: update to 1.1.1
Changes: http://www.alsa-project.org/main/index.php/Changes_v1.1.0_v1.1.1 ABI: https://people.freebsd.org/~jbeich/compat_reports/alsa-lib/1.1.0_to_1.1.1/compat_report.html
Diffstat (limited to 'audio/alsa-lib')
-rw-r--r--audio/alsa-lib/Makefile2
-rw-r--r--audio/alsa-lib/distinfo4
-rw-r--r--audio/alsa-lib/files/patch-src__timer__timer_hw.c15
-rw-r--r--audio/alsa-lib/files/patch-src_topology_parser.c10
4 files changed, 3 insertions, 28 deletions
diff --git a/audio/alsa-lib/Makefile b/audio/alsa-lib/Makefile
index 3953d32d396f..f0e4768ec8eb 100644
--- a/audio/alsa-lib/Makefile
+++ b/audio/alsa-lib/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= alsa-lib
-PORTVERSION= 1.1.0
+PORTVERSION= 1.1.1
CATEGORIES= audio
MASTER_SITES= ALSA/lib \
GENTOO
diff --git a/audio/alsa-lib/distinfo b/audio/alsa-lib/distinfo
index 9c08cc676bef..20ba1b9360a8 100644
--- a/audio/alsa-lib/distinfo
+++ b/audio/alsa-lib/distinfo
@@ -1,2 +1,2 @@
-SHA256 (alsa-lib-1.1.0.tar.bz2) = dfde65d11e82b68f82e562ab6228c1fb7c78854345d3c57e2c68a9dd3dae1f15
-SIZE (alsa-lib-1.1.0.tar.bz2) = 929874
+SHA256 (alsa-lib-1.1.1.tar.bz2) = 8ac76c3144ed2ed49da7622ab65ac5415205913ccbedde877972383cbc234269
+SIZE (alsa-lib-1.1.1.tar.bz2) = 932105
diff --git a/audio/alsa-lib/files/patch-src__timer__timer_hw.c b/audio/alsa-lib/files/patch-src__timer__timer_hw.c
deleted file mode 100644
index 8f21d3cd4139..000000000000
--- a/audio/alsa-lib/files/patch-src__timer__timer_hw.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/timer/timer_hw.c~
-+++ src/timer/timer_hw.c
-@@ -91,10 +91,12 @@ static int snd_timer_hw_async(snd_timer_
- }
- if (sig < 0)
- return 0;
-+#ifdef F_SETSIG
- if (fcntl(fd, F_SETSIG, (long)sig) < 0) {
- SYSERR("F_SETSIG failed");
- return -errno;
- }
-+#endif
- if (fcntl(fd, F_SETOWN, (long)pid) < 0) {
- SYSERR("F_SETOWN failed");
- return -errno;
diff --git a/audio/alsa-lib/files/patch-src_topology_parser.c b/audio/alsa-lib/files/patch-src_topology_parser.c
deleted file mode 100644
index 30338b65d30f..000000000000
--- a/audio/alsa-lib/files/patch-src_topology_parser.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/topology/parser.c.orig 2015-11-09 07:39:18 UTC
-+++ src/topology/parser.c
-@@ -18,6 +18,7 @@
-
- #include "list.h"
- #include "tplg_local.h"
-+#include <sys/stat.h>
-
- /*
- * Parse compound