aboutsummaryrefslogtreecommitdiffstats
path: root/audio/alsa-lib
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2013-12-14 22:41:17 +0800
committerflo <flo@FreeBSD.org>2013-12-14 22:41:17 +0800
commit3947f6800c605ea5aac1ccb95204b381cbecf846 (patch)
tree3c3536c4cd313fac086be7f8987b4636a3393e80 /audio/alsa-lib
parent27ce45e14623983a2a508dd222c66d06ac8c8600 (diff)
downloadfreebsd-ports-gnome-3947f6800c605ea5aac1ccb95204b381cbecf846.tar.gz
freebsd-ports-gnome-3947f6800c605ea5aac1ccb95204b381cbecf846.tar.zst
freebsd-ports-gnome-3947f6800c605ea5aac1ccb95204b381cbecf846.zip
- ALSA now supports playing HTML5 audio with 32-bit sample format [1]
after being converted from float as passed by firefox/libcubeb [2] - Restore behavior from r296140 while adding alignment options in case of issues. This should make things slightly less broken and add more sample formats. [1] - Some apps (e.g. linux-firefox with ports/169896) don't check with ALSA which sample formats are supported and just feed whatever they like, assuming the underlying device supports it. While here also fix mixer device for OSS plugin. It should be /dev/dsp according to 4Front OSS wiki. The only works with ARIFF_OSS enabled but the volume is reset on close(). audio/oss doesn't work either way: the new (OSSv4) way to control mixer is via SNDCTL_MIX_* ioctls. [2] PR: ports/183861 [1] PR: ports/184006 [2] Submitted by: Jan Beich <jbeich@tormail.org> Approved by: maintainer timeout
Diffstat (limited to 'audio/alsa-lib')
-rw-r--r--audio/alsa-lib/Makefile1
-rw-r--r--audio/alsa-lib/files/asound.conf.sample49
2 files changed, 37 insertions, 13 deletions
diff --git a/audio/alsa-lib/Makefile b/audio/alsa-lib/Makefile
index 030d5634857b..effab3ca5129 100644
--- a/audio/alsa-lib/Makefile
+++ b/audio/alsa-lib/Makefile
@@ -3,6 +3,7 @@
PORTNAME= alsa-lib
PORTVERSION= 1.0.27.2
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ALSA/lib \
GENTOO/distfiles
diff --git a/audio/alsa-lib/files/asound.conf.sample b/audio/alsa-lib/files/asound.conf.sample
index 8b412a542051..f6fb895f08a1 100644
--- a/audio/alsa-lib/files/asound.conf.sample
+++ b/audio/alsa-lib/files/asound.conf.sample
@@ -1,42 +1,65 @@
#
# FreeBSD/OSS
#
+pcm_slave.oss {
+ pcm.type oss
+}
+
pcm.!default {
- type oss
- device /dev/dsp
+ type plug
+ slave oss
}
ctl.!default {
type oss
- device /dev/mixer
}
#
# Remap all possible surround stuffs.
#
+pcm.!front {
+ type plug
+ slave oss
+}
+
+pcm.!rear {
+ type plug
+ slave oss
+}
+
+pcm.!center_lfe {
+ type plug
+ slave oss
+}
+
+pcm.!side {
+ type plug
+ slave oss
+}
+
pcm.!surround40 {
- type oss
- device /dev/dsp
+ type plug
+ slave oss
}
pcm.!surround41 {
- type oss
- device /dev/dsp
+ type plug
+ slave oss
}
pcm.!surround50 {
- type oss
- device /dev/dsp
+ type plug
+ slave oss
}
pcm.!surround51 {
- type oss
- device /dev/dsp
+ type plug
+ slave oss
}
pcm.!surround71 {
- type oss
- device /dev/dsp
+ type plug
+ slave oss
}
#