aboutsummaryrefslogtreecommitdiffstats
path: root/audio/amarok-kde4
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-05-04 15:19:42 +0800
committerpav <pav@FreeBSD.org>2009-05-04 15:19:42 +0800
commit539370b9ebed05d04c8ddc9a420245c5c9a30492 (patch)
tree4209ffa5747f28a57d4fe789ef22b5b3eff9b90d /audio/amarok-kde4
parent08ee9ff1dab51994a9bba69035c06c5b2813419c (diff)
downloadfreebsd-ports-gnome-539370b9ebed05d04c8ddc9a420245c5c9a30492.tar.gz
freebsd-ports-gnome-539370b9ebed05d04c8ddc9a420245c5c9a30492.tar.zst
freebsd-ports-gnome-539370b9ebed05d04c8ddc9a420245c5c9a30492.zip
- Fix last.fm support
PR: ports/133718 Submitted by: Eugene M. Zheganin <emz@norma.perm.ru> Approved by: Matt <datahead4@gmail.com> (maintainer)
Diffstat (limited to 'audio/amarok-kde4')
-rw-r--r--audio/amarok-kde4/Makefile2
-rw-r--r--audio/amarok-kde4/files/patch-last.fm34
2 files changed, 35 insertions, 1 deletions
diff --git a/audio/amarok-kde4/Makefile b/audio/amarok-kde4/Makefile
index 592da48f99af..23e8084f2c9a 100644
--- a/audio/amarok-kde4/Makefile
+++ b/audio/amarok-kde4/Makefile
@@ -6,7 +6,7 @@
PORTNAME= amarok
PORTVERSION= 2.0.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTNAME}/${PORTVERSION}/src
diff --git a/audio/amarok-kde4/files/patch-last.fm b/audio/amarok-kde4/files/patch-last.fm
new file mode 100644
index 000000000000..cb47d0ad6ebd
--- /dev/null
+++ b/audio/amarok-kde4/files/patch-last.fm
@@ -0,0 +1,34 @@
+--- src/services/lastfm/LastFmServiceSettings.cpp
++++ src/services/lastfm/LastFmServiceSettings.cpp
+@@ -94,14 +94,12 @@
+ debug() << "username:" << QString( QUrl::toPercentEncoding( Ws::Username ) );
+
+ QString authToken = md5( ( m_configDialog->kcfg_ScrobblerUsername->text() + md5( m_configDialog->kcfg_ScrobblerPassword->text().toUtf8() ) ).toUtf8() );
+- QString sign_key = md5( ( "api_key" + QString( Ws::ApiKey ) + "authToken" + authToken + "methodauth.getMobileSession" + QString( Ws::SharedSecret ) ).toUtf8() );
+
+ // now authenticate w/ last.fm and get our session key
+ WsReply* reply = WsRequestBuilder( "auth.getMobileSession" )
+ .add( "username", m_configDialog->kcfg_ScrobblerUsername->text() )
+ .add( "authToken", authToken )
+ .add( "api_key", Ws::ApiKey )
+- .add( "api_sig", sign_key )
+ .get();
+
+ connect( reply, SIGNAL( finished( WsReply* ) ), SLOT( onAuthenticated( WsReply* ) ) );
+--- src/services/lastfm/LastFmService.cpp
++++ src/services/lastfm/LastFmService.cpp
+@@ -115,14 +115,12 @@
+ debug() << "username:" << QString( QUrl::toPercentEncoding( Ws::Username ) );
+
+ QString authToken = md5( ( m_userName + md5( password.toUtf8() ) ).toUtf8() );
+- QString sign_key = md5( ( "api_key" + QString( Ws::ApiKey ) + "authToken" + authToken + "methodauth.getMobileSession" + QString( Ws::SharedSecret ) ).toUtf8() );
+
+ // now authenticate w/ last.fm and get our session key
+ WsReply* reply = WsRequestBuilder( "auth.getMobileSession" )
+ .add( "username", m_userName )
+ .add( "authToken", authToken )
+ .add( "api_key", Ws::ApiKey )
+- .add( "api_sig", sign_key )
+ .get();
+
+ connect( reply, SIGNAL( finished( WsReply* ) ), SLOT( onAuthenticated( WsReply* ) ) );