aboutsummaryrefslogtreecommitdiffstats
path: root/audio/amarok-kde4
diff options
context:
space:
mode:
authormich <mich@FreeBSD.org>2007-03-08 00:17:21 +0800
committermich <mich@FreeBSD.org>2007-03-08 00:17:21 +0800
commitdf699d6f8d0833a1c225a91bc487325622d66aae (patch)
tree7332da9254dc070c71a921d917c03f1c38159852 /audio/amarok-kde4
parentdfbc085a11f5d841596ae003c5ff30d21f988c38 (diff)
downloadfreebsd-ports-gnome-df699d6f8d0833a1c225a91bc487325622d66aae.tar.gz
freebsd-ports-gnome-df699d6f8d0833a1c225a91bc487325622d66aae.tar.zst
freebsd-ports-gnome-df699d6f8d0833a1c225a91bc487325622d66aae.zip
- fix PLIST after libmtp support is working again
- Fix detection of msdosfs/vfat [1] PR: ports/109111 [1] Submitted by: Bartosz Fabianowski <freebsd@chillt.de> [1]
Diffstat (limited to 'audio/amarok-kde4')
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_mediadevice_generic_genericmediadevice.cpp18
-rw-r--r--audio/amarok-kde4/pkg-plist4
2 files changed, 22 insertions, 0 deletions
diff --git a/audio/amarok-kde4/files/patch-amarok_src_mediadevice_generic_genericmediadevice.cpp b/audio/amarok-kde4/files/patch-amarok_src_mediadevice_generic_genericmediadevice.cpp
new file mode 100644
index 000000000000..be021742b252
--- /dev/null
+++ b/audio/amarok-kde4/files/patch-amarok_src_mediadevice_generic_genericmediadevice.cpp
@@ -0,0 +1,18 @@
+--- amarok/src/mediadevice/generic/genericmediadevice.cpp.orig Mon Feb 12 23:01:20 2007
++++ amarok/src/mediadevice/generic/genericmediadevice.cpp Mon Feb 12 23:01:29 2007
+@@ -418,13 +418,7 @@
+ if( m_medium.mountPoint() == (*mountiter)->mountPoint() )
+ m_medium.setFsType( (*mountiter)->mountType() );
+ }
+- m_actuallyVfat = m_medium.fsType() ==
+-#ifdef __FreeBSD__
+- "msdosfs"
+-#else
+- "vfat"
+-#endif
+- ? true : false;
++ m_actuallyVfat = (m_medium.fsType() == "vfat" || m_medium.fsType() == "msdosfs") ? true : false;
+ m_connected = true;
+ m_transferDir = m_medium.mountPoint();
+ m_initialFile = new GenericMediaFile( 0, m_medium.mountPoint(), this );
+
diff --git a/audio/amarok-kde4/pkg-plist b/audio/amarok-kde4/pkg-plist
index 4d150af7bb7f..a76967685b24 100644
--- a/audio/amarok-kde4/pkg-plist
+++ b/audio/amarok-kde4/pkg-plist
@@ -16,6 +16,9 @@ lib/kde3/libamarok_daap-mediadevice.a
lib/kde3/libamarok_massstorage-device.so
lib/kde3/libamarok_massstorage-device.la
lib/kde3/libamarok_massstorage-device.a
+%%MTP%%lib/kde3/libamarok_mtp-mediadevice.so
+%%MTP%%lib/kde3/libamarok_mtp-mediadevice.la
+%%MTP%%lib/kde3/libamarok_mtp-mediadevice.a
lib/kde3/libamarok_nfs-device.so
lib/kde3/libamarok_nfs-device.la
lib/kde3/libamarok_nfs-device.a
@@ -1023,6 +1026,7 @@ share/locale/uk/LC_MESSAGES/amarok.mo
share/locale/uz/LC_MESSAGES/amarok.mo
share/locale/zh_CN/LC_MESSAGES/amarok.mo
share/locale/zh_TW/LC_MESSAGES/amarok.mo
+%%MTP%%share/services/amarok_mtp-mediadevice.desktop
%%NJB%%share/services/amarok_njb-mediadevice.desktop
share/services/amarokitpc.protocol
share/services/amaroklastfm.protocol